Você está offline; aguardando reconexão

Como calcular o número de meses entre duas datas no Excel

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

Para obter uma versão deste artigo referente ao Microsoft Excel 97 e versões anteriores, consulte 67093.

NESTA TAREFA

Sumário
Este artigo passo a passo mostra como calcular o número de meses entre duas datas.

Para calcular o número de meses entre duas datas, utilize um dos seguintes métodos. Tenha em atenção que os dois métodos utilizam as seguintes informações:
  • DATAM = Data Anterior
  • LDate = Data PosteriorNOTA: se escrever LDate ou DATAM directamente nesta fórmula em vez de a escrever nas referências das células apropriadas, terá de as colocar entre aspas (por exemplo, "9/7/00").
back to the top

Arredondar

Este método não utiliza o dia do mês nos seus cálculos. Por exemplo, considerando uma data de início de 31/10/10 e uma data de término de 02/11/10, o resultado apresentado é de um mês, embora só tenham passado dois dias.

Para este método, utilize a seguinte fórmula
=(ANO(LDate)-ANO(DATAM))*12+MESES(LDate)-MÊS(DATAM)
tal como apresentado no seguinte exemplo:
  1. Digite 31/10/10 na célula A1.
  2. Digite a fórmula a seguir na célula A2:
    =(ANO(AGORA())-ANO(A1))*12+MÊS(AGORA())-MÊS(A1)
    O número retornado é igual ao número de meses de 31/10/10 até a data de hoje, arredondado para o próximo número inteiro. 
back to the top

Arredondamento por defeito

Este método utiliza o número de dias para efetuar os cálculos e arredonda por defeito para o número mais próximo de meses completos. Por exemplo, considerando uma data de início a 30/10/10 e uma data de término de 30/11/10, o resultado apresentado é de um mês, no entanto, a data de término de 29/11/10 retorna um zero.

Para este método, utilize a seguinte fórmula
=SE(DIA(LDate)>=DIA(EDate),0,-1)+(ANO(LDate)-ANO(EDate))
*12+MÊS(LDate)-MÊS(EDate)
tal como apresentado no seguinte exemplo:
  1. Digite 31/10/10 na célula A1.
  2. Digite a seguinte fórmula na célula B1:
    =SE(DIA(AGORA))>=DIA(A1),0,-1)+(ANO(AGORA())-ANO(A1)) *12+MÊS(AGORA())-MÊS(A1)
    OBSERVAÇÃO: certifique-se de que a célula B1 está formatada como Geral. O número que é devolvido é igual ao número de meses de 31/10/10 até data de hoje, arredondado por defeito para o número mais próximo de meses completos.
back to the top
XL2007 XL2003  XL2010
Propriedades

ID do Artigo: 214134 - Última Revisão: 03/29/2013 16:08:00 - Revisão: 6.0

Microsoft Office Excel 2007, Microsoft Office Excel 2003, Microsoft Excel 2010

  • kbdatetime kbformula kbinfo kbhowtomaster KB214134
Comentários