Como usar as funções de planilha índice e CORRESP com vários critérios no Excel

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.

Clique aqui para ver a versão em Inglês deste artigo: 214142
Para obter um Microsoft Excel 98 e versão anterior deste artigo, consulte 59482.
Sumário
Este artigo oferece vários exemplos que usam as funções de planilha INDEX e MATCH no Microsoft Excel para localizar um valor com base em vários critérios.
Mais Informações
Os exemplos a seguir usam as funções de planilha índice e CORRESP para localizar um valor com base em vários critérios.

Exemplo 1: Dados em colunas

Método 1

  1. Inicie o Excel.
  2. Digite os seguintes dados em uma nova planilha:
       A1: Part   B1:  Code   C1:  Price   D1:  Find Part  E1:  Find Code   A2: x      B2:  11     C2:  5.00    D2:  y          E2:  12   A3: x      B3:  12     C3:  6.00    D3:  y          E3:  11   A4: y      B4:  11     C4:  7.00    D4:  x          E4:  12   A5: y      B5:  12     C5:  8.00    D5:  x          E5:  11					
  3. Para recuperar o preço de parte y com código 12 e returnthe o valor na célula F2, digite a seguinte fórmula na célula F2:
    =ÍNDICE($C$2:$C$5,CORRESP(D2,IF($B$2:$B$5=E2,$A$2:$A$5),0))
  4. Pressione CTRL + SHIFT + ENTER para inserir a fórmula como uma arrayformula.

    A fórmula retorna o valor 8.00.
  5. Selecione a célula F2, pegue a alça de preenchimento e, em seguida, preencher tocell F5 para recuperar o preço para cada combinação parte e código.

Método 2

Um segundo método produz os mesmos resultados, mas utiliza a concatenação em vez disso. A seguinte fórmula de exemplo pode ser melhor para dados com mais de dois critérios de correspondência, porque ele não precisa de instruções IF aninhadas. Esse método é idêntico ao método 1, exceto pelo fato de você substituir a fórmula na etapa 3 com a seguinte fórmula:
= INDEX($C$2:$C$5,MATCH(D2&E2,$A$2:$A$5&$B$2:$B$5,0))

Exemplo 2: Dados organizados em linhas

Método 1

  1. Inicie o Excel.
  2. Digite os seguintes dados em uma nova planilha:
       A1: Part        B1: x      C1: x     D1: y       E1: y   A2: Code        B2: 11     C2: 12    D2: 11      E2: 12   A3: Price       B3: 5.00   C3: 6.00  D3: 7.00    E3: 8.00   A4: Find Part   B4: y      C4: y     D4: x       E4: x   A5: Find Code   B5: 12     C5: 11    D5: 12      E5: 11					
  3. Para recuperar o preço de parte y com código 12 e returnthe o valor na célula B6, digite a seguinte fórmula na célula B6:
    = ÍNDICE($B$3:$E$3;CORRESP(B4;IF($B$2:$E$2=B5;$B$1:$E$1);0))
  4. Pressione CTRL + SHIFT + ENTER para inserir a fórmula como uma arrayformula.

    A fórmula retorna o valor 8.00.
  5. Selecione a célula B6, pegue a alça de preenchimento e, em seguida, preencher rightto célula E6 para recuperar o preço para cada combinação parte e código.

Método 2

Um segundo método produz os mesmos resultados, mas utiliza a concatenação em vez disso. A seguinte fórmula de exemplo pode ser melhor para dados com mais de dois critérios de correspondência, porque ele não precisa de instruções IF aninhadas. Esse método é idêntico ao método 1 (exemplo 2), exceto pelo fato de você substituir a fórmula na etapa 3 com a seguinte fórmula:
= INDEX($B$3:$E$3,MATCH(B4&B5,$B$1:$E$1&$B$2:$E$2,0))
exemplos de fórmulas de índice correspondente XL2003 XL2007

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 214142 - Última Revisão: 06/21/2015 03:34:00 - Revisão: 7.0

Microsoft Office Excel 2003, Microsoft Office Excel 2007, Microsoft Excel 2010

  • kbquery kbfunctions kbhowto kbmt KB214142 KbMtpt
Comentários