Você está offline; aguardando reconexão

Erro na fila de impressão quando desaparece o controlador de impressora

sbs_smallEste é um artigo passo a passo.
Sintomas
O driver da impressora desaparece inesperadamente enquanto ela está sendo usada e ocorre um erro na fila de impressão.

Causa
A configuração padrão do driver de impressora foi modificado erroneamente e o arquivo do driver está danificado.

Resolução

Corrigir para mim
Para corrigir o problema automaticamente, clique no link Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas neste assistente.




Observação A solução Corrigir pode ser executada no modo Light ou Completo.

O modo Light faz alterações no spooler de modo que você não precise fazer alterações adicionais. O modo Completo restaurará as definições padrão do spooler de impressão e requer que você reinstale suas impressoras.

Observação Este assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se o computador que você está usando não apresentar o problema, salve a solução Corrigir em uma unidade flash ou em um CD para depois executar no computador com esse problema.

Etapa 1: Parar o serviço do Spooler de impressão e excluir os elementos na pasta Spool (vídeo)
Etapa 1: Parar o serviço do Spooler de impressão e excluir os elementos na pasta Spool (texto)
  1. Clique em Iniciare, a seguir, em Painel de Controle.


  2. No Painel de Controle, clique em Sistema e segurança.


  3. Em Sistema e segurança, clique em Ferramentas administrativas.


  4. Em Ferramentas administrativas, faça um clique duplo em Serviços.


  5. Em Serviços, faça clique duplo em Spooler de impressão.


  6. Na janela Propriedades de Spooler de impressão, clique em Parar e, a seguir, em OK.


  7. Abra o Windows Explorer e escreva o caminho C:\Windows\System32\spool\PRINTERS.


  8. Agora exclua todos os arquivos existentes em PRINTERS, incluídas pastas e subpastas.


  9. No Windows Explorer, escreva o caminho:

    Windows 32 bits - C:\Windows\System32\spool\drivers\w32x86
    Windows 64 bits - C:\Windows\System32\spool\drivers\x64









  10. Em C:\Windows\System32\spool\drivers\w32x86 (ou x64), exclua todos os arquivos existentes.


  11. Instale novamente o driver de impressora com o CD que foi fornecido com ela ou baixe-o do site do fabricante para determinar se o erro continua. Se continuar, passe para a seguinte etapa.

Etapa 2: Fazer backup do Registro (vídeo)
Etapa 2: Fazer backup do Registro (texto)
Observação: esta etapa mostra como fazer backup do Registro porque na etapa 3 são modificados alguns dos seus valores, o que pode produzir um erro grave se for feito de maneira errada. Desta forma, pode-se voltar a um estado prévio ao erro.

  1. Clique em Iniciar e, na caixa de pesquisa, escreva regedit. A seguir, pressione Enter.



    Observação: caso uma senha de administrador ou uma confirmação seja solicitada, digite a senha ou forneça uma confirmação conforme necessário.
  2. No Editor de Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print. A seguir, selecione a pasta Print, clique em Arquivo e escolha Exportar…


  3. Agora, especifique um caminho para o backup, escreva um nome, por exemplo, Print, e clique em Salvar.







Etapa 3: Modificar o registro (vídeo)
Etapa 3: Modificar o registro (texto)
Importante: esta seção contém etapas que indicam como modificar o Registro. Porém, podem surgir graves problemas se o Registro for modificado incorretamente. Portanto, assegure-se de seguir estas etapas cuidadosamente. Para maior proteção, faça backup do Registro antes de modificá-lo. Se desejar obter mais informações, consulte a etapa anterior ou o artigo Backup do Registro.
  1. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Local Port e clique duas vezes em Driver.


  2. Em Dados do valor da janela Editar cadeia de caracteres, você vai encontrar o texto localspl.dll , caso contrário, digite localspl.dll e clique em OK.


  3. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Provider e exclua todas as subpastas.


  4. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors e exclua todas as subpastas.


  5. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\WindowsNT x86\Drivers e exclua todas as subpastas.


  6. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers e exclua todas as subpastas.


  7. Feche o Editor do Registro.


  8. Clique em Iniciar , abra a seta localizada junto a Desligar e, a seguir, clique em Reiniciar.


  9. Repita os pontos de 1 até 5 da etapa 1 para ir a Propriedades de Spooler de impressão. A seguir, clique em Iniciar e em OK.


  10. Instale novamente o driver de impressora com o CD que foi fornecido com ela ou baixe-o do site do fabricante. O problema estará solucionado.
Sua opinião é importante para nós: envie sua opinião sobre estes artigos através do campo de comentário que se encontra na parte inferior. Você estará nos ajudando a melhorar seu conteúdo. Muito obrigado!


Propriedades

ID do Artigo: 2394829 - Última Revisão: 02/05/2013 01:48:00 - Revisão: 2.8

Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate

  • kbstepbystep kbtshoot kbvideocontent kbhowto kbmsifixme KB2394829
Comentários
html>