O usuário não pode exibir informações gratuitas/ocupadas para um usuário remoto em uma implantação híbrida de Exchange Server

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Observação

O assistente de Configuração Híbrida incluído no Console de Gerenciamento do Exchange no Microsoft Exchange Server 2010 não tem mais suporte. Portanto, você não deve mais usar o assistente de Configuração Híbrida antigo. Em vez disso, use o assistente de Configuração Híbrida do Microsoft 365 que está disponível em https://aka.ms/HybridWizard. Para obter mais informações, confira Assistente de Configuração Híbrida do Microsoft 365 para Exchange 2010.

Sintomas

Você tem uma implantação híbrida de Microsoft Exchange Server e Microsoft Exchange Online locais no Microsoft 365 no qual seu servidor híbrido está em execução Exchange Server 2010. No entanto, os usuários não podem exibir informações gratuitas/ocupadas para um usuário remoto. Quando um usuário tenta exibir informações gratuitas/ocupadas para um usuário remoto, as informações gratuitas/ocupadas não são exibidas. Em vez disso, o usuário pode experimentar um ou mais dos seguintes sintomas:

  • As informações gratuitas/ocupadas para o usuário remoto são exibidas como caracteres de sinal de número (#) no Calendário.

  • Em Outlook Web App, o "erro 5037" é exibido.

  • Os arquivos Microsoft Outlook <FileName>-fb.log e <FileName>-as.log contêm uma mensagem de erro que se assemelha ao seguinte:

    <Resposta FreeBusyResponseMessage><ResponseClass="Error"><MessageText>O chamador não tem acesso a dados gratuitos/ocupados.</MessageText><ResponseCode>ErrorNoFreeBusyAccess</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey><MessageXml><ExceptionType xmlns="http://schemas.microsoft.com/exchange/services/2006/errorsMicrosoft.Exchange.InfoWorker.Common.Availability.NoFreeBusyAccessException></ExceptionType><ExceptionCode xmlns="http://schemas.microsoft.com/exchange/services/2006/errors">5037</ExceptionCode><ExceptionServerName xmlns="http://schemas.microsoft.com/exchange/services/2006/errors">ServerName</ExceptionServerName><ResponseSource xmlns="http://schemas.microsoft.com/exchange/services/2006/errors/>https://\<Server>.outlook.com/EWS/Exchange.asmx/WSSecurity<ResponseSource></MessageXml></ResponseMessage><FreeBusyView><FreeBusyViewType xmlns="http://schemas.microsoft.com/exchange/services/2006/types">None</FreeBusyViewType></FreeBusyView></FreeBusyResponse>

Por exemplo, um usuário do Microsoft 365 não pode exibir informações gratuitas/ocupadas para um usuário local. No entanto, outros usuários podem exibir informações gratuitas/ocupadas para o mesmo usuário local.

Motivo

Esse problema ocorrerá se o nome de domínio do endereço SMTP (Simple Mail Transfer Protocol) do usuário que está tentando exibir as informações gratuitas/ocupadas não estiver incluído entre os nomes de domínio na relação de organização. Por exemplo, quando você executa o cmdlet Test-OrganizationRelationship, a saída a seguir é exibida:

RunspaceId : a6c3799f-2ecd-4d79-ae4b-6c470dddd1dee
Identidade:
Id : LocalFederatedDomainsAreMissingFromTheRemoteOrganizationRelationsipDomains
Status : Aviso
Descrição: há domínios federados localmente que não estão presentes na lista de domínios para o objeto de relação de organização remota.
IsValid : True

Isso ocorrerá se o domínio SMTP não tiver sido adicionado manualmente à relação de organização. Isso também poderá ocorrer se as seguintes condições forem verdadeiras:

  • A conta de usuário do Microsoft 365 foi criada antes de você atualizar o ambiente local para Exchange Server 2010.
  • Você usou o assistente de Configuração Híbrida no Exchange Server 2010 no ambiente local para configurar a confiança da federação. Por exemplo, o nome de domínio do usuário do Microsoft 365 é contoso.com.

Nesse cenário, a conta de usuário do Microsoft 365 não tem @contoso.mail.onmicrosoft.com como um de seus endereços proxy. A solicitação para o ambiente local usa @contoso.com em vez de para a conta de @contoso.mail.onmicrosoft.com usuário do Microsoft 365. A solicitação é rejeitada porque a relação da organização no ambiente local não foi contoso.com adicionada a ela.

Resolução

Para resolve esse problema, edite a relação de organização no ambiente local para incluir o domínio SMTP do usuário que está enfrentando o problema. Para fazer isso, utilize um dos métodos seguintes.

Método 1: usar Console de Gerenciamento do Exchange

  1. No servidor do Exchange local, abra Console de Gerenciamento do Exchange e selecione Configuração da Organização no Microsoft Exchange Local.
  2. Selecione a guia Relações de Organização e, em seguida, exiba as propriedades da relação de organização.
  3. Selecione a guia Organização Externa , digite o nome de domínio federado nos domínios federados da caixa de organização externa do Exchange e selecione Adicionar.
  4. Repita a etapa 3 para cada domínio que você deseja adicionar.
  5. Selecione OK.

Método 2: usar o Shell de Gerenciamento do Exchange

  1. No servidor local, abra o Shell de Gerenciamento do Exchange.

  2. Configure a relação da organização como uma variável. Por exemplo, execute o seguinte comando:

    $OrgRel = Get-OrganizationRelationship Contoso
    
  3. Adicione os nomes de domínio adicionais que você deseja à variável. Por exemplo, execute o seguinte comando:

    $OrgRel.DomainNames += "contoso.com"
    
  4. Atualize a relação da organização usando o novo valor de nomes de domínio. Por exemplo, execute o seguinte comando:

    Set-OrganizationRelationship $OrgRel.Name -DomainName $OrgRel.DomainNames
    

Mais informações

Para ajudar a identificar o problema no Microsoft 365, siga estas etapas:

  1. Conecte-se ao Exchange Online usando o PowerShell remoto. Para obter mais informações sobre como fazer isso, consulte Conectar-se ao Exchange Online PowerShell.

  2. Compare o endereço SMTP do usuário com a relação da organização. Para fazer isso, execute o seguinte comando:

    if ( (Get-OrganizationRelationship).DomainNames -contains (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1]) { write-host "The domain was found" -ForegroundColor Green } else { write-host (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1] "was not found" -ForegroundColor Yellow}
    

    Observação

    Você também pode comparar cada domínio listado nos domínios aceitos com os nomes de domínio que estão na relação de organização. Para fazer isso, execute o seguinte comando:

    Get-AcceptedDomain | ForEach-Object { if ( (Get-OrganizationRelationship).DomainNames -contains $_.DomainName) { write-host $_.DomainName "was found" -ForegroundColor Green } else { write-host $_.DomainName "was not found" -ForegroundColor Yellow} }
    

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