Works: Como recuperar os dados de uma planilha corrompida do Works

Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
Os arquivos de planilha do Microsoft Works são salvos como arquivos .xlr. Arquivos com esta extensão estão no formato original do Microsoft Excel format. Arquivos de Planilhas corrompidas no Works podem ser recuperadas usando o Excel ou usando um dos métodos que se mostraram eficientes para recuperar dados corrompidos de planilhas do Excel. Estes métodos incluem:
  • Abra o arquivo no Microsoft Excel ou outro programa de planilhas compatível.
  • Abra o arquivo no Microsoft Word.
  • Abra o arquivo usando o Microsoft Excel 2000 Viewer 97.
Mais Informações

Método 1: Abra o Arquivo no Excel (ou outro programa de planilhas compatível)

Use este método quando quiser preservar fórmulas e formatação de células. Se puder abrir o arquivo com o Excel, siga as seguintes etapas para recuperar os dados:
  1. Inicie o Excel.
  2. Abra a Planilha .xrl corrompida do Works.
  3. Se o arquivo abrir, corrija quaisquer erros.
  4. Selecione todas as células que contém dados.
  5. No menu Editar, clique em Copiar.
  6. Inicie a planilha do Works e crie uma nova planilha.
  7. Selecione a célula A1.
  8. No menu Editar, clique em Colar.
  9. No menu Arquivo, clique em Salvar.
  10. Dê um nome o arquivo e clique em Salvar.
  11. Optional: Alterne para o Excel e salve o arquivo.

Método 2: Abra o arquivo no Microsoft Word

Use este método se o Excel não abrir o arquivo .xlr, se suspeitar que o problema pode ser uma fórmula corrompida ou se o Excel não estiver disponível.

Se o conversor do Excel estiver instalado, é possível abrir sua planilha do Works no Word. Se o arquivo abrir no Word, você não poderá recuperar as fórmulas das células, mas somente os resultados destas fórmulas que estão atualmente nas células. Você também perderá qualquer formato especial.

DICA: Para determinar se o conversor do Microsoft Excel está instalado, clique Abrir no menu Arquivo no Word e, em seguida, clique na caixa Tipos de arquivos; se a planilha do Microsoft Excel estiver na lista, o conversir está instalado.

Para abrir uma Planilha do Works no Word, siga estas etapas:
  1. Inicie o Microsoft Word.
  2. No menu Arquivo, clique em Abrir.
  3. Na caixa Arquivos do tipo, clique em Todos os arquivos.
  4. Na caixa Nome do arquivo, selecione a planilha corrompida do Works.
  5. Clique em Abrir.

    O arquivo abre como um arquivo de texto separado por vírgulas; que significa que as células são separadas por vírgulas.
  6. No menu Arquivo, clique em Salvar como.
  7. Na caixa Salvar como tipo, clique em Somente texto (*.txt).
  8. Dê um nome o arquivo e clique em Salvar.
  9. Inicie a Planilha do Works.
  10. No menu Arquivo, clique em Abrir.
  11. Na caixa Tipos de arquivo, clique em Texto (*.txt).
  12. Localize o arquivo desejado e, em seguida, clique em Abrir.

Método 3: Usar o visualizador do Excel

Use este método se o Excel não abrir o arquivo .xlr, se suspeitar que o problema pode ser uma fórmula corrompida ou se o Excel não estiver disponível.

Se o Visualizador do Excel estiver instalado, você poderá abrir a pasta de trabalho corrompida do Works no Visualizador do Excel, copiar as células e colá-las em uma planilha. Contudo, você não poderá recuperar quaisquer fórmulas das células, apenas os resultados das fórmulas que estão atualmente nas células.

Para obter mais informações sobre o Visualizador do Excel, visite o seguinte site na Web:
Quando você visualiza um documento de Planilha do Microsoft Works e a planilha tiver mais de uma página, pressionar PAGE UP e PAGE DOWN pode não modificar as páginas conforme esperado.
Propriedades

ID do Artigo: 271074 - Última Revisão: 12/05/2015 21:20:26 - Revisão: 3.2

Microsoft Works 7.0 Standard Edition, Microsoft Works 6.0 Standard Edition, Microsoft Works Suite 2003 Standard Edition, Microsoft Works Suite 2001 Standard Edition, Microsoft Works Suite 2002 Standard Edition

  • kbnosurvey kbarchive kbdownload kb3rdparty kbhowto kbinterop KB271074
Comentários