Quando usar uma fórmula de matriz SUM(IF())

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.

Clique aqui para ver a versão em Inglês deste artigo: 275165
Sumário
Você pode usar a função de planilha SUMIF() no Microsoft Excel para qualquer uma das situações a seguir:
  • Quando você deseja retornar uma soma para um único critério (por exemplo, uma única condição IF)
  • Quando desejar usar vários critérios e retornar a soma para várias células
Os critérios que podem ser usados com a função de planilha SUMIF() é limitada a texto, números ou um intervalo, e a função não pode usar as constantes de matriz.

Para obter informações adicionais sobre constantes de matriz e funções de planilha, clique nos números abaixo para ler os artigos na Base de Conhecimento Microsoft:
214286 Algumas funções de planilha não permitem constantes de matriz
192222 Algumas funções de planilha não permitem constantes de matriz
Você não pode usar a função de planilha SUMIF() com operadores lógicos Booleanos, como OR e AND.

Para obter informações adicionais sobre funções de planilha e operadores booleanos, clique no número abaixo para ler o artigo na Base de Conhecimento Microsoft:
267982 Como usar um AND lógico ou um OR em uma instrução SUM+IF no Excel
Quando desejar usar várias condições, constantes de matriz, instruções IF aninhadas ou operadores Booleanos; ou você deseja um total para várias condições (critérios); Use as duas funções SOMA e IF juntos. Por exemplo, use SUM(IF()) em vez da função SUMIF().

Este artigo demonstra como usar as duas funções SOMA e IF juntos em vez da função de planilha SUMIF().
Mais Informações
Para usar as funções de planilha SOMA e IF juntos para somar vários critérios, consulte os exemplos a seguir.

Exemplo 1: A Função IF aninhada com Booleano OR (+)

  1. Inicie o Excel e crie a seguinte planilha:
       A1: Dept  B1: Employees C1: Criteria   A2: A     B2: 2	   C2: A   A3: B     B3: 4	   C3: B   A4: C     B4: 3		   A5: A     B5: 3		   A6: B     B6: 3		   A7: C     B7: 2		   A8: A     B8: 4		   A9: C     B9: 3							
  2. Na célula D1, digite a seguinte fórmula:
    = SOM(IF ((A2:A9="A")+(A2:A9="B"),B2:B9,0))
  3. Pressione CTRL + SHIFT + ENTER (ou COMMAND + RETURN no Mac) para inserir a fórmula como uma fórmula de matriz.

    A fórmula retorna 16, o número total de funcionários nos departamentos A e B.

Exemplo 2: A função IF aninhada com os Critérios de Matriz ({"A", "B"})

  1. Repita a etapa 1 do exemplo 1.
  2. Na célula D2, digite a seguinte fórmula:
    = SOM(IF(A2: A9 = {"A","B"}, B2:B9, 0))
  3. Pressione CTRL + SHIFT + ENTER (ou COMMAND + RETURN no Mac) para inserir a fórmula como uma fórmula de matriz.

    A fórmula retorna novamente 16.

Exemplo 3: A Função de planilha SUMIF()

  1. Repita a etapa 1 do exemplo 1.
  2. Na célula D3, digite a seguinte fórmula:
    =SUMIF(A2:A9,C2:C3,B2:B9)
  3. Pressione CTRL + SHIFT + ENTER (ou COMMAND + RETURN no Mac) para inserir a fórmula. A fórmula retorna 9, o número de funcionários que atendem aos critérios A.
  4. Pegue a alça de preenchimento e preencha a fórmula até a célula D4.

    A fórmula retorna 7, o número de funcionários que atendem aos critérios B.
Referências
Para obter mais informações sobre a função de planilha soma, clique em Ajuda do Microsoft Excel sobre o Ajuda menu de tipo soma no Assistente do Office ou no Assistente de resposta e clique Pesquisa Para exibir os tópicos retornados.

Para obter mais informações sobre a função de planilha se, clique em Ajuda do Microsoft Excel sobre o Ajuda menu de tipo Se a função de planilha no Assistente do Office ou no Assistente de resposta e clique Pesquisa Para exibir os tópicos retornados.

Para obter mais informações sobre o SOMASE, clique em Ajuda do Microsoft Excel sobre o Ajuda menu de tipo SOMASE no Assistente do Office ou no Assistente de resposta e clique Pesquisa Para exibir os tópicos retornados.
XL2010 XL2007 XL2003

Propriedades

ID do Artigo: 275165 - Última Revisão: 01/03/2015 14:54:00 - Revisão: 8.0

Microsoft Office Excel 2003, Microsoft Office Excel 2007, Microsoft Excel 2010, Microsoft Office 2008 for Mac

  • kbhowto kbmt KB275165 KbMtpt
Comentários