Imagens vinculadas não são exibidas quando uma apresentação do PowerPoint e imagens são movidas para uma nova unidade

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 285317
Sintomas
Após você mover uma apresentação do Microsoft PowerPoint e imagens que estão vinculadas a essa apresentação para uma nova unidade ou local da pasta, as imagens não são visíveis. Em vez disso, as imagens são exibidas como espaços reservados, mesmo que as imagens estejam na mesma pasta na mesma unidade onde a apresentação que se encontra.

Por exemplo, crie uma apresentação que contém muitas imagens vinculadas e, em seguida, você gravar em um CD gravável (CD-R). Quando você abre a apresentação de CD-R em outro computador, as imagens não são exibidas na apresentação, mesmo que eles estejam no CD-r.
Causa
A pasta que contém as imagens foi movida. Microsoft Office PowerPoint 2007, PowerPoint 2003 e PowerPoint 2002 usam um caminho absoluto para localizar imagens vinculadas. Se a letra de unidade ou caminho for alterado, as imagens não aparecem. Isso pode acontecer quando uma apresentação que foi criada na unidade C é gravado no diretório raiz de um CD-R e, em seguida, aberto a partir de CD-ROM, normalmente a unidade D. Porque os caminhos para imagens vinculadas começam com C, as imagens não são encontradas quando a apresentação é aberta.
Como Contornar
Para contornar esse problema, use um dos seguintes métodos.

Método 1: Usar "Pacote para CD"ou"viagem"

Quando você deseja executar uma apresentação em outro computador, o PowerPoint pode criar um pacote que coloca todos os arquivos necessários para uma pasta ou em um CD. PowerPoint 2002 pode colocar todos os arquivos necessários em um único arquivo ou abranjam vários discos. Em seguida, descompacte o PowerPoint 2002 Pack e o arquivo ir no compartilhamento de rede ou computador de destino e executar a apresentação.

Quando você compacta sua apresentação, você pode decidir incluir todos os arquivos vinculados na apresentação. Quando você faz isso, o PowerPoint converte os caminhos absolutos dos links de imagem relativo aos. Isto é, em vez do caminho que está sendo "C:\Meus Documentos\Meus Pictures\image001.jpg", o caminho será "imagem001.jpg".

Empacotando uma apresentação e arquivos associados

PowerPoint 2007

Para usar o recurso pacote para CD do PowerPoint 2007, execute essas etapas:
  1. Abra a apresentação que você deseja compactar para CD.
  2. Clique no Botão Microsoft Office Microsoft Office Button, aponte para Publicar e, em seguida, clique em pacote para CD .
  3. Se você for solicitado para confirmar a conversão em formatos anteriores do PowerPoint, clique em OK .
  4. Por padrão, todos os arquivos vinculados são incluídos com a apresentação compactada. Clique em Copiar para pasta ou clique em Copiar para CD .

    Se você clicar em Copiar para pasta , execute estas etapas:
    1. Digite um nome de pasta na caixa Nome da pasta e clique em Procurar para localizar um destino para esta pasta.
    2. Clique em Selecionar e, em seguida, clique em OK .
    3. Clique em Sim para incluir os arquivos vinculados em conjunto com a apresentação.
    Se você clicar em Copiar para CD , você deve ter um CD gravável em branco pronto para inserir na sua unidade de disco de CD ou DVD. Clique em Repetir . Quando o PowerPoint termina a gravar o CD, clique em não quando for solicitado para gravar outro CD.
  5. Clique em Fechar .
Para iniciar a apresentação, você pode inserir o CD em um computador e, em seguida, clique duas vezes no ícone CD no Windows Explorer, ou localize a pasta que você criou na etapa 4 e, em seguida, abra a apresentação no PowerPoint 2007.

PowerPoint 2003

Para usar o recurso pacote para CD do PowerPoint 2003, execute essas etapas:
  1. Abra a apresentação que você deseja compactar para CD.
  2. Clique em pacote para CD no menu arquivo .
  3. Por padrão, todos os arquivos vinculados são incluídos com a apresentação compactada. Clique em Copiar para pasta ou clique em Copiar para CD .

    Se você clicar em Copiar para pasta , execute estas etapas:
    1. Digite um nome de pasta na caixa Nome da pasta e clique em Procurar para localizar um destino para esta pasta.
    2. Clique em Selecionar e, em seguida, clique em OK .
    3. Clique em Sim para incluir os arquivos vinculados em conjunto com a apresentação.
    Se você clicar em Copiar para CD , você deve ter um CD gravável em branco pronto para inserir na sua unidade de disco de CD ou DVD. Clique em Repetir . Quando o PowerPoint termina a gravar o CD, clique em não quando for solicitado para gravar outro CD.
  4. Clique em Fechar .
Para iniciar a apresentação, você pode inserir o CD em um computador e, em seguida, clique duas vezes no ícone CD no Windows Explorer, ou localize a pasta que você criou na etapa 4 e, em seguida, abra a apresentação no PowerPoint 2007.

PowerPoint 2002

Para usar o Assistente para viagem em uma apresentação para executar em outro computador, execute essas etapas:
  1. Abra a apresentação que você deseja compactar.
  2. No menu arquivo , clique em Assistente para viagem .
  3. Siga as instruções no Assistente para viagem.

    Quando solicitado para qual unidade copiar para, clique em Selecionar destino e procurar um local de arquivo temporário. Isso é onde você compactar sua apresentação e seus arquivos associados. Clique em Avançar .
  4. Optar por incluir Arquivos vinculados . Neste ponto, você pode optar por incorporar fontes TrueType com a sua apresentação. Clique em Avançar .
  5. Não inclua o visualizador. Clique em Avançar e, em seguida, clique em Concluir .
Em seguida, você pode copiar o arquivo compactado e o programa Pngsetup.exe para qualquer compartilhamento de rede ou unidade que você escolher.

Descompactar uma apresentação do PowerPoint 2002

Para exibir sua apresentação, você deve ir para o local que você copiou o arquivo de pacote para e descompactá-lo. Para fazer isso, execute as seguintes etapas:
  1. No Microsoft Windows Explorer, navegue até o local da apresentação compactada e, em seguida, clique duas vezes em Pngsetup .
  2. Digite o local onde você deseja descompactar o arquivo.
  3. Clique em OK .
A apresentação e as imagens vinculadas serão ser descompactadas no local escolhido.

Usando código de macro para definir o caminho relativo

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento. No entanto, eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.
Observação Os exemplos de macro a seguir funcionam somente no PowerPoint. Visual Basic for Applications macros não são suportadas pelo Visualizador do Microsoft PowerPoint. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
230746Visualizar PPT:: Não executar macros da apresentação com o Visualizador

Você também pode usar uma macro para converter os links de absoluto em relativo. Isso permitirá que o PowerPoint localizar as imagens com base no local atual da apresentação, desde que as figuras são neste mesmo local.

A seguir está um exemplo de código, mostrando uma maneira em que isso poderia ser automatizado. Este exemplo de código assume que a apresentação e as imagens vinculadas estão no mesmo local de pasta. Se não estiverem no mesmo local de pasta, em seguida, executar esse código irá quebrar o vínculo para a imagem.

Código de exemplo

  1. Abra o Editor do Visual Basic:

    PowerPoint 2007
    1. Clique na guia Exibir .
    2. Clique em macros no grupo de macros .
    3. Digite RelPict na caixa Nome da macro e, em seguida, clique em criar .
    PowerPoint 2003 e o PowerPoint 2002
    1. No menu Ferramentas , aponte para macro e, em seguida, clique em segurança .
    2. Clique em média para o nível de segurança. Clique em OK .
    3. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
    4. No menu Inserir , clique em módulo .
  2. Digite o seguinte código no módulo:
    Sub RelPict()   Dim oSlide As Slide   Dim oShape As Shape   Dim lPos As Long   Dim strLink As String   '   ' Loop through the presentation checking each shape   ' on each slide to see if it is a linked picture.   '   For Each oSlide In ActivePresentation.Slides      For Each oShape In oSlide.Shapes         If oShape.Type = msoLinkedPicture Then            With oShape.LinkFormat   '   ' Search from the right hand portion of the source   ' filename and find the first backslash "\" character.   '               lPos = InStrRev(.SourceFullName, "\")   '   ' Check to see if the link has already been modified.   '               If lPos <> Null Then   '   ' Determine how long the filename is, by subtracting   ' the position the "\" character was found at from   ' the total length of the source file name.   '                  lPos = Len(.SourceFullName) - lPos   '   ' Extract the filename from the source file name, then   ' assign the filename to the source file name, turning   ' it into a relative path.   '                  strLink = Right(.SourceFullName, lPos)                  .SourceFullName = strLink               End If            End With         End If      Next oShape   Next oSlideEnd Sub					
Situação
A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
kbnoOfficeAlertID PPT2007 PPT2003 PPT2002 PPT

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 285317 - Última Revisão: 06/04/2007 22:26:41 - Revisão: 2.1

Microsoft Office PowerPoint 2007, Microsoft Office PowerPoint 2003, Microsoft PowerPoint 2002 Standard Edition

  • kbmt kbbug kbnofix KB285317 KbMtpt
Comentários