Como automatizar o Excel texto para fala em outro programa do Office

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 287120
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
Este artigo passo a passo explica como você pode usar a funcionalidade de texto para fala do Microsoft Excel em outros programas, incluindo o Microsoft Word, Microsoft PowerPoint e Microsoft Outlook.

Microsoft Excel é o programa somente do Microsoft Office XP que possui recursos internos texto para fala (TTS). Este artigo explica como você pode usar a automação OLE para acessar programaticamente o modelo de objeto do Excel e usar a funcionalidade de texto para fala em outros programas.

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.

back to the top

Usar texto para fala no PowerPoint

O exemplo a seguir usa o modelo de objeto do Excel para acessar o texto para fala de uma apresentação do PowerPoint. Esse procedimento demonstra como fazer referência e crie um objeto do Excel para usar o objeto de fala .

back to the top

Inserir um módulo em uma apresentação do PowerPoint

  1. Abra uma apresentação do PowerPoint.
  2. Pressione ALT+F11 para iniciar o Editor do Visual Basic.
  3. No menu Inserir , clique em módulo .
  4. Digite ou copie e cole no módulo o código de exemplo que aparece posteriormente nesta seção.
back to the top

Adicionar uma referência ao Excel 10 biblioteca de objetos

  1. No Editor do Visual Basic, aponte para referências no menu Ferramentas .
  2. Em Referências disponíveis , clique para selecionar a caixa de seleção Biblioteca de objetos do Microsoft Excel 10.0 e, em seguida, clique em OK .
back to the top

Procedimento Sub para automatizar o Excel texto para fala do PowerPoint

O exemplo a seguir pressupõe que sua apresentação do PowerPoint tem dois slides.
Sub demoTTS()        'Declare and create an Excel object.    Dim XL As Excel.Application    Set XL = CreateObject("Excel.Application")        ActivePresentation.SlideShowSettings.Run     With SlideShowWindows(1).View        'The following is said on the first slide:        XL.Speech.Speak "Welcome to my presentation."        'Change to slide 2, and then say the following two sentences:        .Next        XL.Speech.Speak "This is an example of how to create an Excel Application object."        XL.Speech.Speak "We can use Excel's object model to invoke Text to Speech."                'Close the Excel object and set the object to nothing.        XL.Quit        Set XL = Nothing                'Exit the slideshow.        .Exit    End With    End Sub				
Observação : segurança do PowerPoint é definida no alta por padrão. Macros do Visual Basic não assinadas não são executados nesta configuração. Altere o nível de segurança macro como Médio , seguindo estas etapas:
  1. No menu Ferramentas , aponte para macro e, em seguida, clique em segurança .
  2. Na guia Nível de segurança , clique para selecionar Médio e, em seguida, clique em OK .
  3. No menu arquivo , clique em Sair para fechar o PowerPoint.

    Observação : você deve encerrar e reiniciar o PowerPoint para a alteração do nível de segurança tenham efeito.
back to the top

Usar texto para fala no Word

O exemplo a seguir usa o modelo de objeto do Excel para acessar o texto para fala de um documento do Word. Esse procedimento demonstra como fazer referência e crie um objeto do Excel para usar o objeto de fala .

back to the top

Inserir um módulo no Word

  1. Abra um documento do Word.
  2. Pressione ALT+F11 para iniciar o Editor do Visual Basic.
  3. No menu Inserir , clique em módulo .
  4. Digite ou copie e cole no módulo o código de exemplo que aparece posteriormente nesta seção.
back to the top

Adicionar uma referência ao Excel 10 biblioteca de objetos

  1. No Editor do Visual Basic, aponte para referências no menu Ferramentas .
  2. Em Referências disponíveis , marque a caixa de seleção Biblioteca de objetos do Microsoft Excel 10.0 e, em seguida, clique em OK .
back to the top

Procedimento Sub para automatizar o Excel texto para fala do Word

O exemplo a seguir que você digita o texto no seu Word pressupõe documento e, em seguida, selecione o texto antes de executar o procedimento Sub.
Sub TTS()   'Declare and create an Excel object.      Dim XL_tts As Excel.Application      Set XL_tts = CreateObject("Excel.Application")      XL_tts.Speech.Speak Selection      XL_tts.Quit      Set XL_tts = NothingEnd Sub				
Observação : segurança do Word é definida no alta por padrão. Macros do Visual Basic não assinadas não são executados nesta configuração. Altere o nível de segurança macro como Médio , seguindo estas etapas:
  1. No menu Ferramentas , aponte para macro e, em seguida, clique em segurança .
  2. Na guia Nível de segurança , clique para selecionar Médio e, em seguida, clique em OK .
  3. No menu arquivo , clique em Sair para fechar o Word.
Observação : você deve encerrar e reiniciar o Word para que a alteração de nível de segurança tenham efeito.

back to the top

REFERÊNCIAS

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
277808XL2002: "Run-time error 1004" ao tentar usar texto para fala no macro
Para informações adicionais sobre como obter ajuda com o Visual Basic for Applications, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
163435Recursos de programação para Visual Basic for Applications
back to the top
OfficeKBHowTo inf

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 287120 - Última Revisão: 12/06/2015 00:15:05 - Revisão: 3.1

Microsoft Excel 2002 Standard Edition, Microsoft Outlook 2002 Standard Edition, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbautomation kbenablesight kbhowtomaster KB287120 KbMtpt
Comentários