O Outlook não pode se conectar por meio de um firewall ou de um servidor proxy que está executando a NAT (Conversão de Endereço de Rede) entre redes públicas e privadas

Número de KB original: 291615

Sintomas

Os clientes do Outlook não podem se conectar por meio de um firewall ou servidor proxy que está executando NAT entre redes públicas e privadas.

Motivo

Quando os pacotes IP que contêm as informações de chamada de procedimento remoto (RPC) são editados durante a tradução, os pacotes IP perdem as informações de conectividade RPC. Isso faz com que o cliente não se conecte ao servidor. Além disso, o Outlook pode ter problemas para resolver o nome do Microsoft Exchange Server computador por trás do firewall ou servidor proxy.

Solução alternativa

Um trabalho para firewalls ou servidores proxy que não se baseiam no Microsoft Windows NT é executar uma tradução um para um entre as duas redes. Isso também é chamado de abrir um pipe ou túnel entre as redes públicas e privadas. Isso pega todas as solicitações de um endereço específico na rede pública e as passa diretamente para a rede privada. Para obter informações adicionais sobre como configurar uma tradução um para um, consulte a documentação do fabricante.

Uma tradução ou pipe único não funciona para firewalls e servidores proxy baseados em Windows NT porque o cliente do Outlook tenta associar-se à porta mapeador de ponto de extremidade (EPM), porta 135, no firewall. Esse servidor não retorna as informações corretas de conectividade Exchange Server para o cliente do Outlook.

Outra possível solução de trabalho é usar Outlook Web App. Isso requer apenas permitir o tráfego HTTP por meio do firewall ou servidor proxy.

Mais informações

Para obter mais informações, consulte as seguintes Solicitações de Comentários (RFCs):

  • RFC 1631 - O NAT (Tradutor de Endereço de Rede IP)
  • RFC 1918 – Alocação de endereços para Internet privada

Esses RFCs podem ser encontrados aqui.