Como criar e configurar uma lista de endereço de mala direta no Word

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.

Clique aqui para ver a versão em Inglês deste artigo: 294688
Para obter uma versão deste artigo do Microsoft Word 2000, consulte 212322.
Sumário
Este artigo descreve os formatos aceitáveis para obter uma lista de endereço de mala direta e inclui sugestões e perguntas que são úteis para perguntar como você cria uma lista de endereços.

Criar uma fonte de dados

No Microsoft Word, você pode criar uma nova lista de endereços no Assistente de mala direta. Quando você escolhe "Etapa 3: selecionar destinatários" no assistente, a opção de digitar uma nova lista está disponível. Esta opção cria a lista de endereços.

Outra maneira de criar uma lista de endereços é de uma tabela do Word. Você também pode usar qualquer formato de banco de dados, como um arquivo de texto na qual os campos são separados por vírgulas ou tabulações e registros são separados por marcas de parágrafo.

Em uma lista de endereços, cada categoria de informação, como Sobrenome, é chamada de um campo. O conjunto de campos que compõem informações sobre uma pessoa é chamado de registro.

O que considerar quando você cria uma fonte de dados

Antes de criar uma lista de endereços, decida quais informações você deseja incluir e como você deseja utilizar essas informações e, em seguida, crie o banco de dados. Isso economiza tempo e trabalho mais tarde.

Alguns registros tem mais informações do que as outras pessoas?

Alguns dos seus registros de dados podem ter mais informações do que outros registros. Por exemplo, algumas entradas podem ter um nome de empresa, um título de departamento e até três linhas para o endereço. Outras entradas podem ter apenas um nome, um endereço de uma linha e uma terceira linha com a cidade, estado e CEP.

Na lista de endereços, cada registro de dados deve ter o mesmo número de campos de dados. Crie sua lista de endereços para que ele possui campos suficientes dados para corresponder ao registro com a maioria dos campos. Você não precisa preencher todos os campos no registro de dados; Você pode deixar alguns campos em branco. O Word suprime automaticamente registros em branco.

Você planeja classificar os dados?

Se você planeja classificar os dados, você deve organizá-lo para que você pode classificar os dados com base em alguns critérios. Por exemplo, a cidade, estado e código postal geralmente são impressos na mesma linha de uma etiqueta de endereçamento, então você pode querer incluir todas essas informações no mesmo campo. Se você incluir todas essas informações no mesmo campo, você não pode classificar os registros com base no estado ou código postal. Nesse caso, você deve separar cada parte das informações em um campo separado.

O mesmo é verdadeiro se você deseja classificar seus dados por sobrenomes de destinatários. Nesse caso, você deve separar os sobrenomes e primeiros nomes em campos separados.

Você usará as informações em um campo específico de maneiras diferentes?

Em uma carta modelo, a primeira linha do dentro endereço geralmente contém um título Honorífico e nome completo do destinatário. A saudação pode conter apenas o título Honorífico e sobrenome ou somente o primeiro nome. Se você colocar o título, o nome e o sobrenome em campos separados, você pode usar o mesmo campo para imprimir o último nome o endereço e a saudação. Como alternativa, você pode usar um campo para o título completo e o nome no interior endereço e um segundo campo para o título e o sobrenome na saudação.

Você usará a lista de endereços para vários documentos de mala direta?

Você pode mesclar uma lista de endereço único com qualquer tipo e o número de documentos principais. Configurar uma lista de endereços para imprimir cartas, planeje as informações de destinatário para que você possa usar a mesma fonte de dados para imprimir os endereços em etiquetas de endereçamento ou envelopes.

Quantos campos (partes de informações) para cada registro (a coleção de itens de informação) você tem?

Se você tiver algumas partes de informações para cada registro, você pode usar o Assistente de mala direta (no menu Ferramentas ) no Word. Isso permite que você acesse a caixa de diálogo Destinatários da mala direta para configurar sua lista de endereços.

Há uma limitação de 255 campos na caixa de diálogo Destinatários da mala direta . Se o número de campos exceder esse valor, não use o auxiliar de mala direta. Em vez disso, use um dos seguintes procedimentos:
  • Use o Microsoft Excel como sua fonte de dados. Os campos de dados em uma planilha do Excel Númerode máximo é 256.
  • Use um banco de dados do Microsoft Access como sua fonte de dados.
  • Use um arquivo de texto delimitado por tabulação ou um arquivo de texto delimitado por vírgula como sua fonte de dados.
Degrada o desempenho de mala direta como o número de campos em aumenta a linha de cabeçalho. A configuração do seu computador e a memória disponível também pode limitar o número de campos que você pode inserir em seu documento de dados.

O registro de cabeçalho (linha) não pode conter espaços. Cada campo de cabeçalho está limitado a 40 caracteres e deve começar com uma letra. Cada caractere subseqüente deve ser uma letra, um número ou o caractere de sublinhado. Todos os campos de cabeçalho devem ser preenchidos. Observe que as restrições descritas aqui são diferentes em algumas versões do Word de idioma.

Organizar dados em tabelas ou parágrafos

Quando você organiza os dados em uma tabela, a tabela deve conter uma coluna para cada nome de campo que você deseja usar. A primeira linha da tabela é a linha de cabeçalho; cada linha subseqüente contém as informações de registro de dados.

Embora possa ser quebrado em cada célula, ele será impresso corretamente. A seguir está uma lista de itens a serem considerados quando você usa uma lista de endereços existente como uma fonte de dados:
  • Se você usar uma fonte de cabeçalho separado, certifique-se de que theheader é o primeiro registro (linha de células) na lista de endereços. Verifique surethat há sem espaços, texto ou linhas em branco antes do registro de cabeçalho. Registro de Theheader não pode conter espaços. Cada campo de cabeçalho está limitado a 40characters e deve começar com uma letra. Cada caractere subseqüente deve ser aletter, um número ou o caractere de sublinhado. Todos os campos de cabeçalho devem ser filledin.
  • Certifique-se de que o número de campos de dados em cada datarecord é igual ao número de nomes de campo no registro de cabeçalho. Se um registro tiver informações para um determinado campo, deixe a célula para que fieldblank.
  • Organize as informações nos registros de dados em sameorder, da esquerda para a direita, como os nomes de campo correspondente no registro de cabeçalho. A ordem das colunas na lista de endereços não é importante, porque youwill controlar o posicionamento dos dados em maindocument a mala direta.

Criar uma lista de endereços contém muitos campos

A caixa de diálogo Destinatários da mala direta cria uma lista de endereços (. mdb) para o arquivo de dados. No Microsoft Word, o número máximo de campos para a caixa de diálogo Destinatários da mala direta é 255. para criar um novo banco de dados da caixa de diálogo Destinatários da mala direta , execute estas etapas:
  1. O Microsoft Word 2002

    No menu Ferramentas , clique em Cartas e correspondênciase, em seguida, clique em Assistente de mala direta.

    Microsoft Office Word 2003

    No menu Ferramentas , clique em Cartas e correspondênciase, em seguida, clique em mala direta.

    Microsoft Office Word 2007 e Word 2010

    Na guia correspondências , clique em Iniciar Mala diretae, em seguida, clique em Assistente de mala direta passo a passo.

    Siga as etapas no Assistente de mala direta a "etapa 3: SelectRecipients." Isso é onde você configurar sua lista de endereços.
  2. Clique em digitar uma nova lista.
  3. Clique em criar. Será exibida a caixa de diálogo Nova lista de endereços . Na caixa de diálogo, digite addressinformation para cada registro. Se não houver nenhuma informação para um determinado campo, deixe a caixa em branco. Por padrão, o Word ignora campos em branco, para que a mesclagem é notaffected se entradas em branco estiverem no formulário de dados. O conjunto de informações em eachform constituem registro de dados.
  4. Depois de digitar as informações de um registro, clique em Nova entrada para mover para o próximo registro. Para excluir um registro, clique em Delete Entry. Para procurar um registro específico, clique em Localizar entrada. Para filtrar ou classificar os registros, clique em Filtrar e classificar.

    Observação: Se você deseja personalizar sua lista de endereços, clique em Personalizar. Na caixa de diálogo Personalizar lista de endereços , você pode adicionar, excluir, renomear e reordenar o mergefields.
  5. Na caixa de diálogo Nova lista de endereços , clique em Fechar.
  6. Na caixa de diálogo Salvar lista de endereços , na caixa nome do arquivo , digite o nome que deseja dar a sua fonte de dados, e clique em Salvar.
  7. Na caixa de diálogo Destinatários da mala direta , faça as alterações que desejar e, em seguida, clique em OK.
Você criou um novo endereço e está pronto para passar para a próxima etapa do Assistente de mala direta. Esta etapa é escrever a carta.

Para obter mais informações sobre como criar uma carta modelo, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:
294683 Como usar mala direta para criar cartas de formulário no Word 2002 e em versões posteriores do Word
Se precisar de mais de 255 campos de dados na sua lista de endereços, o Word não pode organizar os dados na caixa de diálogo Destinatários da mala direta . Em vez disso, você pode configurar suas informações como parágrafos separados em uma palavra documento. O registro de cabeçalho e cada registro de dados devem terminar com uma marca de parágrafo, que é o delimitador de registro de dados. Cada nome de campo no registro de cabeçalho e cada campo do registro de dados devem ser separados por um caractere de tabulação ou vírgula, que é o delimitador de campo de dados. Se qualquer um dos campos de dados estiver vazio, você deve incluir um delimitador de campo para identificar o campo vazio.

Se você estiver usando uma lista de endereços a partir de um programa de banco de dados ou planilha, você pode exportar dados para um formato de texto ASCII, separado por vírgulas ou tabulações. Ou, você pode ser capaz de anexar o banco de dados usando ODBC, DDE ou um conversor. Se você exportar os dados para um formato ASCII e Word não reconhece automaticamente o campo e delimitadores de registro, o Word solicita que você selecione os delimitadores ao usar a lista de endereços primeiro. Quando você configura uma lista de endereços neste formato no Word, você deve usar uma marca de parágrafo como o delimitador de registro de dados e um caractere de tabulação ou vírgula como o delimitador de campo de dados.

Além das regras gerais para organizar uma lista de endereços, as seguintes regras também se aplicam às listas de endereço que são configuradas como texto regular:
  • Pressione ENTER ao final de cada registro de dados com uma marca de parágrafo. Certifique-se de que não há nenhum marcas de parágrafo extras entre ou após o datarecords. O Word interpreta os parágrafos vazios (linhas em branco) como emptyrecords.
  • Use o mesmo delimitador de campo no registro de cabeçalho e o registro de dados. Por exemplo, você não pode usar caracteres de tabulação no headerrecord e vírgulas nos registros de dados. Como texto em campos de dados pode includecommas, é preferível usar caracteres de tabulação.
  • Se um registro de dados não incluem informações de campo de dados específico, insira dois caracteres de tabulação ou duas vírgulas para indicar o campo theempty. Não insira um segundo delimitador de campo, se o campo de dados é somenteos no registro de dados.
  • Coloque o campo de dados entre aspas se o fieldcontains de dados qualquer um dos seguintes caracteres:
    • Um caractere de tabulação ou vírgula, se você estiver usando esse mesmo caractere para separar os campos
    • Uma quebra de linha ou uma marca de parágrafo
    • Um caractere que você especificou como o caractere separador de lista na seção International do Painel de controle do Microsoft Windows
  • Se as informações em um campo de dados contém aspas (""), digite os caracteres duas vezes ("" ""). Quando as informações do ismerged de campo de dados, apenas um par de aspas serão impresso.

Decidir quando usar uma fonte de cabeçalho separado

Na maioria dos casos, é conveniente listar o nome do campo para cada campo de dados na primeira linha ou registro de lista de endereços. No entanto, convém listar os nomes de campo em uma fonte de cabeçalho separado pelas seguintes razões:
  • Você pode usar os mesmos nomes de campo e de linha de cabeçalho para mergedata de várias fontes sem ter que repetir ou alterar a linha de cabeçalho ineach lista de endereços ou alterar os nomes de campo de mesclagem na maindocument.
  • Às vezes, uma lista de endereços de outro programa não notinclude um registro de cabeçalho, ou nomes de campo no registro de cabeçalho não coincidem themerge nomes de campo no documento principal. Se você não pode modificar ou adicionar um headerrecord na lista de endereços (por exemplo, porque a lista de endereços é somente leitura), você pode usar uma fonte de cabeçalho separado que contém os nomes dos campos que youspecify.

Adicionar o botão "Mala direta abrir fonte de cabeçalho"

Se você usar uma fonte de cabeçalho separado, você deve especificar a fonte de cabeçalho e a lista de endereços antes de mesclar o documento principal com a lista de endereços.

Para usar uma fonte de cabeçalho em uma mala direta do Word, você deve adicionar o botão de Mala direta abrir fonte de cabeçalho à barra de ferramentas mala direta . Para fazer isso, siga as etapas, conforme apropriado para a versão do Word que você está executando.
O Word 2002 ou Word 2003
  1. No menu Exibir , aponte para barras de ferramentase, em seguida, clique em mala direta. Aparece a barra de ferramentas mala direta .
  2. No menu Ferramentas, clique em Personalizar.
  3. Na guia ' comandos ', selecione Todos os comandos na lista categoria .
  4. Na lista comandos , selecione e arraste o MailMergeOpenHeaderSource à barra de ferramentas mala direta .
  5. Clique em Fechar para fechar a caixa de diálogo Personalizar .
Word 2007
Para usar uma fonte de cabeçalho em uma mala direta do Word no Word 2007, você deve adicionar o botão de Mala direta abrir fonte de cabeçalho para a barra de ferramentas de acesso rápido.
  1. No Word, clique no Botão do Microsoft Office.
  2. Clique em Opções do Word.
  3. Clique em Personalização.
  4. Na caixa de diálogo Escolher comandos em , clique em Todos os comandos.
  5. Clique em Mala direta abrir fonte de cabeçalhoe, em seguida, clique em Adicionar.
  6. Clique em OK.
Word 2010


Para usar uma fonte de cabeçalho em uma palavra mala direta no Word 2007, adicione o botão de mala direta abrir fonte de cabeçalho para a barra de ferramentas de acesso rápido.

  1. Escolha as Opções na guia arquivo .
  2. Escolha Personalizar faixa de opções.
  3. Em Escolher comandos em, substitua Os comandos populares com Todos os comandos.
  4. Clique em Mala direta abrir fonte de cabeçalhoe, em seguida, clique em Adicionar.
    Observação: talvez você precise adicionar uma nova guia antes de adicionar o comando à faixa de opções.
  5. Clique em OK.


Criar uma fonte de cabeçalho

Quando você especifica uma fonte de cabeçalho, lembre-se as seguintes regras:
  • O número de nomes de campo na fonte de cabeçalho deve equalthe o número de campos de dados na lista de endereços.
  • Nomes de campo na fonte de cabeçalho devem estar listados no sameorder como as informações correspondentes na lista de endereços.
  • Use o mesmo delimitador de campo (um caractere de tabulação ou o acomma) para a fonte de cabeçalho e a lista de endereços.
  • Se o documento principal já contiver campos de mesclagem, usar mesmo Mesclar campos na sua fonte de cabeçalho. Se você não fizer isso, você mustreplace os campos de mesclagem no documento principal para coincidir com os nomes dos campos na fonte de theheader. Depois de você especificar uma fonte de cabeçalho, você pode editá-lo tão youedit a lista de endereços.

Usando um registro de cabeçalho de outra lista de endereços

Se você tiver uma lista de endereços que contém um registro de cabeçalho, você pode usá-lo como uma fonte de cabeçalho. Por exemplo, se você dividiu sua lista de endereços em vários documentos, você pode especificar os nomes dos campos no registro de cabeçalho da lista de endereços primeiro. Quando você mescla de outras listas de endereços que não têm um registro de cabeçalho, especifique a lista de endereços primeira como a fonte de cabeçalho. Em seguida, especifica cada uma das listas de endereços restantes sucessivamente.

O Word ignora os registros de dados da lista de endereços primeiro e usa o registro de cabeçalho.

Tipos de dados que você pode usar com mala direta

Você pode mesclar praticamente qualquer tipo de informações de uma fonte de dados de mala direta, incluindo o seguinte:
  • Qualquer texto ou números
  • Elementos gráficos para os quais você tem uma filterinstalled de gráficos


    Observação: Se os elementos gráficos estão contidos em uma lista de endereços de uma programother de palavra, você deve converter o arquivo usando um arquivo formatconverter.
  • Objetos criados em programas que suportam o objeto link andembedding (OLE), como o Equation Editor
  • Campos do Word que exibem um resultado, como um campo {=} (Formula)
Para adicionar informações diferente de texto ou números a uma lista de endereços que você criou no Word, você deve exibir a lista de endereços em uma janela de documento usando o comando Abrir no menu arquivo . Ou então, abra a lista de endereços no programa original que criou o documento. Em seguida, insira as informações na coluna apropriada e linha da tabela de lista de endereços.

Tipos de dados que você não pode usar

Você não pode mesclar textos ou elementos gráficos que estão contidos em um quadro na lista de endereços. No entanto, você pode posicionar campos de mesclagem dentro de quadros. Quando você mescla documentos, o texto e os gráficos da lista de endereços são posicionados no quadro.
OfficeKBHowTo inf dados fonte mailmerge WD2003 WD2007

Propriedades

ID do Artigo: 294688 - Última Revisão: 06/11/2016 23:08:00 - Revisão: 2.0

Microsoft Word 2010, Microsoft Office Word 2007, Microsoft Office Word 2003, Microsoft Word 2002 Standard Edition

  • kbhowtomaster kbmerge kbmt KB294688 KbMtpt
Comentários