Você recebe um erro de projeto do VBA corrompido quando tenta converter um banco de dados no Access 2002

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 294755
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Iniciante: Requer conhecimento da interface do usuário em computadores de usuário único.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Para uma versão deste artigo do Microsoft Access 2000, consulte 225946.
Sintomas
Ao tentar converter um banco de dados do Access 97 para o Access 2002, você receberá a seguinte mensagem de erro
Ocorreu um erro ao carregar Form_FormName. Deseja continuar.
seguido por uma segunda mensagem:
O Visual Basic para aplicativos de projeto no banco de dados está corrompido.
Causa
Você receber essas mensagens de erro quando o banco de dados que você está tentando converter não está em um estado compilado, ou se houve corrupção no banco de dados antes de você tentou convertê-lo para o Microsoft Access 2002.
Resolução
Para contornar esse comportamento, use um dos seguintes métodos.

Método 1: Compactar no Access 97

  1. Abra o banco de dados na versão anterior do Access.
  2. Abra qualquer módulo no modo de design.
  3. No menu Debug , clique em compilar e salvar todos os módulos .
  4. Feche o banco de dados.
  5. No menu Ferramentas , aponte para Utilitários de banco de dados e, em seguida, clique em Compactar bancos de dados .
  6. Converta o banco de dados novamente no Access 2002.
Observação : se você deseja usar esse método, mas já ter removido o Access 97 do seu computador, você tem duas opções:
  • Mover o banco de dados em um computador que ainda tem o Access 97 instalado e siga as etapas listadas no método 1.

    - ou -

  • Reinstale o Access 97 no seu computador.

    Se você reinstalar o Access 97, certifique-se de que instalar o Access 97 em uma pasta diferente da pasta onde você tem o Office XP instalado. Isso pode exigir que você alterar o local de instalação padrão durante a instalação do Access 97.

Método 2: Importar os objetos diretamente

  1. Inicie o Microsoft Access 2002.
  2. Crie um novo banco de dados em branco.
  3. No menu arquivo , aponte para Obter dados externos e, em seguida, clique em Importar .
  4. Selecione o banco de dados que você deseja converter para o Access 2002 e, em seguida, clique em Importar .
  5. Selecione os objetos em cada guia da caixa de diálogo Importar .
  6. Clique em Opções .
  7. Selecione as opções para importar relações , menus e barras de ferramentas e Especificações de importação e exportação .
  8. Clique em OK para executar a importação.
Observe que você deve adicionar quaisquer referências que seu projeto do VBA necessite clicando em referências no menu Ferramentas no Editor do Visual Basic.

Método 3: Remover referências para Utility.mda

  1. Abra o banco de dados na versão anterior do Access.
  2. Abra qualquer módulo no modo de design.
  3. No menu Ferramentas , clique em referências .
  4. Clique para desmarcar a caixa de seleção utilitário e, em seguida, clique em OK .
  5. No menu Debug , clique em Compilar todos os módulos .
  6. Feche o banco de dados.
  7. Converta o banco de dados novamente no Access 2002.
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.
Referências
Para obter mais informações sobre problemas de conversão, clique em Ajuda do Microsoft Access no menu Ajuda , digite converter um banco de dados no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Para obter informações adicionais sobre bancos de dados corrompidos, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
209137Como solucionar problemas e reparar um banco de dados Jet 4.0 danificado no Access 2000
Para obter informações adicionais sobre problemas, você pode encontrar ao tentar converter um banco de dados de uma versão anterior do Microsoft Access, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
224340Mensagem de erro: foram os erros de compilação durante a conversão ou habilitação de neste banco de dados...
OfficeErrorMessages 10015

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 294755 - Última Revisão: 12/06/2015 01:48:09 - Revisão: 4.0

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbprb kberrmsg kbpending KB294755 KbMtpt
Comentários