OFFXPDEV: Como criar arquivos de Ajuda em HTML Context-Sensitive

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 296231
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.

Este artigo se aplica a um banco de dados do Microsoft Access (.mdb) e para um projeto Microsoft Access (.adp).

Para uma versão deste artigo do Microsoft Office 2000 Developer, consulte 242433.
Sumário
Você pode criar arquivos compactados Ajuda em HTML (.chm) usando o HTML Help Workshop incluída no Microsoft Office XP Developer.

Este artigo demonstra como criar um arquivo de Ajuda em HTML simples em HTML Help Workshop e, em seguida, como usar o arquivo de Ajuda em um formulário do Microsoft Access. O arquivo de Ajuda usa as identificações do contexto para exibir tópicos de Ajuda diferentes, dependendo do qual você insere o ponteiro e clique no formulário.
Mais Informações
O método de criação de arquivos de Ajuda apresentados aqui requer HTML Help Workshop. Você pode instalá-lo a partir do CD do Microsoft Office XP Developer.

Para criar este arquivo de Ajuda em HTML de exemplo, execute essas etapas:
  1. Criar dois arquivos HTML: uma para o formulário e outra para o controle.
  2. Crie um arquivo mapa para definir o contexto de identificações.
  3. Crie um arquivo de alias associa cada identificação de tópico um tópico.
  4. Compile esses arquivos em HTML Help Workshop em um único arquivo HTML compactado (*.chm).
  5. Adicione o caminho para a propriedade ArquivoDeAjuda de um formulário de exemplo.
  6. Atribua IDs de contexto para o formulário e um controle no formulário.
  7. Teste o formulário.
O resultado é um formulário no qual você pode pressionar F1 enquanto estiver em uma caixa de texto específico para receber um tópico da Ajuda específica para essa caixa de texto. Quando você pressionar F1 em nenhum outro lugar no formulário, o tópico da Ajuda específicos de formulário é exibido.

Criando arquivos HTML

Para criar um arquivo HTML compactado com ajuda contextual, execute estas etapas:
  1. Clique em Iniciar , aponte para programas , aponte para HTML Help Workshop e, em seguida, clique em HTML Help Workshop .
  2. No menu arquivo , clique em novo , clique em projeto e, em seguida, clique em OK .

    Isso inicia o novo Assistente de projeto. Clique em Avançar .
  3. Na caixa de diálogo New Project - destino , nomeie o projeto MyProject e clique em Avançar .
  4. Clique em Avançar e, em seguida, clique em Concluir .
  5. No menu arquivo , clique em novo .
  6. Selecione o Arquivo HTML e, em seguida, clique em OK .
  7. Na caixa de diálogo HTML título , digite Ajuda do formulário e, em seguida, clique em OK .
  8. Entre as marcas <body>, digite Este é o tópico de Ajuda para o formulário inteiro .
  9. No menu arquivo , clique em Salvar arquivo como .

    A caixa de diálogo Salvar como será exibida.
  10. Salve o arquivo com o nome Test1.htm. Anote a pasta em que você salvar este arquivo.
  11. Feche o arquivo Test1.htm.
  12. No menu arquivo , clique em novo .
  13. Clique em Arquivo HTML e, em seguida, clique em OK .
  14. Na caixa de diálogo HTML título , digite Ajuda do controle e, em seguida, clique em OK .
  15. Entre as marcas <body>, digite Este é o tópico de Ajuda para o controle .
  16. No menu arquivo , clique em Salvar arquivo como .

    A caixa de diálogo Salvar como será exibida.
  17. Salve o arquivo com o nome Test2.htm. Anote a pasta em que você salvar o arquivo.

Criando o arquivo de mapa

  1. Clique no botão Add/Remove topic files .

    Ele é o segundo botão para baixo na guia Project .
  2. Adicionar os dois arquivos que você criou anteriormente: Test1.htm e Test2.htm.
  3. Clique em Iniciar e, em seguida, clique em Executar .
  4. Na caixa Abrir , digite Bloco de notas e, em seguida, clique em OK .
  5. No bloco de notas, digite as seguintes linhas:
    # define 1 1001
    # define 2 2001
  6. No menu arquivo , clique em Salvar como .
  7. Na caixa Salvar como tipo , altere o tipo para Todos os arquivos .
  8. Digite o nome de arquivo Map.h e, em seguida, clique em Salvar . Observe o local em que você salvar o arquivo.

Criando o arquivo de alias

  1. No bloco de notas, clique em novo no menu arquivo .
  2. Digite as seguintes linhas:
    1=test1.htm;
    2 = test2.htm;
  3. No menu arquivo , clique em Salvar como .
  4. Na caixa Salvar como tipo , altere o tipo para Todos os arquivos .
  5. Digite o nome do arquivo Alias.h , clique em Salvar e, em seguida, feche o Notepad.

Compilando um único arquivo HTML compactados

  1. No HTML Help Workshop, clique no botão HTML API informações .

    Este é o quarto botão para baixo no lado esquerdo da guia projeto .
  2. Na guia mapa , clique em Arquivo de cabeçalho .
  3. Clique em Procurar e, em seguida, navegue até o arquivo Map.h que você criou anteriormente no bloco de notas.
  4. Selecione Map.h , clique em Abrir e, em seguida, clique em OK .
  5. Clique na guia alias e, em seguida, clique em incluir .
  6. Clique em Procurar e, em seguida, navegue até o arquivo Alias.h que você criou anteriormente no bloco de notas.
  7. Selecione Alias.h , clique em Abrir e, em seguida, clique em OK .
  8. Clique em OK .
  9. No menu arquivo , clique em compilar . Clique em Sim quando for perguntado se você deseja salvar os arquivos primeiro.
  10. Compile o arquivo de ajuda como MyProject.
  11. Verifique se o arquivo MyProject.chm foi criado e anote o local.

Adicionar o caminho

  1. No Microsoft Access, crie um novo banco de dados chamado BancoDeDados1.mdb. Criá-lo no mesmo local no qual você criou o arquivo de Ajuda.
  2. No arquivo BancoDeDados1.mdb, crie o seguinte formulário:
       Form: Test1   -----------------   Caption: TestForm   Text box   ------------   Name: Field1   Text box   ------------   Name: Field2					
  3. No modo de exibição Design, clique no formulário e, em seguida, clique em Propriedades no menu Exibir .
  4. Clique na guia outros .
  5. Defina a propriedade ArquivoDeAjuda para MyProject.chm .

Atribuindo identificações de contexto

  1. Defina a propriedade IdentificaçãoDoContextoDaAjuda do formulário como 1001 e, em seguida, pressione ENTER.
  2. Selecione o controle campo2 e, em seguida, clique em Propriedades no menu Exibir .
  3. Clique na guia outros .
  4. Defina a propriedade IdentificaçãoDoContextoDaAjuda do controle campo2 como 2001 . Pressione ENTER.

Teste o formulário

  1. No menu Exibir , clique em Modo formulário .
  2. Clique no controle campo1 e, em seguida, pressione F1.

    Observe que o tópico para o formulário é exibido. Isso ocorre porque o controle campo1 não tem um tópico associado e, portanto, será padronizado como o tópico de forma geral.
  3. Feche o tópico da Ajuda.
  4. Clique no controle campo2 e, em seguida, pressione F1.

    Observe que o tópico sobre o controle campo2 é exibido.
Referências
Para obter mais informações sobre como criar arquivos de cabeçalho, clique em HTML Help Workshop Ajuda do Microsoft no menu Ajuda , digite arquivos de cabeçalho no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.
OfficeKBHowTo

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 296231 - Última Revisão: 12/06/2015 02:07:13 - Revisão: 2.1

Microsoft Office XP Developer Edition, Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbhowto kbinfo KB296231 KbMtpt
Comentários