WD2000: Como mesclar uma única fonte de dados para várias cartas com IncludeText

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 299837
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
Quando você usa o recurso mala direta do Microsoft Word, você pode usar apenas um documento principal com uma fonte de dados. No entanto, com se e campos de AutoTexto, ou se e campos IncludeText, você pode simular mesclar uma fonte de dados em várias letras.

Campos de AutoTexto armazenam suas informações em entradas de AutoTexto. Campos IncludeText armazena suas informações em letras separadas. Ambos os métodos produzirem os mesmos resultados.

Este artigo descreve como você pode usar os campos IncludeText para produzir várias letras usando uma fonte de dados.

Para obter informações adicionais sobre como usar o AutoTexto método em vez disso, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
211786Como mesclar uma única fonte de dados para várias letras usando entradas de AutoTexto
Mais Informações
Para mesclar uma fonte de dados único para várias letras usando campos IncludeText, siga estas etapas.

Etapa 1: Configurar o documento principal de mala direta

Para criar uma mala direta para produzir várias letras diferentes para pessoas diferentes com base em um determinado conjunto de critérios, você deve primeiro crie e salve as letras separadas que contêm os campos de mesclagem que você deseja usar.
  1. No menu Ferramentas , clique em mala direta .
  2. Na seção documento principal da caixa de diálogo Auxiliar de mala direta , clique em criar e clique em cartas . Na próxima caixa de diálogo que aparece, clique em Janela .
  3. Para usar uma fonte de dados existente, clique em Obter dados e, em seguida, clique em Abrir fonte de dados . Na caixa de diálogo Abrir fonte de dados , localizar sua fonte de dados e, em seguida, clique em Abrir .
  4. Na caixa de mensagem que aparece, clique em Editar documento principal .
  5. Crie a primeira letra. Insira os campos de mesclagem apropriado.
  6. No menu arquivo , clique em Salvar como e, em seguida, nomeie o arquivo. Por exemplo, digite Letter1 . Clique em Salvar .

    Observação : você deve conhecer o caminho para esse arquivo; por exemplo, se for Letter1 na pasta Meus documentos na unidade C, o caminho é c:\Meus Documents\Letter1.doc. Você precisará inserir essas informações no documento principal criado posteriormente.
  7. Altere essa letra conforme apropriado para a segunda letra. Inserir campos de mesclagem conforme apropriado e salve o arquivo com um nome diferente, como Letter2.doc.
  8. Repita as etapas 6 e 7 para cada carta que você deseja criar. Ao nomear os arquivos, use nomes de arquivo diferentes, como "Letter2", "Letter3" e assim por diante.

Etapa 2: Modificar a fonte de dados

Depois de criar todas as letras como arquivos separados, você precisará modificar sua fonte de dados para incluir um campo que será útil para identificar qual letra criará para um determinado registro. Para fazer isso, execute as seguintes etapas:
  1. Com a última letra de mala direta que você criou na seção "Configuração da mala direta principal documento", anteriormente neste artigo, clique em Selecionar tudo no menu Editar e, em seguida, pressione DELETE para excluir tudo do documento.
  2. No menu arquivo , clique em Salvar como , atribua-lhe um nome de arquivo diferente, como Main.doc e, em seguida, clique em Salvar .

    Este documento se tornará o documento principal de mala direta que você executará a mesclagem de.
  3. No menu Ferramentas , clique em mala direta . Em Fonte de dados , clique em Editar e, em seguida, clique no nome do arquivo de dados. A caixa de diálogo Formulário de dados será exibida.
  4. Clique em Exibir código fonte para exibir a fonte de dados em um formato de tabela.
  5. Para criar um novo campo, clique no botão Gerenciar campos na barra de ferramentas mala direta .
  6. Na caixa nome do campo , digite um nome de campo (por exemplo, digite código ), clique em Adicionar e, em seguida, clique em OK .
  7. Insira um código para cada um dos registros para identificar qual letra será usada durante a mesclagem para esse determinado registro. Por exemplo, se você criou três letras, para cada registro na fonte de dados, digite um 1, 2 ou 3 no campo código . Código 1 representa Letter1 código 2 representa Letter2; código 3 representa Letter3 e assim por diante.
  8. Salve o arquivo de dados e clique no botão de Documento principal de mala direta na barra de ferramentas mala direta para retornar ao documento principal.

Etapa 3: Modificar o documento principal

Você precisará modificar o documento principal em branco (Main.doc) para incluir campos de se identificam qual letra IncludeText será mesclada para cada registro em particular.
  1. Na parte superior do documento em branco, execute estas etapas para inserir um campo IF no documento:
    1. Clique no botão Inserir campo do Word na barra de ferramentas Mala direta.
    2. Clique em se... Em seguida... Outra... .
    3. Na lista Nome do campo, selecione o campo que você criou na fonte de dados na seção "Etapa 2: modificar a fonte de dados", anteriormente neste artigo ( código no exemplo neste artigo).
    4. Na lista comparação , clique em igual a .
    5. Na caixa Comparar com , digite um valor que você usou no campo recém-criado (código), como 1, 2 ou 3.
    6. Clique em OK . Observação: Se você não vir as instruções de código de campo do documento, pressione ALT + F9 no teclado para ativar a exibição de código de campo.

      Se você usou o "Código" para a nome_do_campo e digitado em um valor de 1, o código de campo no documento deve parecer com o seguinte:

      {IF {MERGEFIELD Code} = 1 "" ""}
    7. Clique entre o primeiro conjunto de duas aspas e, em seguida, clique em campo no menu Inserir .
    8. Selecione a categoria vínculos e referências e clique em IncludeText na lista de Nomes de campos .
    9. Na caixa que lê INCLUDETEXT e, em seguida, digite o caminho e o nome completo para a primeira letra. Você deve colocar o caminho entre aspas e use barras invertidas duplas entre cada unidade, diretório e nome de arquivo.

      O código de campo concluído é semelhante à seguinte:

      {IF {MERGEFIELD Code} = 1 "{INCLUDETEXT "C:\\MY DOCUMENTS\\LETTER1.DOC" \*MERGEFORMAT}"}

      Você pode excluir o segundo conjunto de aspas. Eles são usados para uma condição Else que não é necessário para este exemplo.
  2. Selecione o campo se completa e copiá-lo. Colá-lo no documento tantas vezes quantas há letras diferentes com códigos correspondentes. Por exemplo, se houver três letras e três códigos, cole o campo para que haja três cópias dele.
  3. Nos campos colados, modificar o código usado para a comparação valor (1, 2 e assim por diante) e modificar o nome letra a ser usado (Letter1.doc, Letter2.doc e assim por diante).

    Se houver três letras diferentes a serem usadas na mala direta, o documento principal é semelhante à seguinte:
    {IF {MERGEFIELD Code} = 1 "{INCLUDETEXT "C:\\MY DOCUMENTS\\LETTER1.DOC" \*MERGEFORMAT}"}{IF {MERGEFIELD Code} = 2 "{INCLUDETEXT "C:\\MY DOCUMENTS\\LETTER2.DOC" \*MERGEFORMAT}"}{IF {MERGEFIELD Code} = 3 "{INCLUDETEXT "C:\\MY DOCUMENTS\\LETTER3.DOC" \*MERGEFORMAT}"}


  4. Salve o documento principal.

Etapa 4: Mesclar os documentos

Com o documento principal aberto, clique em mala direta no menu Ferramentas e, em seguida, clique em Mesclar . Opte por mesclar para novo documento e, em seguida, verifique que a letra correta é usada para os registros na fonte de dados apropriados.

Quando você executa a mala direta, o Word produz a letra com base no código que tem o arquivo de dados para um determinado registro. Por exemplo, se o registro 1 tem um valor código de 1, o Word produzirá Letter1. Se o registro 2 tem um valor código de 3, o Word usará Letter3.
Referências
Para obter mais informações sobre mala direta, clique em Ajuda do Microsoft Word no menu Ajuda , digite usando a mala direta no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 299837 - Última Revisão: 12/06/2015 02:54:42 - Revisão: 2.3

Microsoft Word 2000 Standard Edition

  • kbnosurvey kbarchive kbmt kbfield kbinfo kbmerge KB299837 KbMtpt
Comentários