ACC2002: Como criar um gráfico de Pareto que usa um modo de gráfico dinâmico

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 304180
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Sumário
Com um gráfico Pareto, você pode analisar facilmente dados categóricos. Em um gráfico Pareto, categorias são organizadas em ordem decrescente da esquerda para direita como colunas de histograma, com base em um critério numérico selecionado, dos valores mais alto ao mais baixo. Em seguida, uma linha de plotagem crescente para porcentagem cumulativa é sobreposta no gráfico de histograma. Dessa forma, você pode determinar rapidamente qual pequeno número de categorias compõe uma porcentagem significativa do valor total.

Este artigo mostra como criar um gráfico de Pareto básico que usa um modo de gráfico dinâmico que baseia-se a consulta Vendas por categoria no banco de dados de exemplo Northwind.mdb.
Mais Informações

Criar um gráfico Pareto

Para criar um gráfico Pareto no Microsoft Access, execute essas etapas.

cuidado : se você seguir as etapas neste exemplo, você modificar o banco de dados de exemplo Northwind.mdb. Convém fazer o backup do arquivo Northwind.mdb e seguir essas etapas numa cópia do banco de dados.

Crie a fonte de dados para o gráfico:

  1. Inicie o Microsoft Access e abra o banco de dados de exemplo Northwind.mdb.
  2. Na janela banco de dados, clique em consultas sob objetos e, em seguida, clique em Vendas por categoria .
  3. No menu Editar , clique em Copiar .
  4. No menu Editar , clique em Colar .
  5. Salve a cópia da consulta Vendas por categoria como qrySalesByCategory .
  6. Abra a consulta qrySalesByCategory no modo de design. Exclua o campo CódigoDaCategoria e o campo NomeDoProduto da grade de design da consulta. Defina a ordem classificação do campo ProductSales para Decrescente .
  7. No menu consulta , clique em Criar tabela para alterar a consulta para uma consulta criar tabela. Na caixa de diálogo Criar tabela , digite tblSalesByCategory na caixa Nome da tabela .
  8. Salve a consulta e executá-lo. Aceite a mensagem para colar linhas para uma nova tabela.
  9. Feche a consulta.
  10. Na janela banco de dados, clique em consultas sob objetos e, em seguida, clique em novo para criar uma nova consulta.
  11. Na caixa de diálogo Nova consulta , clique em Modo de design e, em seguida, clique em OK .
  12. Na caixa de diálogo Mostrar tabela , clique em tblSalesByCategory , clique em Adicionar e, em seguida, clique em Fechar .
  13. Arraste o campo NomeDaCategoria à grade de design da consulta.
  14. Na próxima coluna na grade de design da consulta, digite o seguinte na linha campo :
    ProductSalesTotal: [ProductSales]
  15. Na próxima coluna na grade de design da consulta, digite o seguinte na linha campo :

    Observação : no exemplo a seguir, um sublinhado (_) no final de uma linha é usado como um caractere de continuação de linha. Remova o sublinhado do final da linha quando você recriar este exemplo.
    CumPct: DSum("[ProductSales]","tblSalesByCategory", _
    "[ProductSales] > =" & [ProductSalesTotal] _
    &"") /DSum("[ProductSales]","tblSalesByCategory")
  16. Salve a consulta como qrySalesByCategoryPareto e fechá-lo.

Crie um formulário de gráfico:

  1. Na janela banco de dados, clique em formulários sob objetos e, em seguida, clique em novo para criar um novo formulário.
  2. Na caixa de diálogo Novo formulário , clique em AutoFormulário: gráfico dinâmico , clique em qrySalesByCategoryPareto na caixa Escolher tabela ou consulta onde vêm os dados do objeto e, em seguida, clique em OK .
  3. Arraste o nome da categoria da lista de campo de gráfico para a área Solte campos de categoria aqui .
  4. Arraste ProductSalesTotal da lista de campo de gráfico para a área Solte campos de dados aqui .
  5. Arraste CumPct da lista de campo de gráfico para a área Solte campos de dados aqui .
  6. Feche a lista de campo gráfico .

Modificar o design de gráfico:

  1. Clique com o botão direito do mouse no espaço em branco fora do gráfico e, em seguida, clique em Propriedades .
  2. Na guia Geral da caixa de diálogo Propriedades , defina a caixa Select a Soma de CumPct .
  3. Na guia tipo da caixa de Propriedades , clique em linha como o tipo de gráfico e clique na primeira imagem no painel à direita.
  4. Clique na guia Geral e defina caixa Selecionar o espaço de trabalho do gráfico .
  5. Clique na guia Grupos de séries .
  6. Na caixa Selecione um ou mais série , clique em soma 2 de CumPct , verifique se Novo grupo é selecionado na caixa de operação e, em seguida, clique em OK .
  7. Na caixa Adicionar eixo , clique em 2 , clique em direita , na caixa posição do eixo e, em seguida, clique em Adicionar .
  8. Na guia Geral , defina a caixa Selecionar 2 de eixo de valor .
  9. Na guia Formatar , clique em porcentagem na lista número .
  10. Feche a caixa de diálogo Propriedades .
  11. Clique com o botão direito do mouse dentro da primeira coluna de dados, aponte para Classificar e, em seguida, clique em Classificar em ordem decrescente .
  12. Salve o formulário.
Agora você tem um gráfico de Pareto mostra as categorias de vendas encomendada do produto e seus correspondentes porcentagens.
inf pivotchart de gráfico de pareto

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 304180 - Última Revisão: 12/06/2015 04:11:32 - Revisão: 3.0

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbhowto KB304180 KbMtpt
Comentários