ACC2000: Como criar uma tabela em um banco de dados do Access

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 304262
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Iniciante: Requer conhecimento da interface do usuário em computadores de usuário único.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Para uma versão deste artigo do Microsoft Access 2002, consulte 304238.
Sumário
Na interface de usuário do Microsoft Access, você pode criar uma tabela em um banco de dados usando qualquer um dos três métodos a seguir:
  • Você pode criar uma tabela usando o Assistente de tabela.
  • Você pode criar uma tabela inserindo dados em uma folha de dados.
  • Você pode criar uma tabela no modo Design.
Este artigo mostra como usar cada um desses métodos.
Mais Informações

Criando uma tabela usando o Assistente de tabela

Microsoft Access possui um assistente denominado o Assistente de tabela que irá criar uma tabela para você. Este assistente lhe oferece sugestões sobre que tipo de tabela que você pode criar (por exemplo, uma tabela de lista de endereçamento, uma tabela estudantes, uma tabela de tarefas e assim por diante) e oferece muitos nomes diferentes possíveis para campos dentro dessas tabelas. Para usar o Assistente de tabela para criar uma tabela, execute essas etapas:
  1. Crie um novo banco de dados em branco.
  2. Na janela banco de dados, clique em tabelas sob objetos e, em seguida, clique em novo .
  3. Na caixa de diálogo Nova tabela , clique duas vezes Assistente de tabela .
  4. Siga as instruções nas páginas do Assistente de tabela.
Se você quiser modificar a tabela que cria o Assistente de tabela, abra a tabela no modo de design quando você terminar usando o Assistente de tabela.

Criando uma tabela inserindo dados em uma folha de dados

No Microsoft Access, você também pode criar uma tabela inserindo dados apenas em colunas (campos) em uma folha de dados. Se você inserir dados que é consistentes em cada coluna (por exemplo, somente nomes em uma coluna), ou somente os números de outra coluna, o Access atribuirá automaticamente um tipo de dados para os campos. Para criar uma tabela inserindo dados apenas em uma folha de dados, execute essas etapas:
  1. Crie um novo banco de dados em branco.
  2. Na janela banco de dados, clique em tabelas sob objetos e, em seguida, clique em novo .
  3. Na caixa de diálogo Nova tabela , clique duas vezes Folha . Uma folha de dados em branco é exibida com nomes de coluna padrão campo1, campo2 e assim por diante.
  4. Renomeie cada coluna que você deseja usar. Para fazer isso, clique duas vezes o nome de coluna, digite um nome para a coluna e, em seguida, pressione ENTER.

    Você pode inserir colunas adicionais a qualquer momento. Para fazer isso, clique na coluna à direita de onde você deseja inserir uma nova coluna e, em seguida, no menu Inserir , clique em coluna . Renomeie a coluna conforme descrito anteriormente.
  5. Insira os dados na folha de dados. Insira cada tipo de dados em sua própria coluna. Por exemplo, se você estiver inserindo nomes, digite o nome na sua própria coluna e o sobrenome em uma coluna separada. Se você estiver inserindo datas, horas ou números, insira-os em um formato consistente. Se você inserir dados de maneira consistente, o Microsoft Access pode criar um tipo de dados apropriado e formato para a coluna de exibição. Por exemplo, para uma coluna na qual você insere somente nomes, o Access atribuirá o tipo de dados de texto; para uma coluna na qual você insere apenas números, o Access atribuirá um tipo de dados número. Todas as colunas que você deixar vazia serão excluídas quando você salvar a folha de dados.
  6. Quando você tenha adicionado dados a todas as colunas que você deseja usar, clique em Salvar no menu arquivo .
  7. Microsoft Access perguntará se você deseja criar uma chave primária. Se você não inseriu dados que podem ser usados para identificar exclusivamente cada linha na tabela, como números de peça ou um números de identificação, é recomendável que você clicar em Sim . Se você inseriu dados que identificam exclusivamente cada linha, clique em não e, em seguida, especifique o campo que contém os dados como sua chave primária no modo de design depois que a tabela foi salvo. Para definir um campo como sua chave primária depois que a tabela foi salvo, execute estas etapas:
    1. Abra a tabela Access criadas a partir de dados que você inseriu na folha de dados no modo de design.
    2. Selecione o campo ou campos que você deseja definir como chave primária.

      Para selecionar um campo, clique no seletor de linha para o campo desejado.

      Para selecionar vários campos, mantenha pressionada a tecla CTRL e, em seguida, clique no seletor de linha para cada campo.
    3. No menu Editar , clique em Chave primária .

      Se desejar que a ordem dos campos em uma chave primária de vários campos seja diferente da ordem desses campos na tabela, clique em índices na barra de ferramentas para exibir a janela Índices e em seguida, reordenar os nomes de campo para o índice denominado ChavePrimária.
    Como mencionado anteriormente, o Microsoft Access atribuirá tipos de dados a cada campo (coluna) com base no tipo de dados que você inseriu. Se você desejar personalizar ainda mais--a definição de um campo por exemplo, para alterar um tipo de dados Access atribuiu automaticamente, ou para definir uma regra de validação--abra a tabela no modo de design.

Criar uma tabela no modo Design

Se você deseja criar a estrutura de tabela básica você mesmo e definir todos os nomes de campos e tipos de dados, você pode criar a tabela no modo de design. Para fazer isso, execute estas etapas:
  1. Crie um novo banco de dados em branco.
  2. Na janela banco de dados, clique em tabelas sob objetos e, em seguida, clique em novo .
  3. Na caixa de diálogo Nova tabela , clique duas vezes Modo Design .
  4. Em < Nome da Tabela >: tabela diálogo caixa, definir os campos que você deseja incluir em sua tabela. Para fazer isso, execute estas etapas:
    1. Clique na coluna Nome do campo e, em seguida, digite um nome exclusivo para o campo.
    2. Na coluna Tipo de dados , aceite o tipo de dados padrão do texto que o Access atribui ou clique na coluna Tipo de dados , clique na seta e selecione o tipo de dados que você deseja.
    3. Na coluna Descrição , digite uma descrição das informações que este campo conterá. Essa descrição é exibida na barra de status quando você está adicionando dados para o campo e está incluído na definição do objeto da tabela. A descrição é opcional.
    4. Depois de adicionar alguns campos, talvez seja necessário inserir um campo entre dois outros campos. Para fazer isso, clique na linha abaixo de onde você deseja adicionar um novo campo e, em seguida, no menu Inserir , clique em linhas . Isso cria uma linha em branco no qual você pode adicionar um novo campo.

      Para adicionar um campo ao final da tabela, clique na primeira linha em branco.
  5. Após você ter adicionado todos os campos, defina um campo de chave primária antes de salvar sua tabela. Uma chave primária é um ou mais campos cujo valor ou valores identificam exclusivamente cada registro em uma tabela. Para definir uma chave primária, siga estas etapas:
    1. Selecione o campo ou campos que você deseja definir como chave primária.

      Para selecionar um campo, clique no seletor de linha para o campo desejado.

      Para selecionar vários campos, mantenha pressionada a tecla CTRL e, em seguida, clique no seletor de linha para cada campo.
    2. No menu Editar , clique em Chave primária .
  6. Se você desejar que a ordem dos campos em uma chave primária de vários campos seja diferente da ordem desses campos na tabela, clique em índices na barra de ferramentas para exibir a caixa de diálogo Índices e, em seguida, reordenar os nomes de campo para o índice denominado ChavePrimária.

    Não é necessário definir uma chave primária, mas geralmente é uma boa idéia. Se você não definir uma chave primária, o Microsoft Access perguntará se você deseja Access para criar um para você quando você salva a tabela.
  7. Quando estiver pronto para salvar sua tabela, no menu arquivo , clique em Salvar e, em seguida, digite um nome exclusivo para a tabela.
Referências
Para obter informações adicionais sobre como criar tabelas no Microsoft Access, clique no tópico "Criando e Projetando tabelas" na página de Ajuda do Microsoft Access 2000 no seguinte site da Microsoft:
inf criar como construção tabela fazer configurar de design

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 304262 - Última Revisão: 12/06/2015 04:14:04 - Revisão: 3.0

Microsoft Access 2000 Standard Edition

  • kbnosurvey kbarchive kbmt kbhowto KB304262 KbMtpt
Comentários