Como adicionar campos de pesquisa em uma tabela do Microsoft Access

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

Novato: Requer conhecimentos de interface do usuário em computadores de usuário único.

Para obter uma versão deste artigo para o Microsoft Access 2000, consulte 304463.
Para obter uma versão deste artigo para o Microsoft Access 97, consulte 304464.
Sumário
No Microsoft Access, é possível adicionar um campo em uma tabela para pesquisar informações em outra tabela. Normalmente, você usa essa técnica quando deseja criar relações entre as tabelas. Por exemplo, talvez você tenha uma tabela Produtos com um campo Categoria que pesquisa o nome da categoria na tabela Categoria. Ao usar essa técnica, é possível armazenar o valor da chave principal somente na tabela Categorias, mas exibe o nome de Categoria mais útil.

Este artigo mostra como adicionar campos de pesquisa a uma tabela do Microsoft Access. Primeiro, ele mostra como usar um assistente para criar o campo de pesquisa e, em seguida, mostra como criar o campo de pesquisa manualmente.
Mais Informações

Usar um assistente para criar um campo de pesquisa

  1. Inicie o Access.
  2. No menu Ajuda, clique em Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.

    Observação No Access 2007, clique em Exemplo no painel Categorias de modelo, clique em Northwind 2007 e em Download.
  3. No menu Exibir, clique em Objetos de banco de dados e em Tabelas.

    Observação No Access 2007, no grupo Tabelas na guia Criar, clique em Design da tabela.
  4. Clique duas vezes em Criar tabela no modo Design para criar uma nova tabela.

    Observação No Access 2007, ignore essa etapa.
  5. Digite PesquisarFuncionário na primeira linha em Nome do campo.
  6. Na coluna Tipo de dados, selecione Assistente de pesquisa.
  7. Na primeira página do Assistente de pesquisa, marque a caixa de seleção Eu quero que a coluna de pesquisa procure os valores em uma tabela ou consulta e clique em Avançar.
  8. Clique na tabela Funcionários na lista de tabelas e clique em Avançar.
  9. Clique duas vezes no campo Identificação, no campo Sobrenome e no campo Nome para adicionar os campos à lista de campos selecionados e clique em Avançar duas vezes.
  10. Verifique se a caixa de seleção Ocultar coluna chave está marcada e clique em Avançar.
  11. Clique em Concluir na primeira página do Assistente de pesquisa.
  12. Clique em Sim para salvar a tabela ao ser solicitado e nomeie a tabela como TestLookupWizard.
  13. Clique em Sim para adicionar uma chave principal à tabela ao ser solicitado.

    Observe que o assistente criará uma relação entre a nova tabela e a tabela Funcionários no banco de dados de exemplo do Northwind.
  14. No menu Exibir, clique em Modo folha de dados.

    Observação No Access 2007, abra a tabela no Modo folha de dados.
  15. Clique na seta suspensa no campo PesquisarFuncionário.

    Observe que duas colunas são exibidas na caixa de combinação.

Criar manualmente um campo de pesquisa

  1. Inicie o Access.
  2. No menu Ajuda, clique em Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.

    Observação No Access 2007, clique em Exemplo no painel Categorias de modelo, clique em Northwind 2007 e em Download.
  3. No menu Exibir, clique em Objetos de banco de dados e em Tabelas.

    Observação No Access 2007, no grupo Tabelas na guia Criar, clique em Design da tabela.
  4. Clique duas vezes em Criar tabela no modo Design para criar uma nova tabela.

    Observação No Access 2007, ignore essa etapa.
  5. Digite PesquisarFuncionário na primeira linha em Nome do campo.
  6. Na coluna Tipo de dados clique em Número.
  7. Na janela Propriedades do campo, clique na guia Pesquisa.
  8. Na lista Exibir Controle, clique em Caixa de combinação.
  9. Clique na caixa de propriedade Origem da linha, clique na seta que aparece, clique na lista Funcionários e clique em Criar para abrir o Construtor de consultas.
  10. Clique duas vezes no campo Identificação, no campo Sobrenome e no campo Nome para adicionar os campos à grade de consulta.
  11. No grupo Fechar na guia Design, clique em Fechar para sair do Construtor de consultas.
  12. Clique em Sim ao ser solicitado a salvar as alterações na instrução SQL.
  13. Verifique se a propriedade Coluna acoplada está definida como 1.

    Observação Essa propriedade corresponde ao campo na fonte de linha salva no campo. Nesse exemplo, o campo PesquisarFuncionário armazena o valor Identificação da tabela Funcionários.
  14. Altere o valor da propriedade Número de colunas para 3.

    Observação Esse valor representa o número de campos selecionados na fonte de linha.
  15. Digite 0";1";1" na caixa Larguras das colunas.

    Observação A propriedade Larguras das colunas é uma lista de largura separada por ponto-e-vírgula para cada coluna na fonte de linha. Defina a largura de uma coluna como 0" se deseja ocultar a coluna.
  16. Digite 2" na caixa Linhas da lista.
  17. No menu Exibir, clique em Modo folha de dados.

    Observação No Access 2007, abra a tabela no Modo folha de dados.
  18. Clique em Sim para salvar a tabela ao ser solicitado e nomeie a tabela como TestLookupWizard2.
  19. Clique em Sim para adicionar uma chave principal à tabela ao ser solicitado.
  20. Clique na seta suspensa no campo PesquisarFuncionário.

    Observe que duas colunas são exibidas na caixa de combinação.
OfficeKBHowTo inf Acc2002 Acc2003 ACC2007
Propriedades

ID do Artigo: 304462 - Última Revisão: 01/25/2008 22:23:43 - Revisão: 5.1

Microsoft Office Access 2007, Microsoft Office Access 2003, Microsoft Access 2002 Standard Edition

  • kbinfo kbexpertisebeginner kbdesign kbdatabase kbhowto KB304462
Comentários