Os usuários não podem ver informações de disponibilidade depois que uma caixa de correio é movida para o Microsoft 365

Sintomas

Depois que uma caixa de correio é movida para o Microsoft 365, um usuário local não pode ver as informações de disponibilidade para a caixa de correio no Assistente de Agendamento.

A captura de tela mostra que um usuário local não pode ver as informações de disponibilidade para a caixa de correio no Assistente de Agendamento.

Além disso, o usuário não pode mais exibir a pasta Calendário e recebe um erro "Não foi possível atualizar".

A captura de tela mostra que o usuário não pode mais exibir a pasta Calendário e recebe um erro.

Motivo

As permissões padrão da pasta Calendário são definidas como Nenhuma ou Colaborador. Quando você consulta informações de disponibilidade usando o Assistente de Agendamento em um cenário entre florestas, o serviço de Disponibilidade usa a relação de organização em vez de permissões de usuário delegadas. O Assistente de Agendamento faz solicitações entre florestas em nome da relação da organização, em vez de em nome do usuário que a está solicitando. A relação da organização é vinculada à conta padrão que é vista nas permissões de calendário. Portanto, ele não pode processar uma permissão explicitamente concedida, como "Disponibilidade" ou "Disponibilidade, assunto, local".

Solução alternativa

Quando as permissões padrão da pasta Calendário são definidas como Nenhuma ou Colaborador, os detalhes podem ser obtidos somente quando a delegação de usuário é usada anexando calendários diretamente à exibição de calendário do Outlook. Em uma implantação híbrida, a funcionalidade de disponibilidade e compartilhamento de calendário funciona de maneira diferente de quando ambos os usuários estão no mesmo ambiente. As permissões padrão determinam o tipo de informação de disponibilidade que os usuários em uma floresta remota podem ver. Se as permissões padrão forem definidas como Nenhuma ou Colaborador, nenhuma informação de disponibilidade será exibida para usuários remotos e os usuários não poderão exibir o calendário da caixa de correio. Isso ocorre porque nenhum tipo de permissão oferece nenhum nível de visibilidade de disponibilidade.

A captura de tela mostra que o nível de permissão padrão está definido como Colaborador, sem oferecer nenhum nível de visibilidade de disponibilidade.

A captura de tela mostra que o nível de permissão padrão está definido como Nenhuma, sem oferecer nenhum nível de visibilidade de disponibilidade.

Se um usuário remoto precisar ver informações de disponibilidade para a caixa de correio, o proprietário da caixa de correio poderá contornar esse problema alterando as permissões padrão para Disponibilidade ou Disponibilidade, assunto, local. Isso altera as informações de disponibilidade compartilhadas para todos os usuários remotos. Por exemplo, as permissões padrão podem ser definidas como Disponibilidade:

Captura de tela da alteração do nível de permissão padrão para Disponibilidade.

Os usuários remotos podem ver os dados de disponibilidade no Assistente de Agendamento:

Captura de tela que mostra que os usuários remotos podem ver os dados de disponibilidade no Assistente de Agendamento.

Ou os usuários remotos podem ver os dados de disponibilidade como um calendário adicional:

A captura de tela mostra que os usuários remotos podem ver os dados de disponibilidade como um calendário adicional.

Um usuário remoto pode receber permissões da pasta Calendário para obter acesso adicional ao conteúdo da pasta Calendário:

A captura de tela mostra que a permissão do usuário está definida como revisor, que pode ler Detalhes Completos.

Observação

A concessão da permissão Disponibilidade, assunto, local (Detalhes Limitados) é insuficiente em um ambiente híbrido. O usuário deve receber pelo menos a permissão de Revistor para exibir detalhes do item de calendário.

O usuário remoto (Usuário de Teste 1) agora pode ver a pasta Calendário da caixa de correio:

Captura de tela que mostra a pasta Calendário da caixa de correio.

Informações adicionais

Para obter informações adicionais sobre a configuração da disponibilidade entre florestas, clique no número abaixo para ler o respectivo artigo na Base de Dados de Conhecimento Microsoft:

3079932 Os usuários podem ver apenas informações básicas de caixa de correio de disponibilidade em uma floresta remota no Microsoft 365

Há algumas diferenças com as permissões de colaborador ao definir as permissões de calendário padrão ou quando você concede explicitamente uma permissão de calendário de usuário. Quando as permissões de calendário padrão são definidas, a Configuração de disponibilidade usa Nenhuma.

A captura de tela mostra que a configuração de Disponibilidade é definida como Nenhuma quando o nível de permissão de calendário padrão é definido como Colaborador.

Quando um usuário recebe direitos de colaborador, o nível de permissão é alterado automaticamente para Personalizado. Isso inclui a Disponibilidade.

A captura de tela mostra que o nível de permissão será alterado automaticamente para Personalizado depois que o usuário receber direitos de colaborador, o que inclui a disponibilidade.

Esse é o comportamento esperado, pois os usuários que podem criar itens em um calendário também podem ver a pasta e exibir informações de disponibilidade.