COMO: Enviar resultados do formulário para uma planilha do Microsoft Excel usando o FrontPage 2000

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 308692
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
Você pode criar um formulário no Microsoft FrontPage 2000 e tem os resultados do formulário gravados uma pasta de trabalho do Microsoft Excel 2000. Este artigo fornece um exemplo de como criar a pasta de trabalho e o formulário e, em seguida, como conectá-los.

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita, incluindo, mas não se limitando às garantias implícitas de comercialização e/ou adequação a uma finalidade específica. Este artigo presume que você esteja familiarizado com a linguagem de programação demonstrada e as ferramentas usadas para criar e depurar procedimentos. Profissionais de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades específicas.
Se você não tenha muita experiência de programação, talvez queira em contato com um Microsoft Certified Partner ou Microsoft Advisory Services. Para obter mais informações, visite da Microsoft:

Microsoft Certified Partners - https://partner.microsoft.com/global/30000104

Comunicado de Microsoft Services - http://support.microsoft.com/gp/advisoryservice

Para obter mais informações sobre as opções de suporte estão disponíveis e sobre como entrar em contato com a Microsoft, visite o seguinte site: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Para criar uma pasta de trabalho de exemplo e um formulário, siga estas etapas.

back to the top

Criar a pasta de trabalho Excel

  1. Inicie o Excel 2000.
  2. Na célula A1, digite First_name .
  3. Na célula B1, digite Last_name .
  4. Na célula C1, digite E_mail .
  5. Selecionar as células A1:C1.
  6. No menu Inserir , aponte para nome e, em seguida, clique em Definir .
  7. Clique em Adicionar e, em seguida, clique em OK .
  8. No menu arquivo , clique em Salvar como .
  9. Na caixa nome do arquivo , digite um nome para o arquivo e, em seguida, clique em Salvar .
  10. Feche o Excel.
back to the top

Criar o formulário

  1. Inicie o FrontPage 2000.
  2. Abra a Web que você deseja adicionar o formulário.
  3. No menu arquivo , aponte para novo e, em seguida, clique em página .
  4. Na guia Geral , clique em Página Normal e, em seguida, clique em OK .
  5. No menu Inserir , aponte para formulário e, em seguida, clique em formulário .
  6. No menu Inserir , aponte para formulário e, em seguida, clique em Caixa de texto de uma linha . Pressione ENTER.
  7. Repita a etapa 6 mais duas vezes.
  8. Clique em à esquerda da primeira caixa de texto e, em seguida, digite nome .
  9. Clique duas vezes na caixa de texto primeira.
  10. Na caixa nome , digite First_name e, em seguida, clique em OK .
  11. Clique à esquerda da segunda caixa de texto e digite Sobrenome .
  12. Clique duas vezes na caixa de texto segunda.
  13. Na caixa nome , digite Last_name e, em seguida, clique em OK .
  14. Clique à esquerda da terceira caixa de texto e digite E_mail endereços .
  15. Clique duas vezes na caixa de texto terceira.
  16. Na caixa nome , digite E_mail e, em seguida, clique em OK .
back to the top

Importar a pasta de trabalho para a Web

  1. No menu arquivo , clique em Importar .
  2. Clique em Adicionar arquivo , vá para e clique em pasta de trabalho da Excel e, em seguida, clique em Abrir .
  3. Clique em OK .
  4. Se você tiver uma pasta chamada fpdb na Lista de pastas , arraste a pasta de trabalho para a pasta fpdb e prossiga para o próximo conjunto de etapas.
  5. Na Lista de pastas , clique com o botão direito na pasta raiz da web e, em seguida, clique em Nova pasta .
  6. Digite fpdb e, em seguida, pressione ENTER.
  7. Arraste a pasta de trabalho para a nova pasta.
back to the top

Conectar-se a pasta de trabalho ao formulário

  1. No menu Ferramentas , clique em Configurações da Web .
  2. Na guia banco de dados , clique em Adicionar .
  3. Na caixa nome , digite um nome para esta conexão de banco de dados.
  4. Clique em arquivo ou pasta na Web atual e, em seguida, clique em Procurar .
  5. Na caixa arquivos do tipo , aponte para a seta e em seguida, clique em Microsoft Excel Driver .
  6. Vá para a pasta fpdb, clique na pasta de trabalho e, em seguida, clique em OK .
  7. Clique em Avançado e, em seguida, clique em Adicionar .
  8. Na caixa nome , digite ReadOnly .
  9. Na caixa valor , digite 0 e, em seguida, clique em OK .
  10. Clique em OK duas vezes.
  11. Clique em Verificar e, em seguida, clique em OK .
  12. Clicar com o botão direito do mouse em qualquer lugar no formulário e clique em Propriedades do formulário .
  13. Clique em Enviar para banco de dados e em seguida, clique em Opções .
  14. Na guia Resultados de banco de dados na caixa Conexão de banco de dados para usar , aponte para a seta e clique na conexão de banco de dados que você nomeou na etapa 3.
  15. Na caixa tabela para armazenar os resultados do formulário , aponte a seta e, em seguida, clique em nome .
  16. Na guia Campos salvos , clique em First_name , clique em Modificar e, em seguida, clique em OK .
  17. Repita a etapa anterior para campos de formulário Last_name e E_mail.
  18. Clique em OK duas vezes. Se você receber uma mensagem de erro sobre a extensão de arquivo da página, clique em OK .
  19. No menu arquivo , clique em Salvar como .
  20. Na caixa Salvar como tipo , aponte para a seta e, em seguida, clique em Active Server Pages .
  21. Digite um nome para o arquivo e, em seguida, clique em OK .
back to the top

Testar seu formulário

  1. Publicar sua Web. O servidor Web pode ser Microsoft Personal Web Server ou qualquer servidor com extensões do FrontPage.
  2. Vá para o formulário com seu navegador da Internet.
  3. Inserir texto em todos os campos do formulário.
  4. Clique em Enviar .
  5. Inicie o Excel.
  6. No menu arquivo , clique em Abrir .
  7. Procure o local publicado da Web e abra a pasta de trabalho.

    Observação : você deve ver que os dados enviados é na segunda linha da pasta de trabalho. Um envio subseqüente deve ser digitado na linha próxima não utilizada.
back to the top
Referências
Para obter informações adicionais sobre como instalar o Microsoft Personal Web Server em um computador com Windows 98, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
306898Como instalar o Microsoft Personal Web Server
back to the top
página frontal

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 308692 - Última Revisão: 12/06/2015 06:01:39 - Revisão: 1.6

Microsoft FrontPage 2000 Standard Edition

  • kbnosurvey kbarchive kbmt kbhowto kbhowtomaster KB308692 KbMtpt
Comentários