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Erro de "Erro de servidor no aplicativo '/'" ao tentar entrar em um aplicativo que está configurado para Azure AD B2C

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Sintomas
Quando você tenta entrar em um aplicativo que está configurado para a empresa Microsoft Azure AD (Active Directory) para o consumidor (B2C), você recebe a seguinte mensagem de erro:

Erro de servidor no aplicativo '/'

Código de status de resposta não indica o sucesso: 404 (não encontrado)

Descrição: Uma exceção não tratada ocorreu durante a execução da atual solicitação da web. Examine o rastreamento da pilha para obter mais informações sobre o erro e onde foi originado no código.

Detalhes da exceção: System.Net.Http.HttpRequestException: código de status de resposta não indica o sucesso: 404 (não encontrado)

Erro de origem: Uma exceção não tratada ocorreu durante a execução da atual solicitação da web. Informações relacionadas à origem e locais da exceção podem ser identificadas usando o rastreamento de pilha de exceção abaixo.

Rastreamento de pilha:


[IOException: não é possível obter o documento: https://login.microsoftonline.com/contoso.onmicrosoft.com/.well-known/openid-configuration?p=Policyname]
Causa
O nome da diretiva de inscrição pode ser ausente ou incorreto no arquivo Web. config para o aplicativo.
Resolução
Para corrigir esse problema, execute as seguintes etapas:
  1. Abra o arquivo Web. config para o aplicativo.
  2. No arquivo Web. config, verifique se a chave de aplicativo "ida: SignUpPolicyId" existe.
  3. Substitua o valor da chave do aplicativo com o nome da diretiva de inscrição fornecido no portal de administração do Azure AD B2C.

    A parte do arquivo alterada será semelhante ao seguinte:
    <appSettings></appSettings>

    <add key="ida:SignUpPolicyId" value=" key="ida:SignUpPolicyId" value=""></add key="ida:SignUpPolicyId" value=">B2C_Signup_Policy_Name">

Mais Informações

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 3092588 - Última Revisão: 09/17/2015 17:15:00 - Revisão: 1.0

Microsoft Azure Active Directory

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