Você está offline; aguardando reconexão

Registro falha quando você usar um aplicativo do Gerenciador de conexão de terceiros em um dispositivo baseado em Windows 8.1

IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.

Clique aqui para ver a versão em Inglês deste artigo: 3097526
Sintomas
Suponha que você tenha um dispositivo baseado em Windows 8.1 com um adaptador de banda larga móvel (MBN) (um adaptador 4g interno ou um pente LTE ou UMTS USB). No entanto, em vez da ferramenta interna do Windows, você usar um aplicativo do Gerenciador de conexão de terceiros para gerenciar sua conexão, como a de seu fornecedor de software independente (ISV) ou com o fabricante do adaptador MBN.

Nessa situação, considere os seguintes cenários.
  • Cenário 1

    Está em local que não é coberto pelo seu provedor de casa e, portanto, você está em roaming. No aplicativo do Gerenciador de conexões, você selecionar as opções4g e Registro automático .

  • Cenário 2

    Você bloqueou o PIN enquanto o aplicativo do Gerenciador de conexões foi configurado para selecionar automaticamente um operador. Em seguida, você desbloqueado seu PIN inserindo a chave de desbloqueio (PUK) pessoal. Finalmente, tentar selecionar manualmente um operador.
Em ambos os cenários, congela o aplicativo do Gerenciador de conexões e falha de registro com a rede do provedor. Quando esse problema ocorrer, você precisa reiniciar seu computador ou o serviço de rede de longa distância sem fio (WWANSVC).
Causa
O aplicativo do Gerenciador de conexões usa SetRegisterMode para alterar o modo de registro para a rede de banda larga móvel. No entanto, o WWANSVC não encaminha o aviso de rejeição da rede móvel para o aplicativo. Você espera WWANSVC para enviar um aviso OnSetRegisterModeComplete atualizar o aplicativo do Gerenciador de conexões sobre o status do registro.
Resolução
Importante: Siga cuidadosamente as etapas nesta seção. Problemas sérios poderão ocorrer se você modificar o registro incorretamente. Antes de modificá-lo, Faça backup do registro para restauração no caso de ocorrerem problemas.

Para resolver o problema, desative o mecanismo de conexão automática. Para fazer isso, defina a chave do registro de configuração automática como segue:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WwanSvc\AutoConfig
Nome: fEnabled
Tipo: REG_DWORD
Valor: 0
valores possíveis: 1 = ativado (padrão)
0 = desativado

Para a configuração tenha efeito, você deve reiniciar o WWANSVC.
Mais Informações
O cenário 1 ocorre quando as seguintes condições forem verdadeiras:
  • Rede móvel oferece 4G, 3G e 2G.
  • O WWANSVC tenta se conectar a 4G (conforme solicitado pelo aplicativo).
  • O operador da rede móvel rejeita a solicitação de registro (por exemplo, porque o contrato móvel permite apenas 3G).
  • O adaptador do MBN encaminha a rejeição por sinalização WwanRegisterStateDeregistered para WWANSVC.
  • O WWANSVC não atualiza o aplicativo, enviando OnSetRegisterModeComplete aviso.
Portanto, o aplicativo do Gerenciador de conexões não é notificado sobre o status da conexão.

Propriedades

ID do Artigo: 3097526 - Última Revisão: 10/16/2015 22:37:00 - Revisão: 1.0

Windows 8.1

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3097526 KbMtpt
Comentários
;