Tecla Caps Lock inesperadamente inverte os caracteres em uma sessão de área de trabalho remota para um computador baseado no Windows Server 2012

IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.

Clique aqui para ver a versão em Inglês deste artigo: 3120433
Sintomas
Suponha que você se conectar a um computador remoto em uma sessão de área de trabalho remota. Se um aplicativo, como winword.exe ou osk.exe, altera o status de teclas Caps Lock, essa alteração não será sincronizada novamente para o computador cliente.

Por exemplo, em uma sessão de área de trabalho remota, quando você abre o Microsoft Word, digite 'h', ativa Caps Lock pressionando-se o teclado e, em seguida, digite 'ELLO', a palavra é 'hELLO'. Em seguida, pressione a tecla Enter. Nessa situação, o 'hELLO' no Word será corrigido para 'Hello' automaticamente e Caps Lock está desativada na sessão da área de trabalho remota. Entretanto, no teclado físico do cliente, a luz Caps Lock é ainda e ele ainda estiver no status de Caps Lock no. Ela não é sincronizada com a sessão de área de trabalho remota status teclas Caps Lock.

Observação:

O recurso do Word que dispara esse problema é chamado 'Corrigir uso acidental da tecla cAPs LOCK' em Opções de AutoCorreção.

Em uma sessão de área de trabalho remota para um computador baseado no Windows Server 2008 R2, se podemos fazer as mesmas etapas, a tecla Caps Lock no teclado físico do cliente fica desativada status, que é sincronizado com a sessão de área de trabalho remota.
Causa
Esse problema ocorre porque o Windows Server 2012 e Windows Server 2012 R2 usam o "dispositivo de teclado de área de trabalho de remota" para lidar com as entradas de teclado nas sessões de área de trabalho remotas.
Resolução
Para fazer com que o cliente e a sessão de área de trabalho remota sincronização teclas Caps Lock novamente, é necessário minimizar a janela de sessão de área de trabalho remota ou clicar com o mouse fora da janela de sessão de área de trabalho remota e, em seguida, clique nela novamente.

Para aplicativos do Office, você pode desativar a Corrigir uso acidental da tecla cAPs LOCK em Opções de AutoCorreção para corrigir o problema. Por exemplo, siga estas etapas para 2016 do Word.
  1. Inicie o Word 2016, selecione arquivoe, em seguida, selecione Opções.
  2. Selecione Revisores de texto.
  3. Selecione o botão Opções de AutoCorreção .
  4. Desmarque a caixa de seleção Corrigir uso acidental da tecla cAPs LOCK .
  5. Clique em OK.

Propriedades

ID do Artigo: 3120433 - Última Revisão: 12/21/2015 02:17:00 - Revisão: 5.0

Windows Server 2012 Datacenter, Windows Server 2012 Standard, Windows Server 2012 R2 Datacenter, Windows Server 2012 R2 Standard

  • kbtermserv kbmt KB3120433 KbMtpt
Comentários