Você está offline; aguardando reconexão

O erro "Não foi possível acessar o serviço do Windows Installer" ocorre quando você tenta adicionar ou remover um programa no Windows XP ou Windows Server 2003

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Para continuar recebendo atualizações de segurança do Windows, certifique-se de que você está executando o Windows XP com o Service Pack 3 (SP3). Para obter mais informações, consulte esta página da Web da Microsoft: O suporte está terminando para algumas versões do Windows

Para suporte para este problema no Windows 7 e Windows Vista, consulte o artigo 2642495 na Base de Dados de Conhecimento Microsoft: Erro “Não foi possível acessar o serviço do Windows Installer” ao instalar ou atualizar programas no Windows 7 ou Windows Vista
Importante Este artigo é destinado aos usuários avançados. Caso não se sinta confortável com a solução de problemas avançada, solicite a ajuda de alguém. Ou, para obter ajuda do Atendimento ao Cliente Microsoft, vá para a página da Web Fale Conosco.
Sintomas
Quando você tenta instalar um aplicativo de software no Windows XP ou Windows Server 2003, você recebe a seguinte mensagem de erro:
O serviço Windows Installer não pôde ser acessado. Isso pode ocorrer se você estiver executando o Windows em modo de segurança, ou se o serviço Windows Installer não tiver sido devidamente instalado. Entre com contato com a equipe de suporte para obter ajuda.
Observação Esse problema também pode ocorrer quando você tenta desinstalar um aplicativo de software.
Causa
Esse problema poderá ocorrer se uma das seguintes condições for verdadeira:  
  • Os arquivos do Windows Installer em seu computador estão danificados ou ausentes.
  • Você instala ou remove um programa que usa o arquivo (.msi) do pacote de instalação de software da Microsoft do Windows Installer (MSI). Por exemplo, isso pode ocorrer quando você tenta instalar o Microsoft Office no seu computador.
Resolução
Para resolver esse problema, use os métodos a seguir.

Método 1: Registrar novamente o Windows Installer

Para registrar novamente o Windows Installer, verifique o local do arquivo Msiexec.exe no seu computador e no Registro do Windows e registre novamente o Windows Installer. Para fazer isto, clique aqui para expandir esta seção.e siga estas etapas.

Observação Como há várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se esse for o caso, consulte a documentação do produto para concluir essas etapas.
  1. Determinar o local do arquivo Msiexec. exe no seu computador. Para fazer isto, siga estas etapas:
    1. Clique em Iniciar, clique em Executar, digite %windir%\system32 e clique em OK.

      Observação Esta etapa abre a pasta onde o arquivo Msiexec.exe está localizado.
    2. Anote o local do arquivo Msiexec.exe. O local do arquivo Msiexec.exe é uma combinação do valor na caixa Endereço e o próprio nome do arquivo Msiexec.exe.

      Por exemplo, se a caixa Endereço contém um valor de C:\Windows\system32, o local do arquivo Msiexec.exe é C:\Windows\system32\Msiexec.exe.
  2. Importante Esta seção, este método ou esta tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, certifique-se de seguir essas etapas cuidadosamente. Para obter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
    322756 Como fazer backup e restaurar o Registro no Windows


    Certifique-se de que o local do arquivo Msiexec.exe no Editor do Registro está correto. Para fazer isto, siga estas etapas:
    1. Clique em Iniciar, em Executar, digite regedit na caixa Abrir e clique em OK.
    2. Expanda HKEY_LOCAL_MACHINE, expanda SYSTEM, expanda CurrentControlSet, expanda Serviçose clique em MSIServer.
    3. No painel à direita, clique com o botão direito do mouse em ImagePath e clique em Modificar.
    4. Na caixa Dados do valor, digite o local do arquivo Msiexec.exe que foi determinado na etapa 1, seguido do valor de /V e clique em OK.

      Por exemplo, se o local do arquivo Msiexec.exe é C:\Windows\system32\Msiexec.exe, digite o seguinte texto na caixa de texto Dados do valor:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Clique em OK para fechar a caixa de diálogo Editar Cadeia de Caracteres.
    6. No menu Arquivo, clique em Sair para fechar o Editor do Registro.
  3. Inicie o computador no modo de segurança e registre o arquivo Msiexec.exe. Para fazer isto, siga estas etapas:
    1. Clique em Iniciare clique em Desligar o computador ou Desligar.
    2. Selecione a opção Reiniciar e clique em OK, ou clique em Reiniciar.
    3. Pressione F8 antes da tela do Windows aparecer.
    4. No menu Opções Avançadas do Windows, use as teclas de seta para selecionar a opção Modo de Segurança e pressione Enter.
    5. Se você usa um computador de inicialização dupla ou inicialização múltipla, selecione o sistema operacional apropriado da lista e pressione Enter.
    6. Faça logon no computador.
    7. Clique em Iniciar, em Executar, digite msiexec /regserver na caixa Abrir e clique em OK.

      Observação Para os sistemas operacionais de 64 bits, você também precisará registrar novamente o instalador MSI de 64 bits. Para fazer isto, clique em Iniciar, clique em executar, digite %windir%\Syswow64\Msiexec /regserver na caixa Abrir e clique em OK.

      Em edições de 64 bits do sistema operacional Windows, os binários de 32 bits estão localizados na pasta %systemroot%\SysWow64.. Os binários de 64 bits estão localizados na pasta %systemroot%\System32.
    8. Clique em Iniciare clique em Desligar o computador ou Desligar.
    9. Selecione a opção Reiniciar e clique em OK, ou clique em Reiniciar.
Se o problema ainda ocorrer, e você ainda recebe a mensagem de erro mencionada na seção "Sintomas", siga as etapas no Método 2.

Método 2: Reinstalar o Windows Installer

Para reinstalar o Windows Installer, renomeie os arquivos danificados do Windows Installer e reinstale o Windows Installer. Para fazer isto, clique aqui para expandir esta seção.e siga estas etapas:
  1. Clique em Iniciar, em Executar, digite cmd na caixa Abrir e clique em OK.
  2. Digite cd %windir%\system32 e pressione Enter.
  3. Digite attrib -r -s -h dllcache e pressione Enter.
  4. Digite ren msi.dll msi.old e pressione Enter.
  5. Digite ren msiexec.exe msiexec.old e pressione Enter.
  6. Digite ren msihnd.dll msihnd.old e pressione Enter.
  7. Digite sair e pressione Enter.
  8. No prompt de comandos, digite exit e pressione Enter.
  9. Clique em Iniciare clique em Desligar o computador ou Desligar.
  10. Selecione a opção Reiniciar e clique em OK, ou clique em Reiniciar.
  11. Faça logon no computador.
  12. Baixar e instalar a versão mais recente do Windows Installer. Para obter informações adicionais sobre como adquirir o Windows Installer, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
    893803 O Windows Installer 3.1 v2 (3.1.4000.2435) está disponível
  13. Clique em Iniciare clique em Desligar o computador ou Desligar.
  14. Selecione a opção Reiniciar e clique em OK, ou clique em Reiniciar.
Mais Informações
Clique aqui para ver mais informações sobre este problema. O Windows Installer 4.0 não está disponível como redistribuível para o Windows Vista. O Windows Installer 4.0 está incluído com o sistema operacional Windows Vista.

Se os métodos descritos neste artigo não resolverem o problema, entre em contato com os Serviços de Atendimento ao Cliente Microsoft para obter mais ajuda.

Este problema também pode ocorrer se a propriedade Tipo de inicialização para o serviço do Windows Installer for definida para um valor de Desabilitar. Para verificar se o serviço do Windows Installer está definido para um valor de Desabilitar, siga estas etapas:
  1. Clique em Iniciar, clique em Executar, digite services.msc na caixa Abrir e clique em OK.
  2. Na lista Serviços (Local) clique com o botão direito do mouse em Windows Installer e clique em Propriedades.
  3. Se a lista suspensa Tipo de inicialização for definida para um valor de Desabilitar, selecione a opção Manual da lista suspensa Tipo de inicialização e clique em OK.
  4. No menu Arquivo, clique em Sair.
Para obter mais informações sobre o Windows Installer, consulte Visão geral do Windows Installer no site do Microsoft Developer Network (MSDN). Para obter mais informações sobre como obter o mecanismo Windows Installer, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft :
292539 Como obter o mecanismo do Windows Installer
Propriedades

ID do Artigo: 315346 - Última Revisão: 07/16/2013 04:21:00 - Revisão: 7.1

Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Microsoft Windows XP Professional x64 Edition

  • kbresolve kberrmsg kbprb KB315346
Comentários
'><\/script>");