Você está offline; aguardando reconexão

Erro: Nenhum texto ou erro de violação de acesso ao ler um arquivo de Ajuda

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 319247
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.
Sintomas
Quando você visualiza um arquivo de Ajuda em HTML (extensão de nome de arquivo .chm), você receberá uma das seguintes opções:
  • Nenhum texto no corpo do arquivo de Ajuda
  • Uma mensagem de erro de violação de acesso
  • A seguinte mensagem de erro:
    "Página não pode ser exibida"
Causa
Um ou mais dos problemas na lista anterior podem ocorrer se o nome do arquivo CHM ou o caminho para o arquivo contém um sinal numérico (#). Se o nome do arquivo CHM contém o símbolo #, os tópicos no índice de conteúdo não irão aparecer. Se o caminho contém o símbolo #, você receberá uma mensagem de erro de violação de acesso.
Resolução
Para contornar esse problema, remova o símbolo # do nome do arquivo ou de caminho para o arquivo.
Situação
A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no começo deste artigo.
Mais Informações
Para verificar qual versão da Ajuda em HTML que você está usando, localize o arquivo Hhctrl.ocx no seu computador. Clique com o botão direito do mouse Hhctrl.ocx , clique em Propriedades e, em seguida, verifique se a correspondência de versão abaixo:

HHCTRL.OCX Ajuda em HTML normalmente no sistema operacional
4.74.87021.3Windows 2000
4.74.87931.31Windows 2000(SP1)
4.74.88751,32Windows ME
4.74.92731.33Windows XP

Etapas para reproduzir o problema

Para reproduzir o problema, execute essas etapas:
  1. Localize qualquer arquivo CHM no computador que contém uma tabela de conteúdo. Renomeie o arquivo para que o nome do arquivo contém o símbolo #.
  2. Clique duas vezes no arquivo CHM. Observe que o índice analítico aparece, mas os tópicos não aparecem no painel mais à direita da janela da Ajuda.
  3. Altere o nome do arquivo do arquivo CHM com o nome original.
  4. Renomeie a pasta que contém o arquivo CHM para que o nome da pasta contém o símbolo #.
  5. Clique duas vezes no arquivo CHM. Você receber uma mensagem de erro de violação de acesso.

    Observação : se você tentar reproduzir o comportamento em um computador que esteja executando o Windows XP, então é gerado um relatório de erros.
"A página não pode ser exibida" Ajuda "Violação de acesso" HTML CHM libra #

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 319247 - Última Revisão: 04/05/2002 19:03:00 - Revisão: 1.0

Microsoft HTML Help 1.3, Microsoft HTML Help 1.31, Microsoft HTML Help 1.32

  • kbmt kbbug kbpending KB319247 KbMtpt
Comentários
s.dqid"; document.getElementsByTagName("head")[0].appendChild(m);