Mensagem de erro "Operação não pôde ser concluída devido a falha mecanismo de banco de dados ou de diálogo" ao tentar executar uma mala direta

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 322215
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Quando você seleciona uma fonte de dados para uma mala direta no Microsoft Word, você receberá uma mensagem de erro semelhante à seguinte:
A operação não pôde ser concluída devido a falha mecanismo de banco de dados ou de diálogo. Tente novamente mais tarde.
Como resultado, não é possível executar a mala direta.
Causa
Esse problema pode ocorrer se os arquivos do Microsoft Data Access Component (MDAC) no seu computador não são a versão mais recente.

Para obter mais informações sobre o Microsoft Component Checker e como usá-lo para determinar a versão do MDAC, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
307255Component Checker: Diagnosticar problemas e reconfigurar instalações de MDAC
Esse problema também pode ocorrer se o Microsoft Jet 4.0 OLE DB Provider não está registrado.
Resolução
Para resolver esse problema, use um dos seguintes métodos.

Método 1: Atualizar o Microsoft Data Access Component (MDAC) arquivos

Atualizar os arquivos Microsoft Data Access Component (MDAC) no seu computador e, em seguida, fazer uma operação "Detectar e reparar" no Word. Para fazer isso, execute as seguintes etapas:
  1. Para baixar e instalar a versão mais recente do MDAC, visite o seguinte site:
  2. Use o recurso Detectar e Reparar no Word para reparar problemas associados à instalação do Microsoft Office (como arquivos ausentes e configurações do Registro). Para fazer isso, execute as seguintes etapas:
    1. Inicie o Word.
    2. No menu Ajuda , clique em detectar e reparar .
    3. Clique para selecionar a caixa de seleção Descartar minhas configurações personalizadas e restaurar configurações padrão e, em seguida, clique em Iniciar .

Método 2: Registrar o Microsoft Jet 4.0 provedor OLE DB

Você poderá resolver o problema registrando novamente o Jet 4.0 provedor Microsoft OLE DB. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite CMD e, em seguida, clique em OK .
  2. Digite CD %WINDOWS%\SYSTEM32 e, em seguida, pressione ENTER.
  3. Digite regsvr32 MSJETOLEDB40.DLL e, em seguida, pressione ENTER.
  4. Clique em OK se você for solicitado.
  5. Digite exit e pressione ENTER.
Como Contornar
Para contornar esse problema, use um dos seguintes métodos, conforme adequado à sua situação.

Método 1: Usar auxiliar de mala direta

Para usar o auxiliar de mala direta, execute estas etapas:
  1. No menu Ferramentas , clique em Personalizar .
  2. Clique na guia comandos .
  3. Na lista categorias , clique em todos os comandos .
  4. Na lista comandos , arraste MailMergeHelper para a barra de ferramentas que você deseja.
  5. Clique em Fechar .
  6. Clique no botão Auxiliar de mala direta que você inseriu na barra de ferramentas na etapa 4 e, em seguida, siga as instruções na tela para executar a mala direta.

Método 2: Iniciar a mala direta do Microsoft Outlook

Para iniciar a mala direta no Outlook, use o procedimento no seguinte artigo na Base de dados de Conhecimento da Microsoft:
320838Mensagem de erro "a operação não pôde ser concluída devido a falha mecanismo de caixa de diálogo ou banco de dados" Se você usar contatos do Outlook para uma mala direta
Mais Informações
Para obter mais informações sobre mala direta, clique em Ajuda do Microsoft Word no menu Ajuda , digite mala direta no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.
Para obter mais informações sobre como usar contatos do Outlook em uma mala direta do Word, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
294697Como usar a lista de contatos do Outlook com a mala direta no Word 2002
Para obter mais informações sobre como configurar os documentos de mala direta no Word, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
290408Perguntas freqüentes sobre mala direta no Word 2002
294684Como usar a mala direta para criar etiquetas de endereçamento no Word 2002
294685Como usar mala direta para criar envelopes no Word 2002
294683Como usar mala direta para criar cartas de formulário no Word 2002
PRB OFFXP WD2002

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 322215 - Última Revisão: 12/07/2015 10:56:26 - Revisão: 3.2

Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kberrmsg kbprb KB322215 KbMtpt
Comentários