Pode demorar 35 segundos para excluir arquivos através da rede

O suporte para o Windows XP terminou

A Microsoft terminou o suporte para o Windows XP em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

O suporte para o Windows Server 2003 termina em 14 de julho de 2015.

A Microsoft terminou o suporte para o Windows Server 2003 em 14 de julho de 2015. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 811492
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Pode demorar aproximadamente 35 segundos para excluir arquivos através da rede. Esse problema ocorre aproximadamente 10 a 15 por cento do tempo. Um rastreamento de rede do problema mostra os quadros a seguintes:
Cliente-> Server - C NT Create & X, arquivo: \test.txt - solicitação de OpLock\OpBatch
Cliente-> Server - C excluir arquivos, File =: \test.txt
Servidor-> Client - R NT Create & X, FID = 0x8003 - nível de bloqueio = lote
Servidor-> Client - C bloquear - quebra de bloqueio
Um atraso de aproximadamente 35 segundos ocorre neste momento.
Servidor-> Client - R excluir Status_Sharing_Violation
Cliente-> Server - X de C de bloquear &, FID = 0x8003 - Break OpLock
Cliente-> Server - C excluir arquivos, File =: \test.txt
Servidor-> Client - R excluir
Os duas primeiras os quadros são do cliente. O quadro inicial é uma mensagem "NT criar" com uma solicitação de bloqueio/OpBatch para o arquivo. Isso é seguido pela solicitação de "Excluir" para o mesmo arquivo. O próximo quadro é resposta do servidor para a solicitação "Criar NT" com um nível de bloqueio de "lote". O servidor envia uma mensagem de OpLock Break para o quadro anterior para que ele pode excluir o arquivo. O servidor espera 35 segundos (até que seu valor de tempo limite OpLockBreakWait tenha expirado) antes da exclusão não funciona. O cliente pode, em seguida, liberar o bloqueio e tente novamente a exclusão.
Causa
Quando a solicitação de quebra de bloqueio é recebida pelo cliente, o cliente não pode processar a solicitação porque ela já está aguardando a excluir solicitação. O servidor não pode manipular a solicitação de exclusão até que o bloqueio no arquivo foi lançado. Isso faz com que uma condição de pseudo-deadlock é interrompida depois de valor do tempo limite do servidor OpLockBreakWait expira.
Resolução

Informações sobre o Windows XP service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix Windows Server 2003

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Este hotfix é substituído pelo hotfix documentada no seguinte artigo na Base de dados de Conhecimento da Microsoft: Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
885451Um atraso de 35 segundos ocorre quando você exclui um arquivo que está localizado em um compartilhamento de rede no Windows Server 2003

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size     File name   Platform   ----------------------------------------------------------------   26-Jun-2003  20:44  5.2.3790.67    393,728  Mrxsmb.sys  x86   26-Jun-2003  20:44  5.2.3790.67    157,184  Rdbss.sys   x86   26-Jun-2003  20:44  5.2.3790.67  1,121,792  Mrxsmb.sys  IA-64   26-Jun-2003  20:44  5.2.3790.67    462,336  Rdbss.sys   IA-64

Informações sobre o Windows XP hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Esse hotfix requer o Windows XP Service Pack 1.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version          Size     File name   Platform   ------------------------------------------------------------------   30-Jan-2003  16:41  5.1.2600.1164    400,896  Mrxsmb.sys  x86   30-Jan-2003  16:41  5.1.2600.1164    154,880  Rdbss.sys   x86   30-Jan-2003  16:41  5.1.2600.1164  1,259,392  Mrxsmb.sys  IA-64   30-Jan-2003  16:41  5.1.2600.1164    489,216  Rdbss.sys   IA-64

Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo. Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 811492 - Última Revisão: 01/12/2015 21:13:39 - Revisão: 5.11

Microsoft Windows XP Home Edition SP1, Microsoft Windows XP Professional SP1, Microsoft Windows XP Tablet PC Edition, Microsoft Windows XP Media Center Edition 2005 Update Rollup 2, Microsoft Windows XP 64-Bit Edition Version 2002 SP1, Microsoft Windows XP 64-Bit Edition Version 2003, Microsoft Windows Server 2003, 64-Bit Datacenter Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition

  • kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB811492 KbMtpt
Comentários