Como usar o depurador nativo Visual Studio .NET ou Visual Studio 2005 para depurar uma DLL de 6.0 do Visual Basic quando ele é chamado de um aplicativo ASP.NET

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 811658
Sumário
Este artigo passo a passo descreve como usar o depurador nativo do Microsoft Visual Studio .NET ou Microsoft Visual Studio 2005 para depurar uma DLL do Microsoft Visual Basic 6.0, quando ele é chamado de um aplicativo ASP.NET.

Para depurar aplicativos Visual Basic, use um dos seguintes métodos:
  • Usa o ambiente de desenvolvimento Visual Basic.

    Quando você depurar no ambiente de desenvolvimento, você usa código de P. Código de P é uma linguagem interpretada que lhe permite depurar no ambiente de desenvolvimento.

    - ou -
  • Use o depurador nativo se os problemas não forem exibidos quando você depurar no ambiente de desenvolvimento do Visual Basic, mas problemas aparecem na versão compilada.
Este artigo descreve como usar o segundo método para depurar uma DLL de 6.0 do Visual Basic que está sendo usado no ASP.NET. Você depurar a DLL usando o mesmo binário que a DLL executa com (não incluindo qualquer otimizações). Isso cria uma execução é mais fácil depurar do que o código P é exibida quando você depurar no ambiente de desenvolvimento do Visual Basic.

back to the top

Requisitos


A lista a seguir descreve o hardware recomendado, software, infra-estrutura de rede e service packs são necessários:
  • Microsoft Visual Studio .NET ou Microsoft Visual Studio 2005
  • Microsoft Visual Basic 6.0
  • Microsoft (IIS) 5.0 ou posterior
Este artigo pressupõe que você esteja familiarizado com os seguintes tópicos:
  • Sintaxe do Microsoft Visual Basic .NET ou Microsoft Visual Basic 2005
  • Sintaxe do Microsoft Visual Basic 6.0
  • Ambiente do Microsoft Visual Studio .NET ou Microsoft Visual Studio 2005
back to the top

Criar a DLL de 6.0 Visual Basic

  1. No IDE do Visual Basic 6.0, clique em New Project no arquivo menu.
  2. Na caixa de diálogo New Project , clique para selecionar DLL ActiveX e, em seguida, clique em OK .
  3. No Menu Exibir , clique em Propriedades .
  4. Na lista drop-down de caixa do diálogo de propriedades, clique em Class1 .
  5. Altere a propriedade Name para VB6Class .
  6. Adicione o seguinte código à sua classe para criar um método público em sua classe:
    Public Function showButtonValue() As Integer    showButtonValue = 1000End Function
  7. No menu Project , clique em Propriedades de Projeto1 .
  8. Clique na guia Compile e em seguida, clique para selecionar Sem otimização .
  9. Clique para selecionar Criar informações de depuração simbólico caixa de seleção.
  10. Clique na guia Geral , altere o Nome do projeto para VB6DlltoCall e, em seguida, clique em OK .
  11. No menu arquivo , clique em tornar VB6DlltoCall.dll .
  12. Clique para selecionar a pasta do Visual Basic 6.0 e, em seguida, clique em OK para salvar VB6DlltoCall.dll.

    Observação Seu projeto Visual Basic 6.0 é armazenado na pasta Visual Basic 6.0 .
  13. No menu Project , clique em Propriedades VB6DlltoCall .
  14. Clique na guia componentes , clique para selecionar Binary Compatibility e, em seguida, clique em OK .
  15. No menu arquivo , clique em Salvar projeto e, em seguida, clique na pasta Visual Basic 6.0 para salvar o arquivo de classe e projeto.

    Observação VB6Class.CLS é o nome do arquivo de classe que você depurar. Portanto, você pode aceitar apenas os nomes padrão.
  16. No menu arquivo , clique em tornar VB6DlltoCall.dll .

    Observação Ao criar o arquivo de uma segunda vez, você recebe uma mensagem sobre substituir o arquivo existente. Permitir que o compilador para substituir a DLL existente.
  17. No menu arquivo , clique em Sair para fechar o projeto Visual Basic 6.0.
  18. Abra a pasta de Visual Basic 6.0 que contém a DLL.
  19. Clique a DLL com o botão direito do mouse e, em seguida, clique para selecionar Propriedades .
  20. Clique na guia segurança .
  21. Clique no botão Adicionar .
  22. Digite o Computer Name \ASPNET e clique em Verificar nomes para verificar que você localize o ASP.NET conta.

    Observação Substitua o Nome do computador pelo nome do computador. A conta ASP.NET é a conta de usuário que executa o processo do operador do ASP.NET em. Se você não permite essa conta para executar sua DLL, sua classe não é criada e falhar com um erro "Acesso negado".
  23. Clique em OK .
  24. Verifique se esse Ler & executar estiver marcada para a conta ASP.NET e, em seguida, clique em OK .
back to the top

Criar o projeto do ASP.NET no Visual Studio .NET

  1. Inicie o Visual Studio NET..
  2. No menu arquivo , aponte para novo e, em seguida, clique em Project .
  3. Na caixa de diálogo New Project , clique para selecionar Projetos do Visual Basic em Tipos de projeto e, em seguida, clique para selecionar Aplicativo ASP.NET em modelos .
  4. Na caixa de texto local , digite o nome do projeto como http:// localhost / MyASPnetProject.

    Observação O nome do projeto, http:// localhost cria o aplicativo no servidor local.
  5. Clique em OK para criar o projeto.

Criar o ASP.NET 2.0 Project no Visual Studio 2005

  1. Inicie o Visual Studio 2005.
  2. No menu arquivo , aponte para novo e, em seguida, clique em Site .
  3. Na caixa de diálogo New Web Site , clique em Site do ASP .NET em modelos .
  4. Na caixa local , clique em HTTP e, em seguida, digite o nome do projeto como http:// localhost / MyASPnetProject.

    Observação O nome do projeto, http:// localhost cria o aplicativo no servidor local.
  5. Clique em Visual Basic na caixa idioma e, em seguida, clique em OK para criar o projeto.
back to the top

Depuração

  1. No projeto ASP.NET, clique no menu Project e, em seguida, clique em Add Reference .
  2. Clique em Procurar e, em seguida, clique em VB6DlltoCall.dll (criado anteriormente).
  3. Clique em Abrir e, em seguida, clique em OK .

    Observação No Visual Studio 2005, você não tem clique em Abrir .
  4. Adicione um botão da caixa de ferramentas a WebForm1.aspx.
  5. Clique duas vezes botão e, em seguida, adicione o código a seguir para Button1_Click evento no Webform1.aspx.vb:
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click   Dim cls As New VB6DlltoCall.VB6ClassClass()   Button1.Text = cls.showButtonValueEnd Sub
  6. No menu Build , clique em Build Solution .
  7. No menu Debug , clique em Iniciar sem depuração .

    Observação Inicie o aplicativo que você criou uma vez sem depuração para verificar se o processo do operador do ASP.NET foi iniciado e que você poderá anexar ao processo de trabalho na próxima etapa.
  8. No menu Debug , clique em Processes .
  9. Na caixa de diálogo Processes , clique para selecionar aspnet_wp.exe em Available Processes e, em seguida, clique em anexar .
  10. Na caixa de diálogo Attach to Process , clique para selecionar a caixa de seleção nativo e a caixa de seleção Common Language Runtime .

    Observação Se você não tiver a opção de depuração nativa, você não tem Microsoft Visual C++ .NET ou Microsoft Visual C++ 2005 instalado. Você deve instalar o Visual C++ .NET ou Visual C++ 2005 para a depuração para funcionar corretamente.
  11. Clique em OK e, em seguida, clique em Fechar .

    Observação Quando você clicar em OK , o depurador pode levar até cinco minutos para anexar.
  12. No Visual Studio .NET ou Visual Studio 2005 IDE, aponte para Abrir no menu arquivo e, em seguida, clique em arquivo .
  13. Clique na classe Visual Basic 6.0 (VB6Class.cls) de arquivo e, em seguida, clique em Abrir .
  14. Definir um ponto de interrupção no arquivo VB6Class.cls na linha de código a seguir:
    showButtonValue = 1000
  15. Alternar para a janela de navegador da Web que foi aberta com a página .aspx quando você clica em Start Without Debugging na etapa 7.
  16. Clique em botão na página Webform.aspx.

    Isso atinge o ponto de quebra no arquivo de classe Visual Basic 6.0 .
back to the top
Referências
Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
170946Como criar e usar um componente ActiveX mínimo em VB


303845Como criar ou abrir um projeto Visual Studio .NET na Web raiz

Propriedades

ID do Artigo: 811658 - Última Revisão: 12/06/2006 23:18:59 - Revisão: 3.5

Microsoft Visual Basic 2005, Microsoft Visual Basic .NET 2003 Standard Edition, Microsoft Visual Basic .NET 2002 Standard Edition, Microsoft Visual Basic 6.0 Professional Edition, Microsoft Visual Basic Enterprise Edition for Windows 6.0, Microsoft ASP.NET 1.1, Microsoft ASP.NET 1.0

  • kbmt kbvs2005applies kbvs2005swept kbwebforms kbdll kbcominterop kbweb kbdebug kbhowtomaster KB811658 KbMtpt
Comentários