Excel exibe valores incorretos quando você exporta um relatório do Access com números

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 823222
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Este artigo se aplica a um banco de dados do Microsoft Access (.mdb) e a um Microsoft Access (.adp) do projeto.

Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.
Sintomas
Você pode usar a opção de exportação no Access para exportar um relatório para o Microsoft Excel. Se o relatório tiver valores numéricos no campo de texto, planilha do Excel resultante poderá ter valores incorretos.

Esse problema também pode ocorrer quando você usar a opção analisar com o Microsoft Excel no Access.
Como Contornar
Para contornar esse problema, execute estas etapas:
  1. Concatene um caractere para os valores numéricos em um campo de texto. Você pode, por exemplo, concatenar um apóstrofo (').
  2. Exporte o relatório para o Excel.
  3. Remova o caractere concatenado do campo no Excel.
Para contornar o problema para o exemplo fornecido na seção "Passos para reproduzir o problema", execute estas etapas:
  1. Inicie o Access.
  2. Abra o banco de dados C:\MyExample.mdb.
  3. Na janela banco de dados em objetos , clique em relatórios .
  4. No painel direito, clique com o botão direito do mouse MeuRelatório e clique em Modo Design .
  5. Na seção detalhe , clique com o botão direito do mouse na caixa de texto MeuTexto e em seguida, clique em Propriedades .
  6. No caixa de texto: myText diálogo, clique na guia dados .
  7. Na caixa OrigemDoControle , digite = [MeuTexto] & "'".
  8. Clique na guia todas e altere o valor de nome de propriedade para MyText1 .
  9. Clique no ícone de Visualização .
  10. No menu Ferramentas , aponte para Vínculos do Office e clique em seguida, em analisar com o Microsoft Excel .
Você pode ver que os valores em MeuTexto coluna exibir corretamente. No entanto, os valores têm um sufixo de caractere de apóstrofo.

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.

Para remover o sufixo de caractere de apóstrofo da coluna MeuTexto no Excel, execute essas etapas:
  1. Selecione as colunas que têm o sufixo de caractere de apóstrofo.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. Na janela Project - projeto VBA , clique em ThisWorkbook .
  4. No menu Exibir , clique em código .
  5. Cole o seguinte código no código janela:
    Private Sub Workbook_Open()      Selection.Replace What:="'", Replacement:="", LookAt:=xlPart, _        SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _        ReplaceFormat:=FalseEnd Sub
  6. Na janela código , clique em qualquer parte do código mencionada na etapa 5. No menu Executar , clique em Executar Sub/UserForm .
  7. No menu arquivo , clique em Fechar e voltar para Microsoft Office Excel .

    Observação O sufixo de caractere de apóstrofo é removido das colunas selecionadas.
Mais Informações

Etapas para reproduzir o problema

  1. Inicie o Access.
  2. Criar um novo banco de dados e salve o banco de dados como C:\MyExample.mdb .
  3. Criar uma tabela chamada tblExample e adicionar registros à tabela.

    Para fazer isso, execute as seguintes etapas:
    1. Na janela banco de dados em objetos , clique em tabelas .
    2. No menu arquivo , clique em Salvar .
    3. Na caixa de diálogo Salvar como , digite tblExample e, em seguida, clique em OK .
    4. No menu Exibir , clique em Modo folha de dados e adicione os seguintes registros sob o campo MeuTexto :
      165-5		99-3		457-3		689-54
    5. No menu arquivo , clique em Salvar .
  4. Crie um relatório é baseado na tabela tblExample :

    Para fazer isso, execute as seguintes etapas:
    1. Na janela banco de dados em objetos , clique em relatórios e, em seguida, clique em novo .
    2. Na caixa de diálogo Novo relatório , selecione AutoReport: Tabular . No Escolher tabela ou consulta de onde vêm os dados do objeto , clique em tblExample .
    3. Clique em OK .
    4. No menu arquivo , clique em Salvar .
    5. Na Salvar como caixa de diálogo na caixa Nome do relatório , digite MeuRelatório .
  5. No menu Ferramentas , aponte para Vínculos do Office e clique em seguida, em analisar com o Microsoft Excel .

    Observação Você pode ver os seguintes valores em MeuTexto coluna na planilha do Excel:
    -63357336220-526983689-54
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Referências
Para obter mais informações sobre como exportar relatórios do Access para o Excel, clique em Ajuda do Microsoft Access no menu Ajuda , digite Exportar objetos de dados ou banco de dados no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.
ACC2002 acc2000 acc2003

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 823222 - Última Revisão: 12/08/2015 03:19:09 - Revisão: 6.3

Microsoft Office Access 2003, Microsoft Access 2002 Standard Edition, Microsoft Access 2000 Standard Edition

  • kbnosurvey kbarchive kbmt kbreport kbfield kbdatabase kbbug KB823222 KbMtpt
Comentários