Imagens vinculadas não aparecem quando a apresentação e as imagens são movidas para uma nova unidade ou pasta no PowerPoint

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 827115
Sintomas
Após você mover uma apresentação do Microsoft PowerPoint e imagens que estão vinculadas a essa apresentação para uma nova unidade ou para um local de pasta, as imagens não são visíveis. Em vez disso, as imagens são exibidas como espaços reservados. Esse problema ocorre mesmo que as imagens estejam na mesma pasta na mesma unidade onde a apresentação que se encontra.

Por exemplo, crie uma apresentação que contém muitas imagens vinculadas e, em seguida, você gravar em um CD gravável (CD-R). Quando você abre a apresentação de CD-R em outro computador, as imagens não aparecem na apresentação, mesmo que eles estejam no CD-r.
Causa
Esse problema ocorre porque a pasta que contém as imagens foi movida. O PowerPoint usa um caminho absoluto para localizar imagens vinculadas. Se a letra de unidade ou caminho for alterado, as imagens não aparecem. Esse problema pode ocorrer quando uma apresentação que foi criada na unidade C é gravado no diretório raiz de um CD-R e, em seguida, aberto da unidade de CD-ROM, geralmente unidade D. Porque os caminhos das imagens vinculadas iniciar com C, as imagens não são encontradas quando a apresentação é aberta.
Como Contornar
Para contornar esse problema, use um dos seguintes métodos.

Método 1: Usar o recurso "Pacote para CD"

Microsoft Office PowerPoint 2007 e o Microsoft Office PowerPoint 2003 possuem um recurso que é chamado de "Compactar para CD". Quando você deseja executar uma apresentação em outro computador, o recurso "Pacote para CD" pode colocar todos os arquivos necessários em um arquivo-morto.

Se você tiver hardware de gravação de CD, você pode copiar apresentações para um CD gravável (CD-R) vazio, um CD regravável (CD-RW) vazio ou um CD-RW com conteúdo existente. No entanto, o conteúdo existente no CD-RW será substituído.

Você também pode usar o recurso "Pacote para CD" para copiar a apresentação em uma pasta no seu computador, um local de rede, ou, se você não incluir o visualizador, um disquete em vez de diretamente em um CD. Você pode descompactar o arquivo no computador de destino ou o compartilhamento de rede e executar a apresentação.

Quando você compacta sua apresentação, os arquivos vinculados são incluídos automaticamente, embora você tenha a opção de excluí-los. Você também pode adicionar outros arquivos ao pacote de apresentação. O recurso "Pacote para CD" converte os caminhos absolutos dos links de imagem relativo aos. Isto é, em vez do caminho sendo "C:\Meus Documentos\Meus Pictures\image001.jpg", becomes"image001.jpg caminho".

Uma apresentação de remessa e arquivos associados

Para usar o recurso "Pacote para CD" em uma apresentação para executar em outro computador, execute essas etapas:
  1. Abra a apresentação que você deseja compactar. Se você estiver trabalhando com uma nova apresentação não foi salva anteriormente, salve a apresentação.

    Observação Antes de fornecer outras pessoas uma cópia da apresentação, ele é uma boa idéia revisar informações pessoais e ocultas e decidir se é apropriado incluí-las. Convém remover comentários, anotações à tinta e marcações antes de empacotar sua apresentação.
  2. Insira um CD na unidade de CD.

    anotações
    • Você precisará de um dos seguintes tipos de CDs: um CD gravável (CD-R) vazio, um CD regravável (CD-RW) vazio ou um CD-RW com conteúdo existente que pode ser substituído.
    • Se você usar um CD-R, certifique-se que você copie todos os arquivos que você deseja sobre o CD na primeira vez.

      Depois que os arquivos forem copiados, você não pode adicionar mais arquivos para o CD.
  3. No menu arquivo , clique em pacote para CD .
  4. Na caixa nomear o CD , digite um nome para o CD.
  5. Para especificar as apresentações para incluir e ordem de execução, siga um destes procedimentos:
    • Para adicionar mais apresentações ou outros arquivos que não são incluídos automaticamente, clique em Adicionar arquivos . Selecione os arquivos que você deseja adicionar e, em seguida, clique em Adicionar .
    • Por padrão, as apresentações são configuradas até executadas automaticamente na ordem em que estão listados na arquivos para ser copiado lista. Para alterar a ordem de execução, selecione uma apresentação e clique a seta para cima ou seta para baixo para movê-lo para uma nova posição na lista.

      Observação Por padrão, a apresentação que está aberta no momento já está em arquivos a serem copiados lista. Os arquivos que estão vinculados à apresentação, como arquivos gráficos, são incluídos automaticamente, mas não aparecem em arquivos a serem copiados lista. Além disso, o Visualizador do Microsoft Office PowerPoint é incluído por padrão para que você possa executar a apresentação empacotada em um computador que não tenha o PowerPoint instalado.
    • Para remover uma apresentação, selecione a apresentação e, em seguida, clique em Remover .
  6. Para alterar as configurações padrão, clique em Opções e, em seguida, siga um destes procedimentos:
    • Para excluir o visualizador, clique para desmarcar a caixa de seleção Visualizador do PowerPoint .
    • Para impedir que as apresentações sejam reproduzidos automaticamente ou para especificar uma execução automática diferente opção, selecione sua preferência na Escolha como as apresentações serão executadas no Visualizador do PowerPoint lista.
    • Para incluir fontes TrueType, clique para selecionar a caixa de seleção fontes TrueType incorporadas .
    • Para exigir uma senha para abrir ou editar todas as apresentações compactadas, em segurança os arquivos do PowerPoint , digite a senha que você deseja usar.
    • Para fechar a caixa de diálogo Opções , clique em OK .
  7. Clique em Copiar para CD .

    Observação Você pode usar este procedimento para empacotar uma ou mais apresentações em uma pasta no seu computador ou um local de rede em vez de em um CD. Em vez de clicar em Copiar para CD , clique em Copiar para pasta e, em seguida, forneça as informações da pasta.

Método 2: Usar um código de macro para definir um caminho relativo

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.
Observação Os exemplos de macro a seguir funcionam somente no PowerPoint. Visual Basic for Applications macros não são suportadas pelo Visualizador do Microsoft PowerPoint. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
230746Visualizar PPT:: Não executar macros da apresentação com o Visualizador

Você também pode usar uma macro para converter os links de absoluto em relativo. Isso permite que o PowerPoint para localizar as imagens com base no local atual da apresentação, desde que as figuras são neste mesmo local.

A seguir está um exemplo de código que mostra uma maneira que isso pode ser automatizado. Este exemplo de código assume que a apresentação e as imagens vinculadas estão no mesmo local de pasta. Se não estiverem no mesmo local de pasta, executar esse código irá quebrar o vínculo para a imagem.

Código de exemplo

  1. No menu Ferramentas , aponte para macro e, em seguida, clique em segurança .
  2. Clique em Médio para o nível de segurança e, em seguida, clique em OK .
  3. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  4. No menu Inserir , clique em módulo .
  5. Digite o seguinte código no módulo:
    Sub RelPict()   Dim oSlide As Slide   Dim oShape As Shape   Dim lPos As Long   Dim strLink As String   '   ' Loop through the presentation and check each shape   ' on each slide to determine whether it is a linked picture.   '   For Each oSlide In ActivePresentation.Slides      For Each oShape In oSlide.Shapes         If oShape.Type = msoLinkedPicture Then            With oShape.LinkFormat   '   ' Search from the rightmost portion of the source   ' file name and find the first backslash "\" character.   '               lPos = InStrRev(.SourceFullName, "\")   '   ' Determine whether the link was already modified.   '               If lPos <> Null Then   '   ' Determine how long the file name is by subtracting    ' the position at which the "\" character was found from   ' the total length of the source file name.   '                  lPos = Len(.SourceFullName) - lPos   '   ' Extract the file name from the source file name, then   ' assign the file name to the source file name. This procedure turns   ' it into a relative path.   '                  strLink = Right(.SourceFullName, lPos)                  .SourceFullName = strLink               End If            End With         End If      Next oShape   Next oSlideEnd Sub
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
PPT2007 PPT2003 PPT

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 827115 - Última Revisão: 06/06/2007 19:57:02 - Revisão: 3.1

Microsoft Office PowerPoint 2007, Microsoft Office PowerPoint 2003

  • kbmt kbmacro kbdisplay kbprb kbnofix KB827115 KbMtpt
Comentários