Uma sessão da área de trabalho remota pode enfrentar uma longa demora ao tentar fazer logoff de um computador cliente avançado

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 831962
Sintomas
Após você instalar o software cliente avançado do Microsoft Systems Management Server (SMS) 2003 em um computador do Terminal Server, pode levar vários minutos para fazer logoff de uma sessão de serviços de terminal no computador cliente avançado. Além disso, as alterações ao seu perfil não podem ser salvas.
Causa
Esse problema pode ocorrer se outro usuário tentar fazer logon uma sessão do Terminal Server enquanto você está tentando fazer logoff de uma sessão do Terminal Server. Nesse cenário, as notificações de logoff são concluídas em sincronia. Por exemplo, se o usuário tentar fazer logoff de uma sessão quando o usuário B tenta fazer logon em uma nova sessão, o logoff será bloqueado até que o logon seja concluído. O logon pode ser atrasado para processar scripts de logon.

Além disso, o problema pode ocorrer se as seguintes condições forem verdadeiras:
  • Nenhum usuário fez logon no console local do computador cliente avançado.
  • Um usuário tenta fazer logoff de uma sessão de serviços de terminal no computador cliente avançado.

    Observação Essa condição não requer que os usuários ser um usuário específico. Qualquer usuário que os logs por meio de uma sessão de serviços de terminal serão enfrentar esse problema contanto que ninguém estiver conectado ao console local.
Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Quando você instalar esse hotfix, os serviços de site SMS parar e reiniciar e o hotfix inicia uma redefinição de site SMS.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version             Size  File name   ------------------------------------------------------------------------------   26-Nov-2003  16:04                 6,448,128  Mp.msi     27-Nov-2003  00:32  2.50.2726.102  5,422,128  Sms2003-rtm-kb831962-x86-enu.exe     25-Dec-2003  07:10                    11,304  Filemap.ini   25-Dec-2003  07:10  2.0.6.3          354,152  Smsupdate.exe       25-Dec-2003  07:10  2.50.2726.102    541,696  Ccmexec.exe         25-Dec-2003  07:10  2000.80.194.0    274,489  Ntwdblib.dll        25-Dec-2003  07:10  2.0.1493.5011    855,312  Preinst.exe         25-Dec-2003  07:10                   369,152  Sms2003ac-kb831962-x86.msp

Informações sobre a instalação

Esse hotfix atualiza o Client Configuration Manager (CCM) Framework componente para versão 2.50.2726.0102. Esse hotfix contém uma atualização de cliente avançado e uma atualização de estrutura de ponto de gerenciamento. Você deve atualizar todos os pontos de gerenciamento com a nova estrutura. Como parte da instalação, esse hotfix realiza um redefinição para atualizar automaticamente todos os pontos de gerenciamento na hierarquia do SMS do site. Se você adiar a redefinição de site SMS, você deve executar manualmente uma redefinição de site ou remover e adicionar os pontos de gerenciamento. Você deve redefinir cada site onde você aplicar esse hotfix. Para aplicar o hotfix silenciosamente, use a opção /s na linha de comando.

Você deve aplicar esse hotfix em sites primários e secundários. Devido a nova arquitetura no SMS 2003, você deve criar um novo pacote e um novo programa para anunciar esse hotfix para os computadores cliente avançado. Como parte do programa de instalação, esse hotfix pode criar o pacote e o anúncio automaticamente. A Microsoft recomenda que você permitir que o programa de instalação criar o pacote e um anúncio para você.

Para instalar esse hotfix, execute estas etapas:
  1. Baixar o arquivo de hotfix e execute o arquivo executável auto-extraível para criar o Sms2003 rtm-kb831962 arquivo-x 86-enu.exe.
  2. Copie Sms2003-rtm-kb831962-x 86-enu.exe para uma pasta no computador de servidor do SMS site primário ou secundário.
  3. Clique em Iniciar , aponte para Todos os programas , aponte para Systems Management Server e, em seguida, clique em SMS Administrator Console .
  4. Expanda Site Database .
  5. Clique com o botão direito do mouse em coleções , aponte para novo e, em seguida, clique em coleção .
  6. Na caixa nome , digite:
    os clientes para 831962 avançadas
  7. Clique em Query Rule Properties botão.
  8. Na caixa nome , digite:
    os clientes para 831962 avançadas
  9. Clique em Edit Query Statement .
  10. Na guia Geral , clique no Mostrar linguagem de consulta botão.
  11. Cole ou digite a consulta a seguir na caixa consulta instrução :
    select * from SMS_R_System 	inner join SMS_G_System_SMS_ADVANCED_CLIENT_STATE 	on SMS_G_System_SMS_ADVANCED_CLIENT_STATE.ResourceID = SMS_R_System.ResourceId 	where SMS_R_System.ClientType = 1 	and SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Name = "CcmFramework" 	and (SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version < "2.50.2726.0102" 	or SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version in ( "2.50.2726.4","2.50.2726.5",        "2.50.2726.18", "2.50.2726.1", "2.50.2726.16" ))
    para usar essa consulta, você deve ter pelo menos um cliente avançado computador em seu estoque para criar as classes de banco de dados.
  12. Clique em OK três vezes.

    Esta consulta identifica os computadores cliente avançado que não têm esse hotfix instalado. E essa consulta identifica os pontos de gerenciamento que também tenham o cliente avançado instalado.
  13. Execução Sms2003-rtm-kb831962-x 86-enu.exe no computador de servidor do site do SMS.
  14. Depois que os arquivos forem copiados, clique em Sim, desejo criar um pacote e programa agora e, em seguida, clique em Avançar .
  15. Clique em Avançar para aceitar o pacote padrão e o nome do programa padrão.
  16. Clique em Sim para executar uma redefinição de site.
  17. No console SMS Administrator, expanda Packages .
  18. Clique o pacote KB831962 - Hotfix de cliente avançado com o botão direito do mouse, aponte para Todas as tarefas , clique em Distribute Software e em seguida, clique em Avançar .
  19. Clique para selecionar a caixa de seleção para os pontos de distribuição e, em seguida, clique em Avançar .
  20. Clique em Avançar para anunciar o programa.
  21. Clique em Avançar para selecionar o programa para o anúncio.
  22. Clique em anúncio este programa para uma coleção existente e, em seguida, clique em Procurar .
  23. Clique em Clientes avançados para 831962 coleção e em seguida, clique em OK .
  24. Clique em Avançar duas vezes.
  25. Clique em anúncio o programa somente para membros da coleção especificada e em seguida, clique em Avançar .
  26. Conclua o Assistente para distribuição de software.
Para executar uma instalação silenciosa deste hotfix, execute estas etapas:
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Digite cmd e, em seguida, clique em OK .
  3. Localize a pasta que contém o Sms2003 rtm-kb831962 arquivo-x 86-enu.exe.
  4. Digite o seguinte comando e pressione ENTER:
    sms2003-RTM-KB831962-X 86-enu.exe /s
Se você não conseguir instalar a parte cliente avançado esse hotfix, exiba os arquivos de log cliente avançado no computador cliente. O cliente avançado arquivos de log estão na $Systemroot%\System32\Ccmsetup e as pastas %Systemroot%\System32\Ccm\Logs.

importante Status de anúncio para esse hotfix podem ser reportado incorretamente se você tiver hotfixes de cliente avançado adicionais distribuído. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
840864Uma mensagem de status incorreto é exibida após a implantação hotfixes do SMS 2003 Advanced Client
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Mais Informações
Para obter mais informações sobre como encontrar o número de versão da instalação do SMS 2003, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
832103Como determinar o número de versão do Systems Management Server 2003
Para obter mais informações sobre pacotes de clientes do SMS internacional, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
202941Sistemas Management Server International Client Packs
Para obter mais informações sobre a terminologia padrão usada para descrever as atualizações de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do Artigo: 831962 - Última Revisão: 07/24/2007 19:22:54 - Revisão: 8.8

Microsoft Systems Management Server 2003 Enterprise Edition

  • kbmt kbautohotfix kbqfe kbhotfixserver kbnetwork kbsmstopazfix kblogin kbuser kbperformance kbremoting kbfix kbbug KB831962 KbMtpt
Comentários