Ferramenta Remover Dados Ocultos para Office 2003 e Office XP

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
O suplemento Remover Dados Ocultos é uma ferramenta que pode ser usada para remover dados particulares ou ocultos que, ao visualizar um documento em um programa do Microsoft Office podem estar temporariamente invisíveis.

É possível executar o suplemento Remover Dados Ocultos em arquivos individuais do programa Microsoft Office XP ou do Microsoft Office 2003. Ou ainda, é possível executar o suplemento Remover Dados Ocultos em vários arquivos simultaneamente através de uma linha de comando. Em qualquer um dos casos, para executar a ferramenta é necessário ter o programa usado para criar o documento instalado.

Para obter mais informações sobre a ferramenta Remover Dados Ocultos e sobre como obtê-la, visite o seguinte site da Microsoft: Para mais informações sobre problemas conhecidos e tópicos não abordados pelo arquivo Leia-me, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
834636 Problemas conhecidos com o suplemento Remover Dados Ocultos para Office 2003 e Office XP
842684 Problemas conhecidos com o suplemento Remover Dados Ocultos versão 1.1 para Office 2003 e Office XP

Para determinar a versão da ferramenta Remover Dados Ocultos instalada no computador, execute as seguintes etapas:
  1. Clique em Iniciar e em Painel de controle.
  2. Clique em Adicionar ou remover programas.
  3. Na lista de programas instalados, clique em Ferramenta Remover Dados Ocultos e clique no link Clique aqui para obter informações de suporte.
  4. Consulte a tabela a seguir para determinar a versão comercial da ferramenta Remover Dados Ocultos que você tem instalada.

    Versão comercialVersão
    Ferramenta Remover Dados Ocultos 1.111.0.6361.0
    Ferramenta Remover Dados Ocultos 1.06.00.2600.0000
Mais Informações
A seguir, o arquivo LeiaMe do suplemento Remover Dados Ocultos. Este arquivo LeiaMe está localizado na seguinte pasta após instalar o suplemento Remover Dados Ocultos:
caminho\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Arquivo LeiaMe do Microsoft Office 2003: suplemento Remover Dados Ocultos

© 2003 Microsoft Corporation. Todos os direitos reservados.

Este documento fornece informações mais recentes sobre o suplemento Remover Dados Ocultos do Microsoft Office 2003. A seção Conteúdo lista todas as informações contidas neste arquivo. Para informações mais recentes específicas para um produto individual do sistema Office, consulte o arquivo LeiaMe do respectivo produto.

Remover Dados Ocultos é um suplemento para o Microsoft Office 2003 Editions ou para o Microsoft Office XP que permite que usuários removam permanentemente dados ocultos e dados colaborativos dos arquivos dos programas Microsoft Word, Microsoft Excel e Microsoft PowerPoint.

Como usar o documento

Para visualizar o arquivo LeiaMe na tela, maximize a janela do navegador. Para imprimir o arquivo LeiaMe, clique no botão Imprimir na barra de ferramentas.

Conteúdo

Visão geral

Ao distribuir um documento eletrônico do Office, o documento pode conter informações que você queira compartilhar publicamente como, as informações que permitem que você colabore na gravação e edição do documento ou informações ocultas que podem ser usadas para rastrear quem trabalhou no documento.

O suplemento Remover Dados Ocultos é uma ferramenta que pode ser usada para remover informações particulares ou ocultos que talvez não estejam imediatamente visíveis ao visualizar um documento em um aplicativo do Microsoft Office.

É possível executar o suplemento Remover Dados Ocultos em arquivos individuais do aplicativo do Office XP ou do Office System 2003. Ou ainda, é possível executar Remover Dados Ocultos em vários arquivos de linha de comando. Em qualquer um dos casos, é necessário instalar o aplicativo que criou o documento para executar a ferramenta.

Observações

É necessário executar o suplemento Remover Dados Ocultos em arquivos quando você estiver pronto para publicá-los. Isso porque as informações removidas pela ferramenta são usadas pelo Office para recursos de colaboração, como Rastrear alterações, Comentários e Enviar para revisão, e esses recursos de colaboração não funcionarão após usar o suplemento Remover Dados Ocultos.

O suplemento Remover Dados Ocultos foi projetado para remover determinados tipos de dados de arquivos do Office permanentemente, de maneira automática, sem solicitação. Por padrão, o suplemento o solicitará para salvar o arquivo com um novo nome de arquivo.

É necessário usar sempre um novo nome de arquivo, em vez de substituir o arquivo original com um documento novo para preservar a cópia do documento com os dados originais.

Para alterar o idioma usado pelo suplemento Remover Dados Ocultos, é necessário desinstalar o suplemento e baixar uma nova cópia do suplemento Remover Dados Ocultos para aquele idioma. Após o suplemento do novo idioma ser instalado, ele substituirá a versão do idioma original do suplemento. Todas as cópias do suplemento Remover Dados Ocultos, em qualquer idioma, incluem uma versão em idioma inglês para oferecer suporte à ferramenta de linha de comando.

Não é possível Remover Dados Ocultos dos seguintes tipos de arquivos com esta ferramenta:
  • Documentos que usem permissões de gerenciamento de direitos
  • Documentos protegidos
  • Documentos assinados digitalmente
  • Pastas de trabalho compartilhadas
Se tentar executar esta ferramenta em um arquivo que atenda a uma mais das condições acima, a ferramenta terminará a operação e exibirá uma mensagem de erro. O arquivo original permanecerá inalterado.

Retornar ao índice

Requerimentos do sistema

Sistemas operacionais compatíveis: Microsoft Windows XP SP1 ou posterior, Microsoft Windows 2000 SP4 ou posterior, ou Microsoft Windows Server 2003

Este download funciona com os seguintes aplicativos do Office:
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002, SP2 ou posterior
  • Microsoft Excel 2002, SP2 ou posterior
  • Microsoft PowerPoint 2002, SP2 ou posterior
É necessário ter o aplicativo no qual o documento foi criado instalado no computador para executar o suplemento. Além disso, é necessário que a versão do Office instalada seja da mesma versão ou de versão mais recente do que a versão do documento no qual você deseja executar a ferramenta Remover Dados Ocultos. Por exemplo, é possível executar a ferramenta em um documento do Office 2000 usando o Office 2003, mas não é possível executar a ferramenta em um documento do Office 2003 usando o Office XP.

Remover Dados Ocultos funciona com documentos do Word, planilhas do Excel e apresentações do PowerPoint, assim como com páginas da Web e páginas de arquivo único da Web que foram criados no Word, Excel ou PowerPoint. A ferramenta não funciona com outros formatos de documento.

Retornar ao índice

Tipos de dados que podem ser removidos pela ferramenta

Os seguintes tipos de dados são removidos automaticamente.
  • Comentários.
  • Autores e editores anteriores.
  • Nome de usuário.
  • Informações resumidas particulares.
  • Marcas de revisão. A ferramenta aceita todas as revisões especificadas no documento. Como resultado, o conteúdo do documento corresponderá à exibição Marcação na exibição final na barra de ferramentas Revisão.
  • Texto excluído. Esses dados são removidos automaticamente.
  • Versões.
  • Macros do VB. Descrições e comentários são removidos dos módulos.
  • O número de identificação usado para identificar o documento para fins de mesclar as alterações de volta no documento original.
  • Listas de circulação.
  • Títulos de email.
  • Comentários da situação.
  • Identificados exclusivos (somente para documentos do Office 97).
Observação A ferramenta Remover Dados Ocultos também se transforma no recurso Remover informações particulares. Para obter mais informações sobre esse recurso, consulte a seção "Remover informações particulares" na Ajuda do aplicativo.

Retornar ao índice

Problemas conhecidos

  • Excel: No Excel 2002, caminhos de impressora não são removidos, entretanto, eles são removidos no Excel 2003.
  • Excel: O link para uma pasta de trabalho externa de suporte talvez não seja limpo em uma página de arquivo único do Excel da Web.
  • Se o suplemento Remover Dados Ocultos for encerrado inesperadamente, uma janela vazia do Bloco de Notas pode ser exibida e um arquivo de log pode aparecer no diretório de arquivos temporários. Para fechar a janela do Bloco de Notas, clique em Arquivo e em Sair no Bloco de Notas. Para remover este arquivo de log, exclua o conteúdo do diretório de arquivos temporários na pasta de configurações local.
  • Se fechar o suplemento Remover Dados Ocultos antes de concluir a verificação de um documento, um ou mais arquivos temporários podem ser deixados na pasta de destino. Para remover esses arquivos, exclua-os da pasta de destino.
  • Páginas de arquivo único da Web que foram revisadas pela ferramenta pode conter o nome de um arquivo temporário gerado aleatoriamente no arquivo do formulário::///c:/<número>/. O número usado nesse nome tem como base o nome do arquivo de uma página de arquivo único da Web e não é possível rastreá-lo de volta para o computador.
  • Números aleatórios ocultos existentes, usados para aprimorar a precisão da mesclagem e armazenados em arquivos do Word não são removidos.
  • Ao executar a linha de comando, o suplemento Remover Dados Ocultos não funciona em documentos XML criados no Word, Excel ou PowerPoint.
Retornar ao índice

Uso básico

Após instalar o suplemento Remover Dados Ocultos, abra o documento que deseja revisar e no menu Arquivo, clique em Remover Dados Ocultos.

Observação Se não visualizar o comando Remover Dados Ocultos no menu Arquivo, verifique o seguinte:
  1. No menu Ferramentas, clique em Opções e clique na guia Segurança.
  2. Em Segurança de macro, clique em Segurança de macro.
  3. Clique na guia Editores confiáveis.
  4. Marque a caixa de seleção Confiar em todos os suplementos e modelos instalados e clique em OK duas vezes.
Após especificar o nome do arquivo, a ferramenta removerá os dados ocultos especificados automaticamente. Consulte Tipos de dados que podem ser removidos por este suplemento para obter mais informações.

Observações

É sempre necessário salvar com um novo nome de arquivo, em vez de substituir o arquivo original com um documento novo, para preservar a cópia do documento com os dados originais.

O suplemento Remover Dados Ocultos é compatível com salvar documentos como modelos.

Retornar ao índice

Linha de comando

Para executar o suplemento Remover Dados Ocultos da linha de comando, faça o seguinte:
  1. Encerre todas as instâncias do Excel, Word, Outlook e PowerPoint antes de executar a ferramenta de linha de comando.
  2. No menu Iniciar, clique em Executar.
  3. Digite cmd e pressione ENTER.
  4. Alterne para a pasta que contém o arquivo OFFRHD.EXE. Por padrão, esta é a pasta na qual o suplemento Remover Dados Ocultos foi instalado.
  5. No prompt de comando, digite a syntaxe da tarefa que deseja realizar.
Observações

Apesar de o aplicativo do documento não estar visível, ele está sendo executado no plano de fundo. Se o aplicativo iniciar uma caixa de diálogo, o suplemento Remover Dados Ocultos será interrompido até que a caixa de diálogo seja fechada. Se a caixa de diálogo permanecer aberta por mais de 120 segundos, o aplicativo terminará e o suplemento Remover Dados Ocultos passará para o próximo arquivo ou será fechado quando alcançar o último arquivo.

É possível digitar uma barra (/) ou um hífen (-) como sinalizar para preceder parâmetros. Sinalizadores não diferenciam maiúsculas de minúsculas.

Se digitar em vários sinalizadores, somente o primeiro sinalizador será reconhecido.

É necessário inserir o /primeiro parâmetro de origem seguido, alternativamente, pelo /parâmetro de destino. Todos os demais parâmetros podem estar em qualquer ordem.

Se digitar uma barra (/) no final do nome do diretório de destino, a ferramenta falhará.

A sintaxe do OFFRHD.EXE é a seguinte:
OFFRHD [/?] origem [destino] [/O] [/R] [/F:tipodearquivo] [/L: arquivodelog] [/A]
ParâmetroDescrição
origemexigida. Especifica a unidade, diretório e arquivos dos quais você deseja remover informações. Pode ser qualquer nome de caminho válido e totalmente qualificado.
destinoopcional. Especifica um local para os arquivos verificados. Se este campo não for especificado, todos os arquivos serão salvos no mesmo diretório com um sufixo representando a data atual. Por exemplo, -C010503 representaria 05 de janeiro de 2003. Se o arquivo de destino já existir, ele será substituído.
/OEspecifica que nenhum aviso será solicitado para confirmar se você deseja substituir um arquivo já existente.
/REspecifica que o conteúdo do diretório de origem e seus subdiretórios serão examinados.
/F:tipodearquivoEspecifique o formato dos arquivos de destino.
/F:HEspecifica HTML.
/F:MEspecifica MHTML.
/F:BEspecifica formato de documento binário. Se este parâmetro não for especificado pelo usuário, o padrão será salvar no mesmo formato do arquivo de origem.
/L:arquivodelogEspecifica um local que armazena o arquivo de log. Se não for especificado, o log será exibido quando a ferramenta for concluída.
/AEspecifica que a ferramenta gerará um relatório de problemas encontrados no arquivo, mas não removerá dado algum.
/:?Exibe uma lista de todos os parâmetros disponíveis.
Retornar ao índice

Arquivo de log

Quando o suplemento Remover Dados Ocultos concluir a verificação do(s) arquivo(s), um arquivo de log exibirá os resultados do processo de verificação. É possível salvar este arquivo se desejar voltar a ele posteriormente.

Retornar ao índice

Usando Remover Dados Ocultos com IRM

No Office 2003, não é possível executar a ferramenta Remover Dados Ocultos em documentos protegidos por IRM, salvo se você for o proprietário do documento ou tiver a permissão "Alterar" atribuída com a opção "Acessar conteúdo de forma programática".

Para conceder permissões para executar a ferramenta Remover Dados Ocultos em documentos protegidos por IRM, faça o seguinte:
  1. No menu Arquivo, clique em Permissão e em Restringir permissão como.
  2. Seleciona conta de usuário (geralmente a sua própria) para criar ou abrir o conteúdo e clique em OK.
  3. Na caixa de diálogo Permissão, clique em Mais opções.
  4. Agora clique na conta do usuário para o qual você deseja conceder acesso (é necessário que a conta do usuário tenha a permissão Alterar no documento para usar a ferramenta Remover Dados Ocultos).
  5. Clique em Acessar conteúdo de forma programática e clique em OK.
Retornar ao índice
Propriedades

ID do Artigo: 834427 - Última Revisão: 12/08/2015 05:53:35 - Revisão: 2.1

Microsoft Office Excel 2003, Microsoft Office PowerPoint 2003, Microsoft Office Word 2003, Microsoft Excel 2002 Standard Edition, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbcommandline kbconfig kbtooltip kbinfo KB834427
Comentários