Descrição das diferenças entre o Excel 2001 para Mac e Excel 2000

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 843305
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sumário
Microsoft Excel 2000 e Microsoft Excel 2001 para Mac são programas muito semelhantes de várias maneiras. Por exemplo, eles compartilham um formato de arquivo comum e compartilham a maioria os mesmos recursos. No entanto, há algumas diferenças importantes que você talvez queira saber quando você trabalhar com o Excel 2000 e Excel 2001 para Mac.
INTRODUÇÃO
Este artigo contém informações gerais sobre a diferença entre o Microsoft Excel 2001 para Mac e Microsoft Excel 2000.

back to the top
Mais Informações

Mapas de dados Microsoft

Suporte no Excel 2001 para Mac

No Excel 2001 para Mac, você não pode inserir um mapa de dados do Microsoft em uma planilha. Não há nenhuma ferramenta de mapa na barra de ferramentas padrão e o comando de menu Map não aparece no menu Inserir .

Converter do Excel 2000

Se você abrir uma pasta de trabalho que contém um mapa que foi criado no Excel 2000, o mapa é importado como uma imagem e aparece em preto e branco. Se você clicar duas vezes o mapa no Excel 2000, você receber a seguinte mensagem de erro:
Não é possível iniciar o aplicativo fonte para este objeto. Pode não haver memória suficiente disponível.
Se você abre uma pasta de trabalho que contém um mapa, fizer alterações para a pasta de trabalho, salvá-lo e, em seguida, reabrir a pasta de trabalho no Excel 2000, o mapa ainda funciona corretamente.

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
274220MacXL: Os mapas de dados não têm suporte no Microsoft Excel para Mac


back to the top

Controles ActiveX

Suporte no Excel 2001 para Mac

Excel 2001 para Mac não oferece suporte usando controles ActiveX, também conhecido como "Arquivos OCX" ou "OCXs." Não é possível inserir ou usar o ActiveX controles em planilhas, nas caixas de diálogo personalizada ou em UserForms personalizados.

Como controles ActiveX não são suportados no Excel 2001 para Mac, a caixa de ferramentas de controle não está disponível em planilhas no Excel 2001 para Mac. A caixa de ferramentas no Editor do Microsoft Visual Basic está disponível. No entanto, você não pode adicionar controles ActiveX a ele.

Converter do Excel 2000

Se você abrir uma pasta de trabalho que contém um ou mais controles ActiveX, um dos seguintes problemas pode ocorrer:
  • Cada controle aparece como "X" vermelho.
  • Você recebe uma ou mais mensagens de "Filtro gráfico converter".
Quando os controles forem exibidos, eles não funcionam quando você clica nelas, e você não é possível excluí-los. Além disso, você pode receber uma das seguintes mensagens de erro se você copia e cola um controle ou se você executar um Microsoft macro do Visual Basic for Applications (VBA):
O aplicativo "desconhecido" foi encerrado inesperadamente, porque ocorreu um erro do tipo 3.
Erro em tempo de execução '57121': não é possível sair do modo de design porque o controle 'CheckBox1' não pode ser criado.
Erro em tempo de execução '32809': erro pelo aplicativo ou objeto definido.
Erro em tempo de execução '1004': não é possível iniciar o aplicativo de origem para este objeto. Pode não haver memória suficiente disponível.
Se você abre uma pasta de trabalho que contém controles ActiveX, fizer alterações para a pasta de trabalho, salvá-lo e, em seguida, reabrir a pasta de trabalho no Excel 2000, os controles ActiveX ainda funcionar corretamente. No entanto, eles não funcionam no Excel 2001 para Mac.

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
274222MacXL: Erro ao colar controles ActiveX ou executar uma macro


back to the top

sistema de data 1900 versus sistema de datas 1904

No Excel 2001 para Mac, o sistema de data padrão é o sistema de datas 1904. No Excel 2000, o sistema de data padrão é sistema de data 1900. Normalmente, essa diferença não causa um problema.

No entanto, se você transferir uma pasta de trabalho do Excel 2000 para o Excel 2001 para Mac, ou vice versa e em seguida, copiar uma data de uma pasta de trabalho para outra, a data pode aumentar ou diminuir por quatro anos e um dia. Esse problema ocorre se as duas pastas de trabalho usam sistemas de data diferentes.

Por exemplo, se você copiar a data 1/1/1998 de uma pasta de trabalho usa o sistema de data 1900 e cole a data em uma pasta de trabalho que usa o sistema de data 1904, a data é exibido como 1/2/2002. Ou, se você copiar a data 1/1/1998 de uma pasta de trabalho usa o sistema de datas 1904 e cole a data em uma pasta de trabalho que usa o sistema de data 1900, a data aparece como 31/12/1993.

Desde que você sabe sobre o sistema de data que está usando sua pasta de trabalho, a diferença em sistemas de data não deve causar um problema.

Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
274238MacXL: Data retornada em uma macro é muito cedo quatro anos
274277MacXL: Eixo do gráfico pode ser quatro anos desde o início depois de formatar escala


back to the top

Formato de arquivos do Quattro Pro

Excel 2001 para Mac não oferece suporte abrir ou salvar arquivos no Quattro Pro formato de arquivo.

Se você tentar abrir um arquivo que é salvo em qualquer formato de arquivo do Quattro Pro (WQ1, WQ2, WB1 ou WB2), você receber a seguinte mensagem de erro:
Este arquivo não está em um formato reconhecido.
Se você tiver que abrir um arquivo Quattro Pro no Excel 2001 para Mac, siga um destes procedimentos:
  • Abra o arquivo no Quattro Pro e, em seguida, salve-o no Lotus 1-2-3 arquivo formato (WK4, WK3, WKS ou WK1). Você pode abrir o arquivo resaved no Excel 2001 para Mac.
  • Abrir o arquivo no Excel 2000 e, em seguida, salve-o como uma pasta de trabalho do Microsoft Excel. Você pode abrir a pasta de trabalho no Excel 2001 para Mac. Há suporte para apenas as versões do Quattro Pro para Quattro Pro 7.0 para Microsoft Windows.
Porque o Excel 2001 para Mac não é possível salvar arquivos no formato de arquivo Quattro Pro, salve os arquivos em um formato de arquivo diferente e use outro programa, como o Excel 2000 para converter os arquivos no formato de arquivo do Quattro Pro.

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
179886Lista de formatos de arquivo com suporte no Excel 2000


back to the top

Editor do Visual Basic

O Visual Basic for Applications editando ambiente (Editor do Visual Basic) no Excel 2001 para Mac é quase a mesma no design para o Editor do Visual Basic no Excel 2000. No entanto, considere as seguintes diferenças:
  • Os comandos de menu Janela Locals e Watch não estão disponíveis em Exibir menu. Você não pode exibir esses comandos de menu no Editor do Visual Basic.
  • Não é possível personalizar qualquer uma das barras de ferramentas (Standard, editar ou Debug) ou a barra de menus no Editor do Visual Basic.
  • Não é possível personalizar a caixa de ferramentas que contém controles para uso em UserForms.
  • Não é possível exportar um módulo do Visual Basic ou um UserForm. Se você desejar exportar um módulo ou um formulário de usuário, abra a pasta de trabalho que contém o módulo ou UserForm no Excel 2000 e exporte o módulo ou o formulário de usuário.
  • Controles de lista caixa e combinação caixa não têm propriedades OrigemDoControle e OrigemDaLinha . Portanto, esses controles não podem ser vinculados às células em uma planilha.
back to the top

ODBCDirect, DAO e ADO

ActiveX Data Objects (ADO), Data Access Objects (DAO) e ODBCDirect não estão disponíveis no Excel 2001 para Mac. Portanto, não é possível executar macros do Visual Basic que usar ODBCDirect, DAO ou ADO para recuperar dados externos no Excel. No entanto, você pode executar macros que usam o padrão Open Database Connectivity (ODBC) para recuperar dados externos.

back to the top

Ajuda on-line

No Excel 2000, se você apontar para o Office na Web no menu Ajuda , o site do Microsoft Office Update aparece em seu navegador da Web.

Excel 2001 para Mac usa um método um pouco diferente para exibir essas páginas da Web. Quando você clica no menu Ajuda , o comando Ajuda na Web é exibida. Se você clicar em Ajuda na Web , sua Web navegador é iniciado e a seguinte página da Web HTML será exibida:
Macintosh HD:Microsoft Office 2001:Office:Help:WebHelp.htm
Esta página da Web contém links para vários locais no site da Microsoft. Se você desejar personalizar a página "Ajuda na Web", use um editor de texto ou um editor da Web, como o Microsoft FrontPage para personalizar a página.

back to the top

Objetos incorporados

No Excel 2000, se você inserir um documento de outro programa em uma planilha, você pode alterar o documento incorporado clicando duas vezes nele. Quando você fizer isso, o documento é editado "in-loco," isto é, permanecem no Excel 2000, mas os menus e as barras de ferramentas alterar para que você pode alterar o documento.

No Excel 2001 para Mac, edição in-loco não está disponível. Se você clicar duas vezes em um documento que é inserido em uma planilha, o programa para o documento é iniciado e alterar o documento no programa. Quando tiver terminado, você fecha o documento e retorna ao Excel.

back to the top

Modelos para modificação

No Excel 2000, você pode abrir um modelo para modificá-lo abrindo o modelo. As alterações feitas são salvas no modelo próprio quando você salvar o arquivo.

No Excel 2001 para Mac, se você deseja abrir um modelo para modificá-lo, você deve mantenha pressionada a tecla SHIFT enquanto você abrir o modelo. Depois que o modelo estiver aberto, solte a tecla SHIFT. Em seguida, pode alterar o modelo e salvá-lo.

back to the top

Barras de menus

As etapas para modificar a barra de menu do gráfico ou de barra de menu planilha são ligeiramente diferentes no Excel 2001 para Mac. Para modificar a barra de menu planilha ou a barra de menu gráfico, execute essas etapas:
  1. No menu Ferramentas , clique em Personalizar .
  2. Clique na guia barras de ferramentas .
  3. Se desejar fazer alterações para a planilha barra de menus ou barra de menu gráfico, clique para selecionar a Barra de menu planilha Verifique caixa ou a caixa de seleção Barra de menus de gráfico .

    Você pode fazer alterações para menus, itens de menu e submenus em barras de dois menus. Você não pode fazer alterações na barra de menus na parte superior da tela.
  4. Quando você for concluído, clique em Fechar na caixa de diálogo Personalizar . Public/EN-US/Office/843305.gif
Quando você clicar em Fechar , as barras de dois menu desaparecem da tela. No entanto, quaisquer alterações feitas nos menus, itens de menu ou submenus aparecem na barra de menus na parte superior da tela.

back to the top

Ícones de menu

No Excel 2001 para Mac, ícones não aparecem à esquerda dos itens de menu mesmo que elas aparecem quando você personalizar menus, itens de menu e submenus. Esse problema ocorre devido ao projeto do sistema operacional Macintosh.

back to the top
Referências
Para os consultar os artigos da Base de dados de Conhecimento da Microsoft mais recentes e outras informações de suporte sobre o Excel 2001 para Mac, visite o seguinte da Microsoft:

back to the top

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 843305 - Última Revisão: 12/08/2015 07:33:00 - Revisão: 2.4

Microsoft Excel 2001 para Mac, Microsoft Excel 2000 Standard Edition

  • kbnosurvey kbarchive kbmt kbmenu kbconversion kbdao kbhelp kbinfo kbhowtomaster KB843305 KbMtpt
Comentários