Você pode receber uma mensagem de erro ao tentar importar dados ou para vincular a dados em um arquivo de texto grande que contém valores nulos no Access 2003 ou no Access 2002

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 872914
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.
Sintomas
No Microsoft Access, quando você tenta importar os dados ou vincular a dados em um arquivo de texto de largura fixa, o Microsoft Access pára de responder por um período longo e você receber a seguinte mensagem de erro:
Um ou mais linhas de dados em seu arquivo contém muitos caracteres para importar. O máximo de caracteres por linha é 65000.
Após você clicar em OK na caixa de diálogo que contém a mensagem de erro, o Assistente de vinculação de texto ou o Assistente de importação de texto é iniciado. No entanto, os dados no arquivo de texto não aparecer corretamente no Assistente de importação de texto ou o Assistente de vinculação de texto . Portanto, você com êxito não pode importar os dados ou link aos dados no arquivo de texto.
Causa
Esse problema ocorre quando as seguintes condições forem verdadeiras:
  • O arquivo de texto de largura fixa é muito grande.
  • Os campos no arquivo de texto de largura fixa contêm valores nulos incorporados.
Como Contornar
Para contornar esse problema, você deve substituir os valores nulos no arquivo de texto de largura fixa com um espaço em branco. Em seguida, você pode importar os dados ou link para os dados no arquivo de texto de largura fixa. Para fazer isso, execute as seguintes etapas:
  1. Inicie o Microsoft Access.
  2. Abra o banco de dados Access ou o projeto do Access que você deseja importar os dados ou que você deseja vincular.
  3. Na janela banco de dados, clique em módulos na seção objetos e, em seguida, clique em novo .
  4. Cole o seguinte código no Editor do Visual Basic. Esse código substitui os valores nulos espaços em branco e, em seguida, copia o conteúdo do arquivo de texto de largura fixa para um novo arquivo de texto.
    Sub WriteNewTextFile()    Dim characterArray() As Byte    Dim fileLen As Long    Dim strOrigFile As String    Dim strNewFile As String    Dim MyString As String    Dim fs As Object    'Change the path and the names of the files according to your requirement.    strOrigFile = "<Full path of your original text file>"    strNewFile = "<Full path of the new text file>"    Set fs = CreateObject("Scripting.FileSystemObject")    If (fs.FileExists(strOrigFile)) Then            'Open the file and obtain the length        Open strOrigFile For Binary As #1        fileLen = LOF(1)            'Read the file        ReDim characterArray(fileLen) As Byte        Get #1, , characterArray        Close #1            'The problem with the file occurs because the file contains null values that are embedded        Dim i As Long            For i = 1 To fileLen        'If the character is a null value, change it to a blank space like Notepad does            If (characterArray(i) = &H0) Then                characterArray(i) = &H20            End If        Next i        'Write the replacement file        Open strNewFile For Binary As #1        Put #1, , characterArray        Close #1        MsgBox "Completed"    Else        MsgBox "Provide valid path of the text file"    End IfEnd Sub
    Observação o código, você deve substituir <Full path of your original text file> com o caminho correto do seu arquivo de texto de largura fixa. Você também deve substituir <Full path of the new text file> com o caminho correto do novo arquivo de texto.
  5. No Editor do Visual Basic, clique em Janela imediata no menu Exibir .
  6. Na janela Immediate , digite WriteNewTextFile e, em seguida, pressione ENTER.
Um novo arquivo de texto é criado. Agora você pode importar os dados ou link para os dados contidos no novo arquivo de texto de largura fixa.
Mais Informações
Em um banco de dados do Microsoft Access 2000, se você tentar para importar dados ou para vincular a dados no arquivo de texto de largura fixa mesmo que contém valores nulos são incorporados, o Assistente para importação de texto ou o Assistente de vinculação de texto aparece imediatamente. No entanto, os dados no arquivo de texto não forem exibidos corretamente e você poderá notar caracteres não reconhecidos no Assistente de importação de texto ou o Assistente de vinculação de texto . Com êxito não é possível importar os dados ou link aos dados no arquivo de texto. O Access 2000 não parar de responder, e você não recebe a mensagem de erro mencionada na seção "Sintomas".
Referências
Para obter mais informações sobre como importar dados ou para vincular a dados no Microsoft Access 2002, clique em Ajuda do Microsoft Access no menu Ajuda , digite Importar ou vincular dados e objetos no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Para obter mais informações sobre como importar dados ou para vincular a dados no Microsoft Access 2003, clique em Ajuda do Microsoft Office Access no menu Ajuda , digite Importar ou vincular dados e objetos na caixa Procurar no painel Assistência e clique em Iniciar pesquisa para exibir o tópico.
ACC2000 ACC97 arquivo de texto do link acc2002 acc2003 importação desliga bloqueios congela lixo de lixo

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 872914 - Última Revisão: 12/08/2015 07:54:11 - Revisão: 3.2

Microsoft Office Access 2003, Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbnewfile kbfile kbcodesnippet kbimport kbprb kbtshoot kberrmsg KB872914 KbMtpt
Comentários