CORRECÇÃO: Receber uma mensagem de erro "Objeto necessário" ao abrir um virtual catálogo no Commerce Server 2002

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 875517
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Quando você abre um catálogo virtual no Microsoft Commerce Server 2002, você receber a seguinte mensagem de erro:
Ocorreu um erro ao carregar.
Quando você clica em Mostrar detalhes , você recebe a seguinte mensagem de erro:

Número: 0x1A8
Descrição: Objeto necessário
Fonte: Erro de tempo de execução Microsoft VBScript
Observação Quando você cria o catálogo virtual, a categoria de base não está incluída no catálogo virtual.
Causa
O problema ocorre quando o nome da categoria em uma categoria base tem um parêntese de caractere ("()").
Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version     Size     File name   ----------------------------------------------------   28-Jul-2004  05:21  4.5.3818.0  954,468  Catalog.dll
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Mais Informações
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Etapas para reproduzir o comportamento

Criar um catálogo base

  1. Abra o Commerce Server Business Desk (BizDesk).
  2. No menu Catalogs , clique em Catalog Definition Designer .
  3. Na barra de ferramentas, clique em novo e digite cor na caixa nome .
  4. Na lista de Propriedades disponíveis , clique em cor , clique em Adicionar e, em seguida, clique em Salvar & voltar.
  5. Clique em Catalog Editor , clique em novo na barra de ferramentas e, em seguida, clique em Novo catálogo base .
  6. Digite as seguintes informações:
    Nesta caixaDigite o seguinte
    NomeBase
    MoedaAfegane - AFA
    IDENTIFICAÇÃO exclusiva do produtoArtista
    Variante de produto identificação exclusivaAutor
  7. Clique em Salvar & voltar.
  8. Clique no catálogo base que você criou e, em seguida, clique em Open Catalog na barra de ferramentas.
  9. Clique em categorias , clique em novo e, em seguida, digite as seguintes informações:
    Nesta caixaDigite o seguinte
    NomeBlue(L)
    DescriçãoBlue(L)
  10. Clique em Salvar & voltar e em seguida, clique em Voltar .

Criar um catálogo virtual

  1. Na barra de ferramentas, clique em novo e clique em New Catalog Virtual .
  2. Digite as seguintes informações:
    Nesta caixaDigite o seguinte
    NomeVirtual
    MoedaAfegane - AFA
  3. Clique em Salvar & voltar.
  4. Clique no catálogo virtual que você criou e clique em Open Catalog na barra de ferramentas.
  5. No painel de Incluir/excluir , clique em novo .
  6. Na caixa de catálogo , clique em Selecionador de catálogo , clique em catálogo base e, em seguida, clique em Selecionar .
  7. Na lista da regra , clique em Catálogo incluir e, em seguida, clique em concluído .
  8. Clique em Salvar & voltar.
  9. Selecione o catálogo virtual que você criou e, em seguida, clique em recriar na barra de ferramentas.
  10. Na caixa de diálogo Recriar catálogo , clique em OK .
  11. Clique em catálogo virtual e, em seguida, clique em Abrir catálogo .

    Você receber a mensagem de erro mencionada na seção "Sintomas".

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 875517 - Última Revisão: 12/08/2015 08:03:38 - Revisão: 2.3

Microsoft Commerce Server 2002 Standard Edition, Microsoft Commerce Server 2002 Service Pack 1, Microsoft Commerce Server 2002 Service Pack 2, Microsoft Commerce Server 2002 Service Pack 3

  • kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbfix kbbug kbcommserv2002presp4fix KB875517 KbMtpt
Comentários