Algumas regras estão desabilitadas e você recebe uma mensagem de erro ao tentar criar ou habilitar regras no Outlook

Número de KB original: 886616

Sintomas

Depois de atualizar para o Office Outlook 2003 (ou posterior), você poderá notar que algumas de suas regras estão desabilitadas e não podem ser habilitadas. Outras regras funcionam corretamente. Se você tentar habilitar as regras que estão desabilitadas, receberá a seguinte mensagem de erro:

Uma ou mais regras não puderam ser carregadas no servidor do Exchange e foram desativadas. Isso pode ser porque alguns dos parâmetros não têm suporte ou não há espaço suficiente para armazenar todas as suas regras.

Motivo

  • Caixas de correio no Microsoft Exchange Server 2007, Exchange Server 2010 ou Exchange Server 2013

    Esse comportamento ocorrerá se as regras que estão em sua caixa de correio excederem a cota de regras estabelecida para sua caixa de correio. O limite de tamanho de regras para caixas de correio no Exchange Server 2007 (e posterior) tem um tamanho padrão de 64 KB por caixa de correio. O limite total de tamanho de regras também é um limite personalizável de até 256 KB por caixa de correio.

  • Caixas de correio no Exchange Server 2003

    Esse comportamento ocorrerá se as regras que estão em sua caixa de correio excederem um tamanho de 32 quilobytes (KB). O limite total de tamanho de regras para caixas de correio no Exchange Server 2003 é de 32 KB. O limite de regras do Exchange 2003 não pode ser alterado.

No Outlook 2003 e posterior, o tamanho das regras aumentou principalmente para fornecer suporte para o formato Unicode.

Solução alternativa

Se sua caixa de correio estiver no Exchange Server 2007 ou posterior, você poderá pedir ao administrador do Exchange para aumentar a cota de regras para sua caixa de correio.

O comando de exemplo a seguir define a cota de regras como o valor máximo de 256 KB.

Set-Mailbox john@contoso.com -RulesQuota:256kb

O comando de exemplo a seguir permite exibir a cota de regras atual para uma caixa de correio.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Se o administrador do Exchange não puder aumentar a cota de regras para sua caixa de correio, experimente uma das soluções alternativas a seguir que se aplicam a todas as versões do Exchange.

Para contornar esse comportamento para que suas regras sejam restauradas, use um ou mais dos métodos a seguir para diminuir o tamanho de suas regras existentes.

Método 1

Renomeie suas regras para um nome mais curto. Para renomear uma regra no Outlook, siga estas etapas.

Para o Outlook 2010 e versões posteriores:

  1. Na guia Arquivo , clique em Informações.
  2. Clique em Gerenciar Regras e Alertas.
  3. Na guia Regras de email , clique na regra que você deseja renomear.
  4. Clique em Alterar Regras e, em seguida, clique em Renomear Regra.
  5. Digite um nome novo e mais curto para a regra e clique em OK.
  6. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Para Outlook 2007 e Outlook 2003:

  1. No menu Ferramentas , clique em Regras e Alertas.
  2. Na guia Regras de email , clique na regra que você deseja renomear.
  3. Na lista Alterar Regra , clique em Renomear Regra.
  4. Digite um nome novo e mais curto para a regra e clique em OK.
  5. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Método 2

Exclua todas as regras antigas. Para excluir uma regra no Outlook, siga estas etapas:

Para o Outlook 2010 e versões posteriores:

  1. Na guia Arquivo , clique em Informações.
  2. Clique em Gerenciar Regras e Alertas.
  3. Na guia Regras de email , clique na regra que você deseja renomear.
  4. Clique no botão Excluir e clique em Sim para confirmar a exclusão.
  5. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Para Outlook 2007 e Outlook 2003:

  1. No menu Ferramentas , clique em Regras e Alertas.
  2. Na guia Regras de email , clique na regra que você deseja excluir.
  3. Clique em Excluir e clique em Sim para confirmar a exclusão.
  4. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Método 3

Combine regras semelhantes para reduzir o tamanho geral de suas regras. Se for possível, combine regras semelhantes para reduzir o tamanho geral de suas regras. Depois de combinar regras semelhantes, exclua as regras que você não precisa mais. Para editar uma regra existente no Outlook, siga estas etapas.

Para o Outlook 2010 e versões posteriores:

  1. Na guia Arquivo , clique em Informações.
  2. Clique em Gerenciar Regras e Alertas.
  3. Na guia Regras de email , clique na regra que você deseja renomear.
  4. Clique em Alterar Regra e, em seguida, clique em Editar Configurações de Regra.
  5. Modifique a regra conforme apropriado.
  6. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Para Outlook 2007 e Outlook 2003:

  1. No menu Ferramentas , clique em Regras e Alertas.

  2. Na guia Regras de email , clique na regra que você deseja editar.

  3. Na lista Alterar Regra , clique em Editar Configurações de Regra.

    Modifique a regra conforme apropriado.

  4. Quando terminar, clique em Concluir e clique em OK para fechar a caixa de diálogo Regras e Alertas .

Observação

Se a regra for uma regra somente cliente, você deverá clicar em OK duas vezes para fechar a caixa de diálogo Regras e Alertas .

Método 4

Mova o arquivo de pastas pessoais (.pst) para um local que tenha o nome do caminho mais curto. Se você tiver regras que movem mensagens de email para um arquivo .pst, mova o arquivo .pst para um local que tenha o nome de caminho mais curto possível. Por exemplo, mova o arquivo .pst para um local como C:\<file_name.pst>. Para mover o arquivo .pst no Outlook, siga estas etapas:

  1. No Painel de Navegação, clique com o botão direito do mouse em Pastas Pessoais ou no nome da pasta que aparece para o arquivo .pst e clique em Propriedades para <folder_name>.

    Observação

    Essa pasta sempre será uma pasta de nível superior no Painel de Navegação, no Mail.

  2. Na guia Geral , clique em Avançado.

  3. Na caixa de texto Nome do Arquivo , anote o caminho completo e o nome do arquivo do arquivo .pst.

  4. Clique em OK duas vezes para fechar a <caixa de diálogo Propriedades folder_name>.

  5. Saia do Outlook.

  6. Use o Microsoft Windows Explorer para mover o arquivo .pst para o novo local.

    Por padrão, o local de um arquivo .pst é a pasta drive:\Documents and Settings\<user_name>\Local Settings\Application Data\Microsoft\Outlook. O local padrão é uma pasta oculta. Para usar o Windows Explorer para localizar essa pasta, primeiro você deve ativar a exibição de pastas ocultas. Para fazer isso, siga estas etapas:

    1. No Windows Explorer, clique em Opções de Pasta no menu Ferramentas.

    2. Clique na guia Exibir .

    3. Na seção Configurações Avançadas , clique em Mostrar arquivos e pastas ocultos em arquivos e pastas ocultos.

    4. Se você quiser ver todas as extensões de nome do arquivo, clique para limpar a caixa Ocultar extensões para tipos de arquivo conhecidos marcar em Arquivos e Pastas.

      Observação

      As pastas ocultas aparecem esmaecidas para indicar que não são pastas típicas.

    5. Clique em OK.

  7. Use um dos seguintes métodos para abrir o item de email no Painel de Controle:

    • Para fazer isso em um computador baseado em Windows XP ou em um computador baseado no Windows Server 2003, clique em Iniciar, clique em Painel de Controle, clique em Contas de Usuário e clique em Email.

      Observação

      Se você estiver usando a exibição Clássica, clique em Iniciar, clique em Painel de Controle e clique duas vezes em Email.

    • Para fazer isso em um computador baseado no Microsoft Windows 2000, clique em Iniciar, aponte para Configurações, clique em Painel de Controle e clique duas vezes em Email.

  8. Clique em Mostrar Perfis e clique no perfil que contém o arquivo .pst.

  9. Clique em Propriedades e clique em Arquivos de Dados.

  10. Clique no arquivo de dados .pst que você moveu e clique em Configurações.

  11. Quando você receber a solicitação de que o arquivo de dados não pôde ser encontrado no local antigo, clique em OK.

  12. Localize e clique em seu arquivo .pst no novo local da pasta e clique em Abrir.

  13. Clique em OK e clique em Fechar duas vezes.

  14. Clique em OK.

  15. Pare Painel de Controle.

  16. Reinicie o Outlook.

Método 5

Desmarque a caixa somente neste computador marcar. Se você usar uma regra para mover mensagens de email para um arquivo .pst, clique para limpar o neste computador apenas marcar caixa, a menos que você esteja acessando seu Exchange Server email de diferentes computadores cliente. Para fazer isso no Outlook, siga estas etapas:

Para o Outlook 2010 e versões posteriores:

  1. Na guia Arquivo , clique em Informações.
  2. Clique em Gerenciar Regras e Alertas.
  3. Na guia Regras de email , clique na regra que você deseja renomear.
  4. Clique em Alterar Regra e, em seguida, clique em Editar Configurações de Regra.
  5. Clique para limpar a caixa On this machine somente marcar se a caixa marcar estiver selecionada.
  6. Conclua o Assistente de Regras. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

Para Outlook 2007 e Outlook 2003:

  1. No menu Ferramentas , clique em Regras e Alertas.

  2. Na guia Regras de email , clique na regra que você deseja editar.

  3. Na lista Alterar Regra , clique em Editar Configurações de Regra.

  4. Se selecionado, clique para limpar a caixa somente marcar neste computador.

  5. Conclua o Assistente de Regras.

  6. Clique em OK para fechar a caixa de diálogo Regras e Alertas .

    Observação

    Se você usar regras somente cliente que apontam para arquivos de recursos locais, por exemplo, mover itens para uma pasta em um arquivo .pst e usar vários computadores para acessar o Microsoft Outlook, podem ocorrer conflitos de regras. Portanto, algumas regras somente cliente podem estar desabilitadas.