Você está offline; aguardando reconexão

Uma mensagem de erro pode ser registrada no log de depuração do Windows Installer ao tentar instalar um programa que usa o Windows Installer 3.0

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 888310
Sintomas
Quando você tenta instalar um programa que usa o Microsoft Windows Installer 3.0 em um computador com Microsoft Windows XP, a instalação poderá falhar. Além disso, a seguinte mensagem de erro pode ser registrada no log de depuração do Windows Installer:
Depurar: Erro 2203: banco de dados: C:\WINDOWS\Installer\ <file>.msi. Não é possível abrir o arquivo de banco de dados. Erro de sistema-2147287008
Observação: Na mensagem de erro, <file> é um espaço reservado para o nome do arquivo .msi (pacote) que você está tentando instalar.
Causa
Esse problema ocorre porque a função StgCreateDocfile falhará com um valor de retorno STG_E_SHAREVIOLATION. Quando isso ocorre, a classe CHandle não é possível encontrar o identificador de arquivo na lista global para um arquivo de banco de dados que é necessário para instalar o programa.
Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft: Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, é preciso Windows XP Service Pack 2 (SP2) instalado no computador.

Requisito de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Msi.dll3.0.3790.25392,804,22427 De outubro de 200417: 04x 86
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Mais Informações
Para obter mais informações sobre How to Enable Windows Installer Logging no Windows XP, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
314852Como habilitar o log no Windows XP do Windows Installer
Para obter mais informações sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816915Novo esquema para nomeação de arquivos pacotes de atualização de software do Microsoft Windows para
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software
Winx64 Windowsx64 64 bit 64 bits

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 888310 - Última Revisão: 08/29/2007 14:40:21 - Revisão: 2.4

Microsoft Windows Installer 3.0

  • kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwin2000presp5fix kbpubtypekc KB888310 KbMtpt
Comentários
m=document.createElement('meta');m.name='ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?">