Como inserir ou colar uma planilha do Excel 2003 ou uma planilha do Excel 2002 para um desenho no Visio

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Saiba o que isto significa para você e como permanecer protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 898513
Sumário
Este artigo descreve como inserir ou colar um Microsoft Office Excel 2003 planilha ou uma planilha do Microsoft Excel 2002 para um desenho no Microsoft Office Visio. Para incorporar ou vincular uma planilha do Excel em um desenho do Visio, você pode usar o comando objeto no menu Inserir , ou você pode usar o comando Colar especial no menu Editar . Este artigo também descreve um método que você pode usar para exibir uma planilha do Excel que contém muitas colunas e linhas em um desenho do Visio.
INTRODUÇÃO
Este artigo descreve como inserir ou colar uma planilha do Excel 2003 ou uma planilha do Excel 2002 para um desenho no Visio. Você pode usar o comando objeto no menu Inserir , ou você pode usar o comando Colar especial no menu Editar para incorporar ou vincular uma planilha do Excel em um desenho do Visio. Este artigo também descreve um método que você pode usar para exibir uma grande planilha do Excel em um desenho do Visio.

Quando você incorporar uma planilha do Excel em um desenho do Visio, a planilha do Excel se torna parte do desenho. O conteúdo da planilha do Excel incorporada não fazem parte do arquivo de origem. Quando você clica duas vezes em planilha do Excel incorporada no desenho, o Excel executa no lugar. Ou seja, você executar o Excel a partir do Visio. Barras de ferramentas do Excel aparecem, e você pode trabalhar diretamente na planilha do Excel.

Quando você vincula uma planilha do Excel em um desenho do Visio, o conteúdo da planilha do Excel é armazenado no arquivo de origem. O desenho do Visio armazena apenas o local da planilha do Excel. Informações na planilha do Excel são atualizadas somente quando você atualizar o conteúdo do arquivo de origem no Excel.

back to the top

Incorporar ou vincular uma planilha do Excel em um desenho usando o comando objeto no menu Inserir do Visio

Use o comando objeto no menu Inserir para inserir uma planilha do Excel no desenho do Visio. Você pode incorporar ou vincular uma planilha do Excel existente, ou você pode incorporar uma nova planilha do Excel. Para fazer isso, use um dos seguintes métodos, dependendo da sua situação.

Incorporar ou vincular uma planilha do Excel existente

  1. Inicie o Visio e em seguida, abra seu desenho.
  2. Clique em objeto no menu Inserir e, em seguida, clique em Criar do arquivo .
  3. Clique em Procurar . Na caixa de diálogo Procurar , localize a planilha do Excel que você deseja inserir, clique em planilha do Excel e, em seguida, clique em Abrir .
  4. Clique em OK .
  5. Use uma das etapas a seguir, dependendo da sua situação:
    • Se você deseja incorporar a planilha do Excel, certifique-se que a caixa de seleção Vincular ao arquivo não está marcada. Se a caixa de seleção Vincular ao arquivo é marcada, clique para desmarcar a caixa de seleção Vincular ao arquivo .
    • Se você deseja vincular a planilha do Excel, clique para selecionar a caixa de seleção Vincular ao arquivo .
  6. Se você desejar exibir a planilha do Excel como um ícone no desenho, clique para selecionar a caixa de seleção Exibir como ícone .

    Observação Quando você clica para selecionar a caixa de seleção Exibir como ícone , a planilha do Excel é exibida como um ícone no desenho. Para exibir o conteúdo da planilha do Excel, clique duas vezes no ícone.
  7. Clique em OK .
back to the top

Incorporar uma nova planilha do Excel

  1. Inicie o Visio e em seguida, abra seu desenho.
  2. Clique em objeto no menu Inserir .
  3. Clique em Planilha do Microsoft Office Excel na lista tipo de objeto , clique em Criar novo e, em seguida, clique em OK .
  4. Clique duas vezes planilha do Excel incorporada e, em seguida, adicione os dados que você deseja. Quando você terminar de trabalhar em planilha do Excel, clique em uma área da página de desenho que está fora a planilha do Excel para exibir as barras de ferramentas Visio novamente.
back to the top

Incorporar ou vincular uma planilha do Excel em um desenho usando o comando Colar especial no menu Editar do Visio

Use o comando Colar especial no menu Editar para colar uma planilha do Excel ao seu desenho do Visio. Você pode usar esse método para incorporar ou vincular todas as células de uma planilha do Excel existente ou para incorporar ou vincular algumas células de uma planilha do Excel existente. Para fazer isso, execute as seguintes etapas:
  1. Inicie o Excel e em seguida, abra a planilha que você deseja.
  2. Selecione as células que você deseja. Para selecionar todas as células na planilha, clique no botão Selecionar tudo .
  3. No menu Editar , clique em Copiar .
  4. Inicie o Visio e em seguida, abra seu desenho.
  5. No menu Editar , clique em Colar especial .
  6. Use uma das etapas a seguir, dependendo da sua situação:
    • Se você deseja incorporar a planilha do Excel, clique em Colar se ele não ainda estiver selecionado e, em seguida, clique em Planilha do Microsoft Office Excel na lista como .
    • Se você deseja vincular a planilha do Excel, clique em Colar vínculo .
  7. Se você desejar exibir a planilha do Excel como um ícone no desenho, clique para selecionar a caixa de seleção Exibir como ícone .

    Observação Quando você clica para selecionar a caixa de seleção Exibir como ícone , a planilha do Excel é exibida como um ícone no desenho. Para exibir o conteúdo da planilha do Excel, clique duas vezes no ícone.
  8. Clique em OK .
back to the top

Exibir uma grande planilha do Excel em um desenho do Visio

Quando você incorpora uma grande planilha Excel que contém muitas colunas e linhas, você não poderá ver todas as colunas e linhas da planilha incorporada no desenho. Observe que, se você clicar duas vezes na planilha do Excel incorporada, horizontal e barras de rolagem verticais aparecem na planilha do Excel. Você pode usar as barras de rolagem para exibir todas as colunas e linhas na planilha incorporada.

Para exibir todas as células de uma grande planilha do Excel em um desenho do Visio, use o seguinte método como uma alternativa para incorporar a planilha em um desenho. Primeiro, copie a planilha do Excel como uma imagem. Em seguida, cole a imagem ao seu desenho do Visio. Para fazer isso, execute as seguintes etapas:
  1. Para copiar o conteúdo da planilha do Excel como uma imagem, siga estas etapas:
    1. Inicie o Excel e em seguida, abra a planilha que você deseja.
    2. Pressione CTRL+END para ir para a última célula na planilha.
    3. Pressione SHIFT + CTRL + HOME para selecionar o intervalo inteiro de células.
    4. Pressione SHIFT e clique em Copiar imagem no menu Editar .
    5. Na caixa de diálogo Copiar imagem , verifique se que como mostrada na tela é selecionado em aparência . Em seguida, verifique se que imagem está selecionado em formato .
    6. Clique em OK .
  2. Para colar a figura ao seu desenho do Visio, execute estas etapas:
    1. Inicie o Visio e em seguida, abra seu desenho.
    2. No menu Editar , clique em Colar .
back to the top

Ajustar a planilha do Excel para a página de desenho do Visio

Quando você insere ou colar uma planilha do Excel grande existente ao seu desenho do Visio, partes da planilha podem aparecer fora da página de desenho Visio. Para ajustar a planilha do Excel para a página de desenho, use um dos seguintes métodos, dependendo da sua situação:
  • Redimensione a página de desenho. Para redimensionar a página de desenho, pressione CTRL e arraste a borda da página de desenho para que a planilha caiba na página de desenho.
  • Redimensione as colunas na planilha antes de você incorporar a planilha em um desenho do Visio ou antes de copiar a planilha como uma imagem. Em seguida, cole a figura para um desenho do Visio. Quando você redimensiona as colunas em uma planilha, você altera a formatação da planilha. Portanto, talvez você queira tentar esse método usando uma planilha de teste antes de você usar esse método na planilha que você deseja exibir em um desenho do Visio. Para redimensionar colunas na planilha, siga estas etapas:
    1. Inicie o Excel e em seguida, abra a planilha que você deseja.
    2. No menu Formatar , aponte para coluna e, em seguida, clique em AutoAjuste da seleção .

      Observação Se você desejar desfazer a operação de AutoAjuste, clique no botão Desfazer .
back to the top
Referências
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
296528Como vincular um desenho do Visio a uma região específica em uma planilha do Excel
back to the top
pasta de trabalho vso2007 vso 2 k 2 k 3 planilha

Aviso: este artigo foi traduzido automaticamente

Proprietăți

ID articol: 898513 - Ultima examinare: 11/14/2006 22:02:47 - Revizie: 2.2

Microsoft Office Visio Professional 2007, Microsoft Office Visio Standard 2007, Microsoft Office Visio Professional 2003, Microsoft Office Visio Standard 2003, Microsoft Visio 2002 Professional Edition, Microsoft Visio 2002 Standard Edition

  • kbmt kbnewfile kbopenfile kbhowto KB898513 KbMtpt
Feedback