Você está offline; aguardando reconexão

Um computador cliente pode fazer do Terminal Services aviso sonoro sons depois que você se conectar a um computador baseado no Windows Server 2003 Service Pack 1

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 901115
Sintomas
Depois de se conectar a um computador baseado no Microsoft Windows Server 2003 Service Pack 1 por meio de uma sessão de serviços de terminal, o computador cliente de serviços de terminal pode tornar um alarme sonoro som quando determinados eventos ocorrerem.

Por exemplo, esse problema ocorre quando você iniciar o bloco de notas em um computador cliente de serviços de terminal, digite alguns caracteres e feche o bloco de notas sem salvar as alterações. Uma caixa de mensagem solicita que você salvar as alterações feitas. A caixa de mensagem é aberta com um som de alarme sonoro.

Observação Você esses sintomas após a instalação do Windows Server 2003 Service Pack 1 em um servidor de terminal.
Causa
Esse problema ocorre porque a função MessageBeep é redirecionada para o computador cliente de serviços de terminal. Se o computador de cliente de serviços de terminal não dá suporte ao áudio, o som de alarme sonoro é executado por meio de alto-falante do sistema.
Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

Windows Server 2003, versões com base em 86 x

   Date         Time   Version            Size    File name   --------------------------------------------------------------   11-Jun-2005  03:02  5.2.3790.346      988,672  Kernel32.dll        11-Jun-2005  03:02  5.2.3790.346      222,208  Termsrv.dll         11-Jun-2005  03:02  5.2.3790.346       52,224  Winsta.dll          25-Feb-2005  03:51  6.1.22.4          371,936  Updspapi.dll

Windows Server 2003 com Service Pack 1, versões com base em 86 x

   Date         Time   Version            Size    File name    --------------------------------------------------------------------   30-Jun-2005  02:35  5.2.3790.360      988,672  Kernel32.dll        30-Jun-2005  02:35  5.2.3790.360      222,208  Termsrv.dll         30-Jun-2005  02:35  5.2.3790.360       52,224  Winsta.dll          05-Mar-2005  01:30  6.1.22.4          371,936  Updspapi.dll     30-Jun-2005  03:06  5.2.3790.2477     245,248  Termsrv.dll         30-Jun-2005  00:58  5.2.3790.2477      32,256  Arpidfix.exe   

Windows Server 2003, versões com base em Itanium

    Date         Time   Version            Size    File name       Platform   --------------------------------------------------------------------   10-Jun-2005  14:29  5.2.3790.346    1,851,392  Kernel32.dll     IA-64   10-Jun-2005  14:29  5.2.3790.346      621,568  Termsrv.dll      IA-64   10-Jun-2005  14:29  5.2.3790.346      141,824  Winsta.dll       IA-64   10-Jun-2005  14:32  5.2.3790.346      934,912  Wkernel32.dll    x86   10-Jun-2005  14:32  5.2.3790.346       52,224  Wwinsta.dll      x86   24-Feb-2005  15:22  6.1.22.4          639,712  Updspapi.dll     IA-64

Windows Server 2003 com Service Pack 1, versões com base em Itanium

   Date         Time   Version            Size    File name         Platform   -----------------------------------------------------------------------   29-Jun-2005  15:02  5.2.3790.360    1,851,392  Kernel32.dll     IA-64   29-Jun-2005  15:02  5.2.3790.360      621,568  Termsrv.dll      IA-64   29-Jun-2005  15:02  5.2.3790.360      141,824  Winsta.dll       IA-64   29-Jun-2005  15:02  5.2.3790.360      934,912  Wkernel32.dll    x86   29-Jun-2005  15:02  5.2.3790.360       52,224  Wwinsta.dll      x86   29-Jun-2005  15:02  5.2.3790.2477     696,320  Termsrv.dll      IA-64   29-Jun-2005  15:02  5.2.3790.2477      74,752  Arpidfix.exe     IA-64   29-Jun-2005  15:02  6.1.22.4          639,712  Updspapi.dll     IA-64

Windows Server 2003, versões com base em 64 x

   Date         Time   Version            Size    File name   --------------------------------------------------------------   29-Jun-2005  15:02  5.2.3790.2477     363,008  Termsrv.dll         29-Jun-2005  15:02  5.2.3790.2477      43,008  Arpidfix.exe        29-Jun-2005  15:02  6.1.22.4          462,560  Updspapi.dll
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.
Mais Informações
importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


Depois de aplicar o hotfix, você pode usar o registro para habilitar o redirecionamento da função MessageBeep . Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite DisableBeep e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse DisableBeep e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , digite 0 e, em seguida, clique em OK .

    Observação Você pode desativar a função MessageBeep alterando o valor para 1.
  7. Feche o Editor do Registro.
Para obter mais informações sobre a descrição da terminologia padrão que é usada para descrever as atualizações de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do Artigo: 901115 - Última Revisão: 10/11/2007 02:28:10 - Revisão: 2.7

Microsoft Windows Server 2003 Service Pack 1, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Standard x64 Edition

  • kbmt kbautohotfix kbwinserv2003sp2fix kbhotfixserver kbbug kbfix kbqfe kbpubtypekc KB901115 KbMtpt
Comentários
nt.write(" hild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> t.write("