Você pode receber uma mensagem de erro quando você tenta imprimir um documento em uma impressora compartilhada de rede de um computador que esteja executando o Windows 2000

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 903932
importante Este artigo contém informações que mostra como ajudar a reduzir as configurações de segurança ou como desativar os recursos de segurança em um computador. Você pode fazer essas alterações para solucionar um problema específico. Antes de fazer essas alterações, recomendamos que avalie os riscos associados à implementação dessa solução alternativa no seu ambiente específico. Se você implementar essa solução alternativa, execute quaisquer etapas apropriadas adicionais para ajudar a proteger seu sistema.
Sintomas
Quando você imprime um documento em uma impressora compartilhada de rede de um computador que esteja executando o Microsoft Windows 2000, o trabalho de impressão não produz saída. Você receberá uma mensagem de erro informando que você não pode imprimir um documento ou que você tiver uma impressora inválida. A mensagem de erro exata varia dependendo do aplicativo que você usa para enviar o trabalho de impressão. Esse problema não ocorre se você efetuar logon para o computador usando uma conta administrativa.

Você pode receber uma das seguintes sintomas, dependendo do seu aplicativo:
  • Se você tentar imprimir um documento do Microsoft Internet Explorer, você recebe uma das seguintes mensagens de erro:
    Antes de imprimir, você precisa selecionar uma impressora. Se você precisar instalar uma impressora, clique duas vezes no ícone Adicionar impressora ou clique no botão Localizar impressora localizado na guia geral desta caixa de diálogo.
    Você não tem permissão para usar a impressora selecionada. Se você precisar acessar, contate o administrador de rede.
  • Se você tentar imprimir um documento do bloco de notas, você receber a seguinte mensagem de erro:
    Impressora PrinterName não está mais disponível. Feche a caixa de diálogo de propriedades e selecione outra impressora.

    Observação PrinterName é um espaço reservado para o nome da impressora.
  • Se você tentar imprimir um documento do Microsoft Excel, você receber a seguinte mensagem de erro:
    A impressora atual não está disponível. Selecione outra impressora.
  • Se você tentar imprimir um documento do Microsoft PowerPoint, você receber a seguinte mensagem de erro:
    Nenhuma impressora instalada.
  • Se você tentar imprimir um documento do Microsoft Outlook, você receber uma das seguintes mensagens de erro:
    Nenhuma impressora instalada. Para instalar uma impressora, aponte para configurações de iniciar o Windows Menu, clique em impressora e, em seguida, clique duas vezes em Adicionar impressora. Siga as instruções no assistente.
    Você não tem permissão para usar a impressora selecionada. Se você precisar acessar, contate o administrador de rede.
  • Se você tentar imprimir um documento do Lotus Notes, você receber a seguinte mensagem de erro:
    Memória insuficiente
  • Se você tentar imprimir um documento do Microsoft Word, você não pode receber qualquer mensagem de erro, mas não é possível imprimir o trabalho de impressão.
Causa
Esse problema normalmente ocorre quando as seguintes condições forem verdadeiras:
  • O servidor de impressora foi atualizado do Windows 2000 para Microsoft Windows Server 2003.
  • A versão do Windows Server 2003 do driver de impressora são enviados do servidor de impressão para um computador que esteja executando o Windows 2000. Para fazer isso, use a ferramenta Citrix ou a ferramenta Printui.
  • Você conectado ao computador que esteja executando o Windows 2000 usando uma conta não administrativa.
Esse problema ocorre porque você não tem permissões de gravação para a pasta Windows\System32\Spooler\Drivers\W32x86\3. O serviço Spooler de impressora não é possível criar ou recriar um arquivo de descrição de impressora binários analisados (.bud) quando o arquivo de impressora .GPD relacionados é atualizado.

O arquivo .bud não é criado ou atualizado quando você pressiona a versão do Windows Server 2003 do driver de impressora do servidor de impressão para o computador onde você está executando o aplicativo. Quando você tentar usar uma impressora quando um arquivo .bud está faltando ou não corresponde ao arquivo .gpd, o serviço Spooler de impressora será criar ou recriar o arquivo .bud. No entanto, se você não tiver as permissões para criar ou recriar o arquivo .bud, o problema ocorre.

Observação O arquivo .bud é uma versão binária do arquivo de descrição de impressora genérico (.gpd) que está incluído com muitos drivers de impressora. O arquivo .bud está localizado na pasta Windows\System32\Spooler\Drivers\W32x86\3.
Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Depois de aplicar o hotfix, reinicie o serviço Spooler de impressão.

Informações sobre a substituição do hotfix

Esse hotfix substitui o hotfix descrito no seguinte artigo da Base de dados de Conhecimento:
873396Você receber uma mensagem de erro se você tentar imprimir um documento em computadores baseados no Windows 2000 e baseado no Windows XP (873396)

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Windows 2000 Service Pack 4
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRamificação do serviço
Faxui.dll0.2.0.2138,00019 De julho de 200506: 13x 86Não aplicável
Localspl.dll5.0.2195.7060260,36819 De julho de 200506: 13x 86Não aplicável
Sp3res.dll5.0.2195.70406,309,37621-Abr-200510: 07x 86Não aplicável
Spoolss.dll5.0.2195.705481,16819 De julho de 200506: 13x 86Não aplicável
Winsrv.dll5.0.2195.7029244.49612-Mar-200507: 54x 86Não aplicável
Winsrv.dll5.0.2195.7029244.49612-Mar-200507: 54x 86UNIPROC
Como Contornar
Aviso Esta solução alternativa pode tornar seu computador ou sua rede mais vulneráveis aos ataques de usuários mal-intencionados ou softwares mal-intencionados como vírus. Nós não recomendamos esta solução alternativa, mas são fornece essas informações para que você pode implementar essa solução alternativa sua vontade. Use esta solução alternativa por seu próprio risco.

Para contornar esse problema, conceda escrever permissão para a pasta Windows\System32\Spooler\Drivers\W32x86\3 e suas subpastas.
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".O problema é uma limitação do spooler corrigido no Windows Server 2003 Service Pack 1. Não há nenhum hotfix para a versão original do Windows Server 2003.
Mais Informações
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.
Lista de produtos beta, local de Hotfix PCL/PS

Aviso: este artigo foi traduzido automaticamente

Proprietăți

ID articol: 903932 - Ultima examinare: 07/26/2006 16:08:08 - Revizie: 1.3

Microsoft Windows 2000 Advanced Server SP4, Microsoft Windows 2000 Datacenter Server, Microsoft Windows 2000 Professional SP4, Microsoft Windows 2000 Server SP4

  • kbmt kbautohotfix kbbug kbfix kbwinserv2003presp1fix kbpubtypekc kbhotfixserver kbqfe KB903932 KbMtpt
Feedback