Você receber a mensagem de erro "argumento ou chamada de procedimento inválida" ao usar o Assistente de petições legais no Word 2003

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 906308
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Sumário
Este artigo descreve uma mensagem de erro que pode ser exibida quando você usa o Assistente de petições legais no Microsoft Office Word 2003. Esse problema ocorre se os
Data
e subchaves de
Options
para o Word 2003 estão corrompidas. Para resolver esse problema, remova essas duas subchaves. Word 2003 recria essas duas subchaves usando as configurações padrão na próxima vez que você iniciar o programa.
Sintomas
Quando você clica em Concluir para concluir as etapas que estão no Assistente de Petição Legal no Microsoft Office Word 2003, você recebe uma mensagem de erro semelhante à seguinte:
Argumento ou chamada de procedimento inválida
Além disso, o documento que você tentou criar usando o Assistente de petições legais não é salvo.
Causa
Esse problema ocorre se as seguintes subchaves do Registro estão corrompidas:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
Resolução
Para resolver esse problema, exclua as subchaves de dois registro que são descritas na seção "Causa" antes de executar o Assistente de petições legais. Para excluir as subchaves do Registro, use um dos seguintes métodos.

Método 1: Usar o modelo suporte

O modelo de suporte está um utilitário de solução de problemas que está disponível no Microsoft Word. O modelo suporte é instalado quando você usar a opção Instalação completa para instalar o Word 2003. f você usou a opção de atualização ou a opção Instalação típica para instalar o Microsoft Word, o modelo suporte não está instalado.

Você pode usar o modelo suporte para remover os
Data
e subchaves de
Options
. No entanto, você deve execute essas etapas nesta ordem antes você pode usar o modelo suporte para remover os
Data
e
Options
subchaves:
  1. Instalar o modelo suporte.
  2. Crie um atalho para o modelo suporte.
No entanto, o modelo suporte pode já foram instalado. Além disso, um atalho para executar o modelo suporte talvez já exista. Nesse caso, vá para a seção "Excluir a subchave de registro de dados".

Observação No caso você queira restaurar as configurações originais, o modelo suporte cria um backup dos
Data
e subchaves de
Options
.

Instalar o modelo suporte

Para instalar o modelo suporte, execute estas etapas:
  1. Clique em Iniciar e em seguida, clique em Painel de controle .
  2. Clique em Adicionar ou remover programas .
  3. Clique em alterar ou remover programas .
  4. Na lista programas instalados , clique na sua versão do Microsoft Office 2003 e, em seguida, clique em Alterar .
  5. Clique em Adicionar ou remover recursos e, em seguida, clique em Avançar .
  6. Na Instalação personalizada , clique para selecionar a caixa de seleção Escolha a personalização de aplicativos avançada e em seguida, clique em Avançar .
  7. Na lista Escolher opções de atualização para aplicativos e ferramentas , execute estas etapas:
    1. Expanda Microsoft Office Word .
    2. Expanda assistentes e modelos .
    3. Clique no ícone mais modelos e macros e, em seguida, clique em Executar todos do meu computador .
  8. Clique em Update para instalar o modelo suporte.

Criar um atalho para o modelo suporte

Para criar um atalho para o modelo suporte, execute as seguintes etapas:
  1. Clique duas vezes nele sua área de trabalho, aponte para novo e, em seguida, clique em atalho .
  2. Clique em Procurar .
  3. Na caixa de diálogo Criar atalho , clique em qualquer lugar na caixa Digite o local do item e, em seguida, digite a seguinte instrução de caminho padrão:
    "C:\Arquivos de Programas\Microsoft Office\Office11\Winword.exe"/a"c:\Arquivos Programas\Microsoft Office\Office11\Macros\Support.dot"
    Observação Se você instalou o Word em um local diferente, altere o caminho padrão da mesma forma.
  4. Clique em Avançar para continuar.
  5. Na caixa Digite um nome para este atalho , digite Modelo suporte e, em seguida, clique em Concluir .

Excluir a subchave do registro de dados

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Maioria das opções usadas com freqüência para o Word é armazenadas na subchave de registro de
Data
. Para exibir essas opções, clique em Opções no menu Ferramentas . Depois de excluir a subchave de registro de
Data
, o Word recria essa subchave de registro de
Data
usando as configurações padrão na próxima vez que você inicia o Word.

Observação Se você excluir a subchave de registro de
Data
, o Word redefine várias opções de volta às suas configurações padrão. Um exemplo dessas opções é a lista de arquivos usados recentemente no menu arquivo . Além disso, o Word restaurará várias configurações que você personalizou na caixa de diálogo Opções .

Para excluir a subchave de registro de
Data
, execute essas etapas:
  1. Feche todos os programas do Microsoft Office.
  2. Clique duas vezes o atalho do Modelo suporte na área de trabalho.
  3. No Modelo suporte , clique em Solução de problemas utilitário .
  4. Na caixa de diálogo Utilitário de solução de problemas do Microsoft Word , clique em Chave de registro de dados na lista Selecionar um item e, em seguida, clique em Excluir .
  5. Clique em OK quando receber a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Data
    Arquivo de backup para essa chave do Registro está em:
    C:\DOCUME~1\username\LOCALS~1\Temp\wddata11.0

    Chave do registro foi excluído.
  6. Clique em Fechar .
  7. No menu arquivo , clique em Sair para fechar o Word.
  8. Inicie o Word.

    Observação Não use o atalho do modelo suporte na área de trabalho para iniciar o Word na etapa 8.
Talvez você precise alterar várias configurações para restaurar suas opções favoritas no Word. Se, por algum motivo, você desejar restaurar a subchave de registro
Data
original, você deve seguir essas etapas:
  1. Feche todos os programas do Office.
  2. Clique duas vezes o atalho do Modelo suporte na área de trabalho.
  3. No Modelo suporte , clique em Solução de problemas utilitário .
  4. Na caixa de diálogo Utilitário de solução de problemas do Microsoft Word , clique em Chave de registro de dados na lista Selecionar um item e clique em Restaurar .
  5. Clique em Sim quando receber a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Esta chave está presente no registro.
    Substituí-lo?
  6. Clique em OK quando receber a seguinte mensagem:
    Chave de registro HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data

    restauração bem-sucedida.
  7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word e saia do Word.

Excluir a subchave do registro de opções

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

A subchave do Registro
Options
armazena as opções que você pode definir do Word. Exemplos dessas opções estiverem alterando as opções de menu ou executando a macro RegOptions . As opções são divididas nas configurações padrão ou configurações opcionais. As configurações padrão são estabelecidas durante a instalação. Você pode alterar as configurações padrão modificando as opções no Word. As configurações opcionais não são criadas durante a instalação.

Para excluir a subchave de registro de
Options
, siga estas etapas.
  1. Feche todos os programas do Office.
  2. Clique duas vezes o atalho do Modelo suporte na área de trabalho.
  3. No Modelo suporte , clique em Solução de problemas utilitário .
  4. Na caixa de diálogo Utilitário de solução de problemas do Microsoft Word , clique em Chave de registro de opções na lista Selecionar um item e, em seguida, clique em Excluir .
  5. Clique em OK quando receber a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft Office\11.0\Word\Options

    Arquivo de backup para essa chave do Registro está em:

    C:\DOCUME~1\username\LOCALS~1\Temp\wdoptn11.0

    Chave do registro foi excluído.
  6. Clique em Fechar .
  7. No menu arquivo , clique em Sair para fechar o Word.
  8. Inicie o Word.

    Observação Não use o atalho do modelo suporte na área de trabalho para iniciar o Word na etapa 8.
Talvez você precise alterar várias configurações para restaurar suas opções favoritas no Word. Se, por algum motivo, você desejar restaurar seu original subchave do Registro
Options
, você deve seguir essas etapas:
  1. Feche todos os programas do Office.
  2. Clique duas vezes o atalho do modelo suporte na área de trabalho.
  3. No Modelo suporte , clique em Solução de problemas utilitário .
  4. Na caixa de diálogo Utilitário de solução de problemas do Microsoft Word , clique em Chave de registro de opções na lista Selecionar um item e clique em Restaurar .
  5. Clique em Sim quando receber a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    Esta chave está presente no registro.

    Substituí-lo?
  6. Clique em OK quando receber a seguinte mensagem:
    Chave de registro HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    restauração bem-sucedida.
  7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word e saia do Word.

Método 2: Exclua manualmente as subchaves do registro

Você pode excluir manualmente as subchaves de registro de
Data
e
Options
usando o Editor do Registro.

Observação Fazer backup as subchaves do registro antes de excluí-los no caso você queira restaurar as configurações originais.

Excluir manualmente a subchave de registro de dados

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Maioria das opções usadas com freqüência são armazenadas na subchave de registro de
Data
. Para exibir essas opções, clique em Opções no menu Ferramentas . Quando você excluir a subchave de registro de
Data
, na próxima vez que você inicia o Word, Word recria essa subchave de registro de
Data
usando as configurações padrão.

Observação Quando você excluir a subchave de registro de
Data
, o Word redefine várias opções de volta às suas configurações padrão. Um exemplo dessas opções é a lista de arquivos usados recentemente no menu arquivo . Além disso, o Word restaurará várias configurações que você personalizar na caixa de diálogo Opções .

Para excluir a subchave de registro de
Data
, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Clique em Iniciar , clique em Executar e digite regedit na caixa Abrir .
  3. Clique em OK .
  4. Localize a seguinte subchave do registro no Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
  5. Clique na pasta de dados .
  6. No menu registro , clique em Exportar arquivo do Registro , digite um nome de arquivo e, em seguida, clique em Salvar . Por padrão, o arquivo .reg é salvo na pasta Meus documentos .
  7. Com a pasta de dados selecionada, clique em Excluir no menu Editar .
  8. Clique em Sim quando receber a seguinte mensagem:
    Tem certeza de que deseja excluir esta chave?
  9. No menu arquivo , clique em Sair para fechar o Editor do Registro.
  10. Inicie o Word.

    Observação Não use a opção /a para iniciar o Word.
Talvez você precise alterar várias configurações para restaurar suas opções favoritas no Word. Se, por algum motivo, você desejar restaurar a subchave de registro
Data
original, você deve seguir essas etapas:
  1. Localize o arquivo .reg à qual você exportado a subchave de registro de
    Data
    para anteriormente e, em seguida, clique duas vezes no arquivo .reg.
  2. Clique em Sim quando receber a seguinte mensagem:
    Tem certeza de que deseja adicionar as informações em Drive_Letter:\path\filename .reg no registro?

Excluir manualmente a subchave de registro de opções

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

A subchave do Registro
Options
armazena as opções que você pode definir do Word. Exemplos dessas opções estiverem alterando as opções de menu ou executando a macro RegOptions . As opções são divididas nas configurações padrão ou configurações opcionais. As configurações padrão são estabelecidas durante a instalação. Você pode alterar as configurações padrão modificando as opções no Word. As configurações opcionais não são criadas durante a instalação.

Para excluir a subchave de registro de
Options
, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Clique em Iniciar , clique em Executar e digite regedit na caixa Abrir .
  3. Clique em OK .
  4. Localize a seguinte subchave do registro no Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
  5. Clique em Opções .
  6. No menu registro , clique em Exportar arquivo do Registro , digite um nome de arquivo e, em seguida, clique em Salvar . Por padrão, o arquivo .reg é salvo na pasta Meus documentos .
  7. Com a pasta de Opções selecionada, clique em Excluir no menu Editar .
  8. Clique em Sim quando receber a seguinte mensagem:
    Tem certeza de que deseja excluir esta chave?
  9. No menu arquivo , clique em Sair .
  10. Inicie o Word.

    Observação Não use a opção /a para iniciar o Word.
Talvez você precise alterar várias configurações para restaurar suas opções favoritas no Word. Se, por algum motivo, você desejar restaurar a subchave de registro de
Options
original, você deve seguir essas etapas:
  1. Localize o arquivo .reg à qual você exportar a subchave de registro de
    Options
    para anteriormente e, em seguida, clique duas vezes no arquivo .reg.
  2. Clique em Sim quando receber a seguinte mensagem:
    Tem certeza de que deseja adicionar informações da Drive_Letter:\path\ filename.reg no registro?
Mais Informações
As subchaves do Registro podem ser corrompidas se o Assistente de petições legais passa um parâmetro que tenha uma das seguintes condições na chamada de procedimento:
  • Parâmetro está fora do intervalo.
  • Parâmetro contém dados inválidos,
Como alternativa, o Assistente de petições legais pode ter chamado um procedimento em um horário inesperado.
Referências
Para obter mais informações sobre como solucionar problemas do Microsoft Office Word 2003, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
820919Como solucionar problemas que ocorrem quando você inicia ou usar o Word 2003 ou o Word 2002

Aviso: este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 906308 - Última Revisão: 12/09/2015 03:07:38 - Revisão: 2.2

Microsoft Office Word 2003

  • kbnosurvey kbarchive kbmt kbprb KB906308 KbMtpt
Comentários