Você pode receber uma mensagem de erro "MEM_BAD_POINTER" em um computador que está executando o Windows XP com Service Pack 2

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 910466
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Quando você executa um programa que usa software de gerenciamento de heap MicroQuill SmartHeap em um computador que está executando o Microsoft Windows XP com Service Pack 2, você receberá uma mensagem de erro semelhante à seguinte:
MEM_BAD_POINTER
Causa
Esse problema ocorre se a caixa de seleção instalar arquivos para idiomas do Leste Asiático estiver selecionada no item de painel de controle regionais e de idioma .
Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 2 (SP2) instalado.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Usp10.dll1.420.2600.2791406,01608 De novembro de 200502: 24x 86
Como Contornar
Para contornar esse problema, execute estas etapas:
  1. Clique em Iniciar , clique em Executar , digite intl.cpl na caixa Abrir e, em seguida, clique em OK .
  2. Clique na guia idiomas , clique para desmarcar a caixa de seleção instalar arquivos para idiomas do Leste Asiático e a caixa de seleção instalar arquivos para idiomas escritos da direita para a esquerda e script complexo e, em seguida, clique em OK duas vezes.
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Mais Informações
Para obter mais informações sobre a terminologia usada neste artigo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Propriedades

ID do Artigo: 910466 - Última Revisão: 12/09/2015 03:44:15 - Revisão: 3.2

Microsoft Windows XP Service Pack 2

  • kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbpubtypekc KB910466 KbMtpt
Comentários