Solicitações de função de encaminhamento de chamada de TAPI 2.x clientes falham com um erro de "LINEERR_INVALIDPARAM" em um servidor de telefonia baseado no Windows Server 2003

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 954057
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Considere o seguinte cenário:
  • Em um ambiente de rede, um computador baseado no Windows Server 2003 funciona como um servidor de telefonia.
  • Um aplicativo usa 2 TAPI. x para implementar a função de encaminhamento de chamadas.
  • A solicitação de encaminhamento de chamadas é emitida em um computador cliente que está executando o Windows XP ou o Windows Vista.
Nesse cenário, a função de encaminhamento de chamadas falhará e código de erro LINEERR_INVALIDPARAM é retornado. Portanto, os usuários não é possível usar a funcionalidade de encaminhamento de chamadas.
Causa
Esse problema ocorre porque o método de verificação de versão TAPI no lado do cliente difere do método de verificação de versão TAPI no lado do servidor. Essa incompatibilidade faz com que a função falhar.
Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site: Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 2 (SP2) instalado.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do registro

Para usar esse hotfix, não é necessário fazer alterações no registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 SP2, versões com base em 86 x
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Tapisrv.dll5.2.3790.4347254.97604-Agosto de 200814: 20x 86
Windows Server 2003 SP2 e Windows XP SP2, versões com base em 64 x
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Tapisrv.dll5.2.3790.4347407,55204-Agosto de 200812: 10x 64SP2Não aplicável
Wtapisrv.dll5.2.3790.4347254.97604-Agosto de 200812: 10x 86SP2UAU
Windows Server 2003 SP2, versões com base em Itanium
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Tapisrv.dll5.2.3790.4347697,34404-Agosto de 200812: 04IA-64SP2Não aplicável
Wtapisrv.dll5.2.3790.4347254.97604-Agosto de 200812: 04x 86SP2UAU
Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Mais Informações
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Suporte técnico para versões com base em 64 x do Microsoft Windows

Se o hardware veio com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornecerá suporte técnico e assistência para a edição x 64 do Windows. Nesse caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows do usando componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware. Se você comprou uma edição x 64 do Windows, como um Windows Server 2003 x 64 edition separadamente, contate a Microsoft para obter suporte técnico.

Para informações de produto sobre o Windows XP Professional x 64 Edition, visite o seguinte site: Para informações de produto sobre versões com base em 64 x do Windows Server 2003, visite o seguinte site:

Propriedades

ID do Artigo: 954057 - Última Revisão: 01/15/2015 10:10:13 - Revisão: 1.0

Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems, Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows XP Professional x64 Edition

  • kbnosurvey kbarchive kbmt kbautohotfix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB954057 KbMtpt
Comentários