Adicionar ou remover suplementos no Excel

Os complementos fornecem comandos e recursos opcionais para Microsoft Excel. Por padrão, os complementos não estão disponíveis imediatamente no Excel, portanto, você deve primeiro instalar e (em alguns casos) ativar esses complementos para que você possa usá-los.

Você está procurando informações sobre Office de complementos com base em HTML, CSS e JS? Se você estiver, consulte Obter um Office de Excel.

Alguns complementos são integrados Excel, como Solver e Analysis ToolPak. Outros complementos estão disponíveis no Centro de Download e devem primeiro ser baixados e instalados. Por fim, há complementos criados por terceiros, como um programador em sua organização ou um provedor de soluções de software. Eles podem ser os complementos do Modelo de Objeto de Componente (COM), os Visual Basic for Applications (VBA) e os complementos DLL. Esses complementos também devem ser instalados para usá-los.

A maioria dos complementos pode ser categorizada em três tipos diferentes:

  • Excel de complementos    Geralmente, eles incluem Excel de um add-in (.xlam), Excel 97-2003 add-in (.xla) ou arquivos de complemento DLL (.xll) ou são complementos de automação. Alguns Excel, como o Solver e o Analysis ToolPak, podem estar disponíveis após a instalação Excel ou Microsoft Office. Normalmente, você só precisa ativar esses complementos para usá-los.

  • Complementos baixáveis    Os complementos adicionais para Excel podem ser baixados e instalados em Downloads em Office.com.

  • Complementos personalizados    Desenvolvedores e provedores de soluções geralmente projetam complementos COM (Modelo de Objeto de Componente) personalizados, complementos de automação, complementos VBA e complementos XLL. Eles devem ser instalados para você usá-los.

Depois de ter instalado ou ativado um complemento, o complemento e seus comandos podem estar disponíveis em um dos seguintes locais:

  • Guia Dados. Depois de instalar e ativar os complementos Analysis ToolPak e Solver, os comandos Análise de Dados e Solver estarão disponíveis no grupo Análise.

    Botão Análise de Dados no grupo Análise de Dados

  • Guia Fórmulas. Depois de instalar e ativar as Ferramentas Conversor de Moedas Euro, os comandos Conversão de Euro e Formatação de Euro são exibidos no grupo Soluções.

    Conversão do Euro e Formatação do Euro

  • Guia Add-Ins. Outros complementos podem ser adicionados à guia Complementos. Essa guia é adicionada à faixa de opções quando você instala e ativa o primeiro complemento mostrado na guia Complementos. Se você não vir a guia Complementos, saia e reinicie Excel.

Outros Introdução, como a guia Introdução, estão disponíveis em outros locais no Excel, como uma guia na faixa de opções ou por meio de macros ou menus personalizados.

Importante: Se você for um desenvolvedor de software, poderá usar este procedimento para instalar ou remover um programa de automação antes de projetar programas de instalação e remoção para o seu complemento.

Para ativar um Excel de dados    

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

    A caixa de diálogo Add-Ins é exibida.

  3. Na caixa Complementos disponíveis, marque a caixa de seleção ao lado do complemento que você deseja ativar e clique em OK.

Se você não conseguir encontrar o add-in que deseja ativar na caixa Adicionar-Ins disponíveis, talvez seja necessário instalá-lo.

Para instalar um Excel de dados    

  • Para instalar um add-in normalmente instalado com o Excel, como Solver ou Analysis ToolPak, execute o programa de instalação para Excel ou Microsoft Office e escolha a opção Alterar para instalar o add-in. Depois de reiniciar Excel, o add-in deverá aparecer na caixa Adicionar-Ins disponível.

  • Alguns Excel estão localizados em seu computador e podem ser instalados ou ativados clicando em Procurar (na caixa de diálogo Adicionar Ins) para localizar o complemento e clicar em OK.

  • Alguns Excel de instalação exigem a execução de um pacote de instalação. Talvez seja necessário baixar ou copiar o pacote de instalação para o computador (um pacote de instalação normalmente é um arquivo com uma extensão .msi nome de arquivo) e, em seguida, execute-o.

  • Outros complementos que não estão disponíveis no computador podem ser baixados e instalados por meio de um navegador da Web a partir de Downloads ou de outros sites na Internet ou em um servidor em sua organização. Siga as instruções de instalação para o download, conforme necessário.

Para inativar um Excel de dados    

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

  3. Na caixa Complementos disponíveis, desmarcar a caixa de seleção ao lado do complemento que você deseja inativar e clique em OK.

    Em muitos casos, quando você inativa um complemento, ele é removido de seu grupo na faixa de opções. Em outros casos, para remover o complemento da faixa de opções, talvez seja necessário reiniciar Excel.

    Observação    A inativação de um complemento não remove o complemento do computador. Para remover o complemento do computador, você deve desinstalá-lo.

Para remover um Excel de dados    

Importante: Se você instalou originalmente o Excel de um servidor de arquivos de rede ou de uma pasta compartilhada, talvez seja necessário remover o complemento desse local. Se você instalou o Excel de um CD e mapeou sua unidade de CD para uma nova letra de unidade após a instalação do add-in, você precisará reinstalar o complemento do CD. Se você estiver executando Excel do CD, desinstale os Excel e reinstale-os do CD.

  1. Clique na guia Arquivo e clique em Sair.

  2. No Painel de Controle, clique em Programas e Recursos (Windows 7 e Windows Vista) ou Adicionar/Remover Programas (Windows XP).

  3. Siga um destes procedimentos:

    • Se você instalou Excel como parte do Microsoft Office, clique em Microsoft Office na lista de programas instalados e clique no botão Alterar.

    • Se você instalou Excel individualmente, clique no nome do programa na lista de programas instalados e clique no botão Alterar.

    • Se você instalou o complemento na Central de Download, clique no nome do programa na lista de programas instalados e clique no botão Desinstalar.

  4. Siga as instruções no programa de instalação.

Importante: Se você for um desenvolvedor de software, poderá usar este procedimento para instalar ou remover um programa de automação antes de projetar programas de instalação e remoção para o seu complemento. Se você não for um desenvolvedor, não precisará usar este procedimento. Entre em contato com o administrador do sistema que forneceu o complemento se quiser instruções de instalação e remoção.

Adicionar um complemento COM

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Complementos COMe clique em Ir.

    A caixa de diálogo Complementos COM é exibida.

  3. Na caixa Complementos disponíveis, marque a caixa de seleção ao lado do complemento que você deseja instalar e clique em OK.

    Dica    Se o complemento que você deseja usar não estiver listado na caixa Complementos disponíveis, clique em Adicionar elocalize o complemento.

Remover um complemento COM

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Complementos COMe clique em Ir.

    A caixa de diálogo Complementos COM é exibida.

  3. Na caixa Complementos disponíveis, desmarcar a caixa de seleção ao lado do complemento que você deseja remover e clique em OK.

    Observação    Isso remove o complemento da memória, mas mantém seu nome na lista de complementos disponíveis. Ele não exclui o complemento do computador.

  4. Para remover um complemento COM da lista de complementos disponíveis e excluir o complemento do seu computador, clique em seu nome na caixa Adicionares disponíveis e clique em Remover.

Observação: Se você for um desenvolvedor de software, poderá usar este procedimento para instalar ou remover um programa de automação antes de projetar programas de instalação e remoção para o seu complemento. Se você não for um desenvolvedor, não precisará usar este procedimento. Entre em contato com o administrador do sistema que forneceu o complemento se quiser instruções de instalação e remoção.

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

    A caixa de diálogo Add-Ins é exibida.

  3. Para instalar um complemento de automação, na caixa Servidores de Automação disponíveis, clique em Automação eclique no complemento que você deseja.

    Dica    Se o complemento que você deseja não estiver na lista, clique em Procurar,localize o complemento e clique em OK.

  4. Para remover um complemento de automação, você deve removê-lo do Registro. Consulte o administrador do sistema para obter detalhes.

Alguns complementos são integrados Excel, como Solver e Analysis ToolPak. Outros complementos estão disponíveis no Centro de Download e devem primeiro ser baixados e instalados. Por fim, há complementos criados por terceiros, como um programador em sua organização ou um provedor de soluções de software. Eles podem ser os complementos do Modelo de Objeto de Componente (COM), os Visual Basic for Applications (VBA) e os complementos DLL. Esses complementos também devem ser instalados para usá-los.

A maioria dos complementos pode ser categorizada em três tipos diferentes:

  • Excel de complementos    Geralmente, eles incluem Excel de um add-in (.xlam), Excel 97-2003 add-in (.xla) ou arquivos de complemento DLL (.xll) ou são complementos de automação. Alguns Excel, como o Solver e o Analysis ToolPak, podem estar disponíveis após a instalação Excel ou Microsoft Office. Normalmente, você só precisa ativar esses complementos para usá-los.

  • Complementos baixáveis    Os complementos adicionais para Excel podem ser baixados e instalados em Downloads em Office.com.

  • Complementos personalizados    Desenvolvedores e provedores de soluções geralmente projetam complementos COM (Modelo de Objeto de Componente) personalizados, complementos de automação, complementos VBA e complementos XLL. Eles devem ser instalados para você usá-los.

Depois de ter instalado ou ativado um complemento, o complemento e seus comandos podem estar disponíveis em um dos seguintes locais:

  • Guia Dados. Depois de instalar e ativar os complementos Analysis ToolPak e Solver, os comandos Análise de Dados e Solver estarão disponíveis na guia Dados da faixa de opções.

  • Guia Home. Outros complementos podem ser adicionados à guia Home.

Outros Introdução, como a guia Introdução, estão disponíveis em outros locais no Excel, como uma guia na faixa de opções ou por meio de macros ou menus personalizados.

Importante: Se você for um desenvolvedor de software, poderá usar este procedimento para instalar ou remover um programa de automação antes de projetar programas de instalação e remoção para o seu complemento.

Para ativar um Excel add-in pré-instalado    

  1. No menu Ferramentas, selecione Complementos.

  2. Na caixa Adicionar Ins disponíveis, marque a caixa de seleção para o Complemento que você deseja ativar e clique em OK.

Para instalar um Excel de dados    

  • Alguns Excel estão localizados em seu computador e podem ser instalados ou ativados clicando em Procurar (na caixa de diálogo Add-Ins acima) para localizar o complemento e clicar em OK.

  • Alguns Excel de instalação exigem a execução de um pacote de instalação. Talvez seja necessário baixar ou copiar o pacote de instalação para o computador (um pacote de instalação normalmente é um arquivo com uma extensão .msi nome de arquivo) e, em seguida, execute-o.

  • Outros complementos que não estão disponíveis em seu computador podem ser baixados e instalados por meio de um navegador da Web a partir de Downloads ou de outros sites na Internet, um servidor em sua organização ou usando a opção Loja interna no Excel. Siga as instruções de instalação para o download, conforme necessário.

    Para instalar Os Complementos da Loja

    1. Clique na guia Inserir na faixa de opções.

    2. Clique no botão Loja.

    3. Use o campo Categoriasou Pesquisa para encontrar Os Complementos.

    4. Clique em Adicionar para instalar o Add-in.

      Observação: Alguns Complementos precisam ser comprados.

Para remover um Excel de dados    

  1. Clique na guia Inserir e clique em Meus Complementos.

  2. Em Office,clique no menu 3 pontos ao lado do Add-in.

  3. Clique em Remover.

  4. Leia o aviso que aparece em relação a outros dispositivos e clique em Remover.

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×