Como corrigir erros de fórmula no Excel para Mac

Seja #VALOR!, #NOME! ou um problema com a função PROCV, as informações a seguir podem ajudá-lo a corrigir o erro.

PROCV

Se você está recebendo erros ou resultados inesperados com a função PROCV, baixe as dicas de referência rápida de solução de problemas da função PROCV.

#VALOR! erro

A origem desse problema geralmente está relacionada à combinação de valores numéricos e valores de texto. Para obter mais informações, consulte corrigir um erro de #VALUE!.

#NOME? erro

Certifique-se de digitar os nomes corretamente, coloque qualquer texto entre aspas ou coloque os nomes das planilhas entre aspas simples ('). Para saber mais sobre outras causas e soluções, consulte #NAME? erro.

#NÚM! erro

Isso pode acontecer se você digitou caracteres extras em uma fórmula. Por exemplo, não digite $1000 em uma fórmula. Em vez disso, digite 1000. Para outras causas e soluções, confira corrigir um erro de #NUM!.

Erro #N/D

Se a fórmula não puder encontrar um valor de referência, retornará o erro #N/D. Para saber mais, consulte Corrigir um erro #N/D.

#REF! erro

O Excel mostra esse erro quando uma fórmula contém uma referência de célula que não é válida. Para obter mais informações, consulte corrigir um erro de #REF!.

#DIV/0! erro

Isso acontece quando um número é dividido por zero (0) ou quando uma fórmula faz referência a uma célula que tem 0 ou está em branco. Para obter mais informações, consulte #DIV/0! erro.

Referenciar outras planilhas e pastas de trabalho

Se você estiver fazendo referência a outra planilha nome, digite ! após o nome e, em seguida, digite uma célula ou um intervalo. Se o nome da planilha contém espaços, coloque o nome entre aspas simples. Por exemplo: =SOMA('Relatório de vendas'!A1:A8).

Ao fazer referência a outra pasta de trabalho externa:

  • Coloque o nome da pasta de trabalho entre colchetes [ ].

  • Digite o caminho completo do arquivo.

  • Coloque o caminho entre aspas simples (no início do caminho e depois do nome da planilha, antes do ponto de exclamação).

    Exemplo: =SOMA('/Usuários/seunome/Área de trabalho/[Q2 Operações.xlsx]Vendas'!A1:A8)

Outras soluções rápidas que podem ajudar

  • Inicie cada fórmula com um sinal de igual (=). Exemplo: =SOMA(A1:A8)

  • Use o símbolo * para multiplicar números, não um X. Exemplo: =A1*A8

  • Abra e feche todos os parêntesis de modo que eles tenham seus pares correspondentes. Este exemplo possui 2 pares: =SE(40>50,SOMA(G2:G5),0)

  • Insira todos os argumentos obrigatórios. O Construtor de Fórmulas pode ajudar com isso. Comece digitando a fórmula com um nome de função e pressione CTRL+A para ver o Construtor de Fórmula.

  • Use aspas antes e depois do texto nas fórmulas. Exemplo: =SE(A2>B2,"Acima do orçamento","OK")

  • Altera o tipo de dados de uma célula referenciada. Pressione COMMAND +1 e, em seguida, selecione Número.

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×