Como corrigir o erro #VALOR! nas funções MÉDIA ou SOMA

Se média ou soma se referir a células que contêm #VALUE! erros, as fórmulas resultarão em uma #VALUE! #REF!.

Erro #VALOR! em MÉDIA

Para ignorar os valores de erro, construiremos uma fórmula que ignora os erros no intervalo de referência enquanto calcula a média com os valores restantes "normais".

Para contornar esse cenário, usamos uma combinação de MÉDIA junto com SE e ÉERROS para determinar se há um erro no intervalo especificado. Este cenário específico exige uma fórmula de matriz:

=MÉDIA(SE(ÉERROS(B2:D2),"", B2:D2))

Esta é uma fórmula de matriz. Portanto, você precisa pressionar Enter (apenas se estiver usando Microsoft 365 ) ou Ctrl + Shift + Enter na fórmula.

Observação: Se você tiver uma versão atual do Microsoft 365, poderá simplesmente inserir a fórmula na célula de saída e pressionar Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz herdada, selecionando primeiro a célula de saída, inserindo a fórmula na célula de saída e pressionando Ctrl + Shift + Enter para confirmá-la. O Excel insere chaves no início e no final da fórmula para você. Para obter mais informações sobre fórmulas de matriz, confira Diretrizes e exemplos de fórmulas de matriz.

Função de matriz em média para resolver o #VALUE! de #NAME?

Observação: A função acima não só funcionará para #VALOR!, como também para #N/D, #NULO, #DIV/0!, etc.

Também é possível utilizar a SOMA da mesma maneira:

=SOMA(SE(ÉERROS(B2:D2),"",B2:D2))

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Corrigir um erro #VALOR! de #NAME?

Função MÉDIA

Função SOMA

Visão geral de fórmulas no Excel

Detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×