Como corrigir um erro #VALOR! nas funções ÍNDICE/CORRESP

Este tópico explica os cenários comuns onde você encontra o erro #VALOR! ao usar as funções ÍNDICE e CORRESP juntas em uma fórmula. Um dos motivos mais comuns para usar a combinação de ÍNDICE e CORRESP é quando você quer pesquisar um valor em um cenário em que PROCV não funciona para você, como quando o valor de pesquisa é maior que 255 caracteres.

Problema: A fórmula não foi inserida como uma matriz

Se você estiver usando o índice como uma fórmula de matriz juntamente com a correspondência para poder recuperar um valor, será necessário converter a fórmula em uma fórmula de matriz, caso contrário, você verá um #VALUE! erro.

Solução: ÍNDICE e CORRESP devem ser usados como uma fórmula de matriz, o que significa que você precise pressionar CTRL+SHIFT+ENTER. Isso quebrará automaticamente a fórmula em chaves {}. Se você tentar inseri-las por conta própria, o Excel exibirá a fórmula como texto.

Se você estiver usando as funções ÍNDICE/CORRESP quando tiver um valor de pesquisa maior que 255 caracteres, elas precisam ser inseridas como uma fórmula de matriz.  A fórmula na célula F3 é =ÍNDICE(B2:B4,CORRESP(VERDADEIRO,A2:A4=F2,0),0) e é inserida pressionando Ctrl+Shift+Enter

Observação: Se você tiver uma versão atual do Microsoft 365, poderá simplesmente inserir a fórmula na célula de saída e pressionar Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz herdada, selecionando primeiro a célula de saída, inserindo a fórmula na célula de saída e pressionando Ctrl + Shift + Enter para confirmá-la. O Excel insere chaves no início e no final da fórmula para você. Para obter mais informações sobre fórmulas de matriz, confira Diretrizes e exemplos de fórmulas de matriz.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Corrigir um erro #VALOR! erro

Função ÍNDICE

Função CORRESP

Pesquisar valores com PROCV, índice ou CORRESP

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×