Criar um diagrama de comunicação UML

Você pode criar um diagrama de Comunicação da UML para mostrar as interações entre linhas de vida que usam mensagens sequenciadas em um acordo de forma livre. Primeiro, você abre o modelo de Comunicação da UML e escolhe uma das quatro opções de modelo. Em seguida, o estêncil de Comunicação da UML é exibido, juntamente com formas que estão em conformidade com o padrão UML 2.5.

Um exemplo de um diagrama de comunicação de UML.

Observação: O estêncil de Comunicação da UML só estará disponível se você for um Visio Plano 2 assinante. Se você tem uma assinatura, verifique se sua versão do Visio é a mais recente.

Iniciar um diagrama de comunicação

  1. Inicie o Visio. Ou se você já tiver um arquivo aberto, clique em Arquivo > Novo.

  2. Vá para Categorias > Software e Banco de Dados > Comunicação uml.

  3. Selecione o modelo em branco ou um dos três diagramas de início. Se você quiser representar a colaboração de linhas de vida mostrando interações entre linhas de vida, certifique-se de escolher o diagrama inicial no canto inferior esquerdo.

  4. Clique em Criar.

  5. Você deve ver a janela Formas ao lado do diagrama. Se você não vê-lo, vá para Exibir > Painéis de Tarefas e certifique-se de que Shapes está selecionado. Se você ainda não vir, clique no botão Expandir formas Botão Expandir Janela de Formas à esquerda.

  6. Na guia Exibir, verifique se a caixa de seleção ao lado de Pontos de Conexão está selecionada. Isso fará com que os pontos de conexão apareçam quando você começar a conectar formas.

  7. Agora, arraste formas que você deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

Iniciar um diagrama de comunicação

  1. Abra Visio para a Web.

  2. Próximo à parte superior direita, selecione Mais modelos.

  3. Na Galeria, role para baixo até a linha Comunicação da UML.

    O primeiro item na linha representa um modelo em branco mais o estêncil de parceiro. Os outros itens na linha são diagramas de exemplo que já têm algumas formas desenhadas para ajudá-lo a começar rapidamente.

  4. Clique em qualquer item para ver uma visualização maior.

  5. Quando você encontrar o diagrama que deseja usar, clique no botão Criar.

    O novo diagrama, com o estêncil relacionado, é aberto no navegador.

Formas de ator e linha de vida

Quando usar

  1. Arraste a forma Ator para a página para representar a função de um usuário ou de um sistema externo.

  2. Arraste a forma Lifeline para a página de cada elemento nomeado que representa um participante individual.

1: Forma de ator com texto "Alguém" 2: forma de linha de vida com texto ":Cupom"

Interações entre linhas de vida como mensagens

Etapa 1

Arraste uma forma de mensagem para a página e cole uma extremidade a um ponto de conexão em outra forma. Você sabe que ele é colado quando há um quadrado verde ao redor do ponto de conexão.

Forma da mensagem com uma extremidade realçada em verde e conectada à forma de linha de vida

Etapa 2

Faça o mesmo para a outra extremidade da mensagem para que ela também seja colada a um ponto de conexão. Você sabe que ele é colado quando há um destaque verde ao redor do ponto.

Forma da mensagem com fim realçado em verde e conectado a outra forma de linha de vida

Etapa 3

Se você quiser que a mensagem seja assíncrona, clique com o botão direito do mouse e escolha Assíncrona. Isso alterará a ponta de seta fechada para uma aberta.

Forma da mensagem, menu com o botão direito do mouse, comando assíncrono selecionado

Colaboração de linhas de vida mostrando interações entre linhas de vida

Visão geral

  1. Primeiro conecte as linhas de vida com a Ferramenta do Conector.

  2. Em seguida, use as formas Mensagem e Retornar Mensagem para mostrar interações entre linhas de vida.

1 apontando para a linha do conector cinza, 2 apontando para a linha de mensagem com texto, "4: Execute()"

Etapa 1

Na guia Página Principal, clique na Ferramenta do Conector (1). Passe o mouse sobre um dos pontos de conexão de uma forma de linha de vida até que você veja um destaque verde (2).

1 apontando para a ferramenta Connector, 2 apontando para o cursor pairando sobre o ponto de conexão realçado verde na forma da linha de vida

Etapa 2

Clique e arraste do destaque verde para um ponto de conexão em outra forma de linha de vida até que você veja um destaque como este.

Fim da linha do conector arrastada para outra forma de linha de vida, com realçaamento verde ao redor do ponto de conexão

Etapa 3

Clique na Ferramenta de Ponteiro quando terminar de conectar as formas de linha de vida.

"Clique aqui quando terminar" apontando para o comando Ferramenta de Ponteiro

Etapa 4

Arraste outra forma de mensagem para que ela seja paralela à outra linha.

Forma de mensagem de posicionamento do cursor no local ao lado da linha do conector

Dicas conectores

Corrigir conectores

Se um conector estiver fazendo muitas curvas, clique com o botão direito do mouse nele e clique em Conectar diretamenter.

Tipo de conector de alteração

Você pode alterar um tipo de conector. Por exemplo, você pode mudar de uma Associação para uma Associação Direcionada. Clique com o botão direito do mouse no conector e clique em Definir Tipo de Conector.

Fazer conexões dinâmicas em vez de conexões de ponto

Se você antecipar muito a movimentação de formas, considere fazer uma conexão dinâmica em vez de uma conexão de ponto.

Mover ou girar texto em conectores

O mais provável é que você precise girar ou mover o texto em suas linhas do conector. Veja como fazer isso:

  1. Clique em uma área vazia da página para desmarcar qualquer coisa que possa ser selecionada.

  2. Na guia Página Principal, no grupo Ferramentas, clique na ferramenta Bloco de Texto Botão Bloco de Texto

  3. Clique no conector que tem texto que você deseja girar ou mover.

  4. Arraste o bloco de texto para movê-lo ou gire-o usando a alça de rotação Alça de rotação

  5. Quando terminar, clique no botão Ferramenta de Ponteiro Botão Ponteiro

    Depois de alternar de volta para o botão Ferramenta de Ponteiro Botão Ponteiro , o texto mantém a mesma posição em relação à forma. Se você usar a Ferramenta de Ponteiro Botão Ponteiro arrastar o texto, a forma também será moveda. Para mover o texto independentemente da forma, volte para a Ferramenta de Bloqueio de Texto Botão Bloco de Texto .

Confira também

Diagramas UML no Visio

Criar um diagrama de componente UML

Criar um diagrama de implantação UML

Criar um diagrama de sequência UML

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

×