Use a função E, uma da funções lógicas, para determinar se todas as condições em um teste são VERDADEIRAS.

Exemplo

Exemplos de função E

A função E retornará VERDADEIRO se todos os seus argumentos forem avaliados como VERDADEIRO e retornará FALSO se um ou mais argumentos forem avaliados como FALSO.

Um uso comum para a função E é expandir a utilidade de outras funções que realizam testes lógicos. Por exemplo, a função SE realiza um teste lógico e, em seguida, retornará um valor se o teste for avaliado como VERDADEIRO e outro valor se o teste for avaliado como FALSO. Usando a função E como argumento teste_lógico da função SE, você pode testar várias condições diferentes em vez de apenas uma.

Sintaxe

E(lógico1, [lógico2], ...)

A sintaxe da função E tem os seguintes argumentos:

Argumento

Descrição

Lógico1

Obrigatório. A primeira condição que você deseja testar que pode ser avaliada como VERDADEIRO ou FALSO.

Lógico2; ...

Opcional. Condições adicionais que você deseja testar que podem ser avaliadas como VERDADEIRO ou FALSO, até um máximo de 255 condições.

Comentários

  • Os argumentos devem ser avaliados como valores lógicos, como VERDADEIRO ou FALSO, ou os argumentos devem ser matrizes ou referências que contêm valores lógicos.

  • Se um argumento de uma matriz ou referência contiver texto ou células vazias, esses valores serão ignorados.

  • Se o intervalo especificado não contiver valores lógicos, a função AND retornará o #VALUE! erro.

Exemplos

Aqui estão alguns exemplos gerais do uso de E por si só e em conjunto com a função SE.

Exemplos do uso das funções SE com E

Fórmula

Descrição

=E(A2>1,A2<100)

Exibirá VERDADEIRO se A2 for maior que 1 E menor que 100, caso contrário, exibirá FALSO.

=SE(E(A2<A3,A2<100),A2,"O valor está fora do intervalo")

Exibirá o valor na célula A2 se ele for menor que A3 E menor que 100. Caso contrário, exibirá a mensagem "O valor está fora do intervalo".

=SE(E(A3>1,A3<100),A3,"O valor está fora do intervalo")

Exibe o valor na célula A3 se for maior que 1 E menor que 100, caso contrário, exibirá uma mensagem. Você pode substituir qualquer mensagem de sua escolha.

Cálculo de Bônus

Aqui está um cenário bastante comum em que precisaremos calcular se vendedores se qualificam para uma comissão usando SE e E.

Exemplo de cálculo de Bônus de Vendas com funções IF e AND.  Fórmula na célula E14 é =IF(AND(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =SE(E(B14>=$B$7,C14>=$B$5),B14*$B$8,0)SE Total de Vendas for maior ou igual a (>=) a Meta de Vendas E Contas forem maiores ou iguais a (>=) a Meta de Contas, multiplicar Vendas Totais por % de Bônus, caso contrário, retornar 0.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community ou obter suporte na Comunidade de respostas.

Tópicos Relacionados

Vídeo: Funções AVANÇADAS
IF Saiba como usar funções aninhadas em uma fórmula
Função IF
Função OR
Função NOT
Visão geral das fórmulas Excel
Como evitar fórmulas quebradas
Detectar erros em fórmulas
Atalhos de teclado em Excel
Funções lógicas (referência)
Excel funções (alfabéticas)
Excel funções (por categoria)

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?

O que afetou sua experiência?

Algum comentário adicional? (Opcional)

Obrigado por seus comentários!

×