Access fornece uma série de ferramentas que ajudam você a criar relatórios atraentes e fáceis de ler que apresentam os dados de uma maneira que melhor se adapte às necessidades de seus usuários. Você pode usar os comandos na guia Criar para criar um relatório simples com um único clique. Você pode usar o Assistente de Relatório para criar um relatório mais complicado ou criar um relatório adicionando todos os dados e elementos de formatação por conta própria. Seja qual for o método escolhido, você provavelmente fará pelo menos algumas alterações no design do relatório para fazê-lo exibir os dados da maneira que você deseja. Este artigo discute o processo geral de criação de um relatório e mostra como adicionar elementos de design específicos ao seu relatório.

Neste artigo

Decidir como definir seu relatório

Ao projetar um relatório, você deve primeiro considerar como deseja que os dados organizados na página e como os dados são armazenados no banco de dados. Durante o processo de design, você pode até descobrir que a organização dos dados nas tabelas não permitirá que você crie o relatório que deseja. Isso pode ser uma indicação de que as tabelas não são normalizadas — isso significa que os dados não são armazenados da maneira mais eficiente.

Fazer um esboço do seu relatório

Esta etapa não é necessária — você pode descobrir que o Assistente de Relatório do Access ou a ferramenta Relatório (ambos disponíveis na guia Criar, no grupo Relatórios) fornecem um design inicial suficiente para seu relatório. No entanto, se você decidir projetar seu relatório sem usar essas ferramentas, talvez seja útil fazer um rascunho aproximado do relatório em um pedaço de papel desenhando uma caixa onde cada campo vai e escrevendo o nome do campo em cada caixa. Como alternativa, você pode usar programas como o Word ou o Visio para criar uma simulação do relatório. Qualquer método usado, certifique-se de incluir linhas suficientes para indicar como os dados se repetem.

Formulário concluído sobrepondo esboço preliminar

Por exemplo, você pode usar uma linha para informações do produto, depois várias linhas repetidas para as vendas desse produto e, finalmente, uma linha de totais de vendas para o produto. Em seguida, a sequência se repete para o próximo produto e assim por diante até o final do relatório. Ou, talvez seu relatório seja uma listagem simples dos dados na tabela, nesse caso, seu esboço pode conter apenas uma série de linhas e colunas.

Observação: Essa técnica também será muito útil se você estiver projetando um relatório para outra pessoa. Nesse caso, a outra pessoa pode desenhar o esboço antes de começar a trabalhar.

Depois de criar seu esboço, determine quais tabelas ou tabelas contêm os dados que você deseja exibir no relatório. Se todos os dados estão contidos em uma única tabela, você pode basear seu relatório diretamente nessa tabela. Mais frequentemente, os dados que você deseja são armazenados em várias tabelas que você deve reunir em uma consulta, antes de poder exibi-los no relatório. A consulta pode ser inserida na propriedade RecordSource do relatório ou você pode criar uma consulta separada e salva e basear o relatório nisso.

Decidir quais dados colocar em cada seção de relatório

Cada relatório tem uma ou mais seções de relatório. A única seção presente em cada relatório é a seção Detalhes. Esta seção se repete uma vez para cada registro na tabela ou consulta em que o relatório se baseia. Outras seções são opcionais e se repetem com menos frequência e geralmente são usadas para exibir informações comuns a um grupo de registros, uma página do relatório ou todo o relatório.

A tabela a seguir descreve onde cada seção está localizada e como a seção é normalmente usada.

Seção

Local

Conteúdo típico

Seção Report header

Aparece apenas uma vez, na parte superior da primeira página do relatório.

  • Título do relatório

  • Logotipo

  • Data atual

Seção Rodapé de relatório

Aparece após a última linha de dados, acima da seção Rodapé da Página na última página do relatório.

Totais de relatório (somas, contagens, médias e assim por diante)

Seção de header de página

Aparece na parte superior de cada página do relatório.

  • Título do relatório

  • Número de página

Seção Rodapé de página

Aparece na parte inferior de cada página do relatório.

  • Data atual

  • Número de página

Seção de header de grupo

Aparece apenas antes de um grupo de registros.

O campo que está sendo agrupado em

Seção Rodapé de grupo

Aparece logo após um grupo de registros.

Totais de grupo (somas, contagens, médias e assim por diante)

Para obter informações sobre como adicionar ou remover seções de header e rodapé de relatório ou seções de rodapé e de rodapé de página, consulte a seção Adicionar ou remover relatório ou página de header e seções de rodapé neste artigo. Você pode adicionar seções de rodapé e de header de grupo usando o painel Grupo, Classificação e Total no layout ou exibição Design.

Decidir como organizar os dados detalhados

A maioria dos relatórios é organizada em um layout tabular ou empilhado, mas Access oferece a flexibilidade de usar qualquer disposição de registros e campos que você deseja.

Layout tabular    Um layout tabular é semelhante a uma planilha. Os rótulos estão na parte superior e os dados são alinhados em colunas abaixo dos rótulos. Tabular refere-se à aparência de tabela dos dados. Esse é o tipo de relatório que Access cria quando você clica em Relatório no grupo Relatórios da guia Criar. O layout tabular é um bom uso se seu relatório tiver um número relativamente pequeno de campos que você deseja exibir em um formato de lista simples. A ilustração a seguir mostra um relatório de funcionário que foi criado usando um layout tabular.

O relatório Funcionários em layout tabular

Layout empilhado    Um layout empilhado se parece com um formulário que você preenche ao abrir uma conta bancária ou fazer uma compra de um varejista online. Cada parte dos dados é rotulada e os campos são empilhados uns sobre os outros. Esse layout é bom para relatórios que contêm muitos campos para exibição em um formato tabular — ou seja, a largura das colunas excederia a largura do relatório. A ilustração a seguir mostra um relatório de funcionários que foi criado usando um layout empilhado.

O relatório Funcionários em layout empilhado

Observação: No Assistente de Relatório, esse layout é conhecido como layout colunar.

Layout misto    Você pode misturar elementos de layouts tabulados e empilhados. Por exemplo, para cada registro, você pode organizar alguns dos campos em uma linha horizontal na parte superior da seção Detalhes e organizar outros campos do mesmo registro em um ou mais layouts empilhados abaixo da linha superior. A ilustração a seguir mostra um relatório de funcionário que foi criado usando um layout misto. Os campos ID, Sobrenome e Nome são organizados em um layout de controle tabular e os campos Título de Trabalho e Telefone Comercial são organizados em um layout empilhado. Neste exemplo, as linhas de grade são usadas para fornecer uma separação visual de campos para cada funcionário.

Relatório Funcionários com layout misto

Layout justificado    Se você usar o Assistente de Relatório para criar seu relatório, poderá optar por usar um layout justificado. Esse layout usa a largura total da página para exibir os registros da forma mais compacta possível. É claro que você pode obter os mesmos resultados sem usar o Assistente de Relatório, mas pode ser um processo muito lento para alinhar os campos exatamente. A ilustração a seguir mostra um relatório de funcionários que foi criado usando o layout justificado do Assistente de Relatório.

Relatório Funcionários com layout justificado

O layout justificado é um bom layout a ser usado se você estiver exibindo um grande número de campos no relatório. No exemplo anterior, se você usar um layout tabular para exibir os mesmos dados, os campos se estenderão para fora da borda da página. Se você usar um layout empilhado, cada registro ocupa muito mais espaço vertical, o que desperdiça papel e torna o relatório mais difícil de ler.

Início da página

Usar layouts de controle para alinhar seus dados

Layouts de controle são guias que você pode adicionar a um relatório enquanto ele está aberto no layout ou no visual Design. Access adiciona layouts de controle automaticamente quando você usa o Assistente de Relatório para criar um relatório ou quando você cria um relatório clicando em Relatório no grupo Relatórios da guia Criar. Um layout de controle é como uma tabela, cada célula da qual pode conter um rótulo, uma caixa de texto ou qualquer outro tipo de controle. A ilustração a seguir mostra um layout de controle tabular em um relatório.

Layout básico de controle tabular

As linhas laranjas indicam as linhas e colunas do layout do controle, e elas ficam visíveis somente quando o relatório é aberto no layout ou no visual Design. Os layouts de controle ajudam você a obter um alinhamento uniforme de dados em linhas e colunas e facilitam a adoção, ressar e remoção de campos. Usando as ferramentas nos grupos Tabela e Posição na guia Organizar (disponível no modo layout ou no modo design), você pode alterar um tipo de layout de controle para outro e remover controles de layouts para poder posicionar os controles onde quiser no relatório.

Início da página

Adicionar ou remover seções de rodapé e de relatório ou página

Conforme mencionado anteriormente neste artigo, os headers e rodapés são seções de relatório que você pode usar para exibir informações comuns ao relatório inteiro ou para cada página de um relatório. Por exemplo, você pode adicionar uma seção Rodapé de Página para exibir um número de página na parte inferior de cada página ou pode adicionar uma seção Report Header para exibir um título para todo o relatório.

Adicionar seções de rodapé e de relatório ou de página

  1. No Painel de Navegação, clique com o botão direito do mouse no relatório que você deseja alterar e clique em Design View no menu de atalho.

  2. Verifique quais seções já estão no relatório. As seções são separadas por barras horizontais sombreadas chamadas seletores de seção. O rótulo em cada seletor de seção indica qual é a seção diretamente abaixo dela.

    Relatório no modo Design

    Cada relatório tem uma seção Detalhe e também pode conter seções Report Header, Page Header, Page Footer e Report Footer. Além disso, se houver níveis de agrupação no relatório, você poderá ver os headers de grupo ou rodapés (como o Arquivo como o Header mostrado na ilustração anterior). Por padrão, os headers de grupo e rodapés são nomeados usando o nome do campo ou a expressão que é a base do grupo. Nesse caso, o nome do campo de agrupação é "Arquivo Como".

  3. Para adicionar seções de header e rodapé de página ou seções de header de relatório e rodapé ao seu relatório, clique com o botão direito do mouse em qualquer seletor de seção e clique em Header/Rodapé de Página ou Report Header/Footer no menu de atalho.

    Cuidado: Se a seção já estiver presente no relatório, o Access avisará que excluirá a seção existente e os controles que ele contém.

    Agora você pode mover controles existentes ou adicionar novos controles às novas seções.

Access sempre adiciona seções de rodapé e de header de página e relatório em pares. Ou seja, você não pode adicionar uma seção de header de página ou relatório sem também adicionar a seção rodapé correspondente. Se você não precisar de ambas as seções, não poderá excluir uma seção, mas poderá reaproveitar a seção nãoutilada a uma altura zero (0) para evitar adicionar espaçamento vertical extra ao relatório. Posicione o ponteiro na parte inferior da seção nãousada até que ele se transforma em uma seta de duas texto alternativoe arraste para cima até que a seção seja oculta. Se houver controles na seção, exclua-os antes de poder ocultar totalmente a seção.

Remover seções de header e rodapé de relatório ou página

  1. No Painel de Navegação, clique com o botão direito do mouse no relatório que você deseja alterar e clique em Design View no menu de atalho.

  2. Clique com o botão direito do mouse em qualquer seletor de seção e clique em Header/Rodapé de Página ou Report Header/Footer no menu de atalho.

Se você estiver removendo um par de rodapé e de header e essas seções contêm controles, Access avisa que a exclusão das seções também excluirá os controles e que você não poderá desfazer a ação. Clique em Sim para remover as seções e excluir os controles ou clique em Não para cancelar a operação.

Início da página

Dicas para formatar diferentes tipos de dados

Quando você cria um relatório usando a ferramenta Relatório (disponível na guia Criar, no grupo Relatórios) ou usando o Assistente de Relatório, o Access adiciona os campos ao relatório para você e cria o controle mais apropriado para exibir cada campo, com base no tipo de dados do campo. Se você estiver adicionando campos a um relatório por conta própria, o método preferencial é arrastar cada campo da Lista de Campos para o relatório. Assim como com o Assistente de Relatório ou a ferramenta Relatório,Access cria o controle mais apropriado para cada campo, dependendo do tipo de dados do campo. Para a maioria dos tipos de dados, o controle mais apropriado (padrão) a ser usado é a caixa de texto.

As seções a seguir fornecem dicas sobre como formatar alguns dos tipos de dados de caso especial.

Campos de valores múltiplos    O controle padrão para um campo com valores múltiplos é uma caixa de combinação. Isso pode parecer uma escolha estranha para um controle em um relatório, porque você não pode clicar na seta em uma caixa de combinação em um relatório. No entanto, no contexto de um relatório, uma caixa de combinação se comporta como uma caixa de texto. A seta só fica visível no visualização Design.

Se o campo contiver vários valores, esses valores serão separados por vírgulas. Se a caixa de combinação não for larga o suficiente para exibir todos os valores em uma linha e a propriedade CanGrow da caixa de combinação for definida como Sim, os valores quebram para a próxima linha. Caso contrário, os valores serão truncados. Para definir a propriedade CanGrow para um controle, abra o relatório no design ou no layout, clique no controle e pressione F4 para exibir a folha de propriedades do controle. A propriedade CanGrow está localizada na guia Formatar e na guia Todos da folha de propriedades do controle.

Campos de texto rich    O controle padrão para um campo de texto rico é uma caixa de texto. Se a caixa de texto não tiver largura suficiente para exibir todos os valores em uma linha e a propriedade CanGrow da caixa de texto estiver definida como Sim, os valores serão wrap para a próxima linha. Caso contrário, os valores serão truncados. Para definir a propriedade CanGrow para um controle, abra o relatório no design ou no layout, clique no controle e pressione F4 para exibir a folha de propriedades do controle. A propriedade CanGrow está localizada na guia Formatar e na guia Todos da folha de propriedades do controle.

Um campo de texto rico ajuda você a formatar texto de várias maneiras. Por exemplo, várias palavras em um campo podem ser sublinhadas, e várias outras palavras no mesmo campo podem estar em itálico. No entanto, você ainda pode definir um estilo de formatação geral para a caixa de texto que contém o rich text. A formatação da caixa de texto só se aplica ao texto que não foi especificamente formatado usando a formatação rich text.

Definir estilos de formatação para uma caixa de texto que exibe um campo de texto rico

  1. Clique com o botão direito do mouse no relatório no Painel de Navegação e clique em Modo de Exibição de Layout no menu de atalho.

  2. Clique na caixa de texto que exibe o campo rich text e, na guia Formatar, no grupo Fonte, clique no estilo de formatação que você deseja aplicar.

    Access aplica a formatação a todo o texto no campo rich text que ainda não teve esse tipo (mas não o valor) de formatação aplicado em uma exibição que dá suporte à entrada de dados, como o exibição Folha de Dados para uma tabela ou consulta, ou o formulário para um formulário. Por exemplo, se uma parte do texto no campo for formatada com uma cor de fonte vermelha e você aplicar uma cor de fonte azul à caixa de texto, Access todo o texto azul, exceto aquele que foi formatado individualmente como vermelho. Como outro exemplo, se uma parte do texto no campo for formatada com um tamanho de fonte de 11 pontos e você aplicar um tamanho de fonte de 14 pontos à caixa de texto, Access aplicará o tamanho da fonte de 14 pontos a todo o texto, exceto aquele que foi formatado individualmente em 11 pontos.

    Campos de anexo    Os campos de anexo usam um controle especial que não é usado para qualquer outro tipo de dados. Você pode anexar vários arquivos a um registro usando um único campo Anexo, mas o campo só pode exibir informações sobre um anexo por vez. Por padrão, o controle de anexo exibe um ícone ou uma imagem, dependendo do tipo de arquivo do anexo exibido no momento pelo controle. Se quiser, você pode definir as propriedades do controle de anexo para que todos os arquivos anexados sejam exibidos como ícones ou para que o campo simplesmente exibe um ícone de clipe de papel e o número de anexos. Supondo que você já use um controle de anexo em seu relatório, você pode usar o procedimento a seguir para ajustar as propriedades do controle para diferentes usos do controle.

Definir as propriedades de exibição para um campo Attachment

  1. Clique com o botão direito do mouse no relatório no Painel de Navegação e clique em Modo de Exibição de Layout no menu de atalho.

  2. Clique no controle de anexo. Se a Folha de Propriedades não for exibida, pressione F4 para exibi-la. Na folha de propriedades, clique na guia Formatar.

    Use a tabela a seguir como um guia para definir as propriedades do controle de anexo.

    Propriedade

    Configuração

    Exibir como

    • Imagem/Ícone exibe elementos gráficos como imagens e todos os outros arquivos como ícones. Essa é a configuração padrão.

    • O ícone exibe todos os arquivos como ícones.

    • Paperclip exibe um ícone de clipe de papel seguido pelo número de anexos entre parênteses.

    Imagem padrão

    Para fazer uma imagem padrão aparecer no controle de anexo quando não houver arquivos anexados, clique em Botão Construtor na caixa de propriedades, navegue até a imagem que você deseja e clique em Abrir.

    Observação: A imagem padrão não será exibida se a propriedade Display As estiver definida como Paperclip.

    Alinhamento da imagem

    Selecione o alinhamento que você deseja na lista. A configuração padrão é Center. Ajustar essa configuração pode produzir resultados inesperados, dependendo da configuração da propriedade Modo de Tamanho da Imagem.

    Modo tamanho da imagem

    Essa configuração só estará disponível se a propriedade Display As estiver definida como Image/Icon.

    • O clipe exibe a imagem em seu tamanho real. A imagem é cortada se for muito grande para caber dentro do controle.

    • Alonga a imagem para que ela preencha todo o controle.

      Observação: A menos que o controle de anexo tenha o mesmo tamanho exato da imagem, o uso dessa configuração distorce a imagem, fazendo com que ela apareça estendida verticalmente ou horizontalmente.

    • O zoom exibe a imagem o mais grande possível sem cortar ou distorcer a imagem. Essa é a configuração padrão.

  3. Se você estiver usando o controle para exibir elementos gráficos, ajuste o tamanho do controle de anexo para que você possa ver a quantidade de detalhes que deseja.

Início da página

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?

O que afetou sua experiência?

Algum comentário adicional? (Opcional)

Obrigado por seus comentários!

×