PROCX (Função PROCX)

Use a função PROCX quando precisar localizar coisas em linhas de uma tabela ou de um intervalo. Por exemplo, procure o preço de uma peça automotiva pelo número da peça ou encontre um nome de funcionário com base na ID do funcionário. Com o PROCX, você pode procurar em uma coluna por um termo de pesquisa e retornar um resultado da mesma linha em outra coluna, independentemente de qual lado a coluna de retorno esteja.

Cause grande impacto com Comunicados

Observação: Esta função está disponível no momento para Microsoft 365 assinantes no canal atual. Ele estará disponível para os assinantes do Microsoft 365 em canal corporativo semestral a partir de julho de 2020. Para saber mais sobre como os recursos são distribuídos para os assinantes do Microsoft 365, confira quando obter os recursos mais recentes do Microsoft 365.

A função PROCX pesquisa um intervalo ou uma matriz e retorna um item correspondente à primeira correspondência encontrada. Se não houver uma correspondência, então o PROCX poderá retornar a correspondência mais adequada(aproximada). 

=PROCX(pesquisa_valor; pesquisa_matriz; matriz_retorno; [se_não_encontrada]; [modo_correspondência]; [modo_pesquisa]) 

Argumento

Descrição

pesquisa_valor

Obrigatório

O valor de pesquisa

pesquisa_matriz

Obrigatório

A matriz ou intervalo a classificar

matriz_retorno

Obrigatório

A matriz ou intervalo a retornar

[se_não_encontrada]

Opcional

Quando uma coincidência válida não é encontrada, retorna o texto [if_not_found] que você fornece.

Caso não seja encontrada uma coincidência válida e [if_not_found], #N/A será retornado.

[modo_correspondência]

Opcional

Especificar o tipo de correspondência:

0 – Correspondência exata. Se nenhum for encontrado, retornar #N/A. Esse é o padrão.

-1 – Correspondência exata. Se nenhum for encontrado, retorna o próximo item menor.

1 – Correspondência exata. Se nenhum for encontrado, retorna o próximo item maior.

2 – Uma correspondência de curingas, em que *,? e ~ têm um significado especial.

[modo_pesquisa]

Opcional

Especificar o modo de pesquisa a ser usado:

1 – Executar uma pesquisa começando do primeiro item. Esse é o padrão.

-1 – Executar uma pesquisa reversa começando do último item.

2 – Executar uma pesquisa binária que dependa da classificação da matriz_procurada em ordem crescente. Caso contrário, resultados inválidos serão retornados.

-2 – Executar uma pesquisa binária que dependa da classificação da matriz_procurada em ordem decrescente. Caso contrário, resultados inválidos serão retornados.

Exemplos

Exemplo 1

Este exemplo é do vídeo acima e usa uma PROCX simples para procurar um nome de país e retornar seu código de país/região. Ele inclui apenas os argumentos valor_procurado (célula F2), matriz_procurada (intervalo B2: B11) e return_array (intervalo D2: D11). Ele não inclui o argumento match_mode, como PROCX, pois ele assume uma correspondência exata.

Exemplo da função PROCX usada para retornar o Nome e o Departamento de um Funcionário com base na ID do Funcionário. A fórmula é =PROCX(B2;B5:B14;C5:C14).

Observação: O PROCX é diferente do PROCV por usar matrizes de pesquisa e retorno separadas, já o PROCV usa uma matriz de tabela única seguida por um número de índice de coluna. A fórmula PROCV equivalente nesse caso seria: =PROCV(F2;B2:D11;3;FALSO)

Exemplo 2

Neste exemplo, estamos pesquisando informações de funcionário com base em um número de identificação de funcionário. Ao contrário do PROCV, o PROCX pode retornar uma matriz com vários itens, o que permite que uma única fórmula retorne o nome do funcionário e o departamento das células C5:D14.

Exemplo da função PROCX usada para retornar um nome e departamento de um funcionário com base na IDt do funcionário. A fórmula é =PROCX(B2;B5:B14;C5:D14;0;1)

Exemplo 3

Este exemplo adiciona a if_not_found argumento ao exemplo acima.

Exemplo da função PROCX usada para retornar um nome e departamento de um funcionário com base na ID do funcionário com o argumento if_not_found. A fórmula é =PROCX(B2;B5:B14;C5:D14;0;1;"Funcionário não encontrado")

Exemplo 4

O exemplo a seguir procura a receita pessoal inserida na célula E2 e localiza uma taxa de imposto correspondente na coluna B. Ele define o argumento if-not_found para retornar um 0 se nada for encontrado. O argumento match_mode é definido como 1, o que significa que a função procurará uma correspondência exata e se não conseguir encontrar, retornará o próximo item maior. Por fim, o argumento search_mode é definido como 1, o que significa que a função pesquisará do primeiro item para o último.

Imagem da função PROCX usada para retornar uma taxa de imposto com base na renda máxima. Esta é uma correspondência aproximada. A fórmula é: =PROCX(E2;C2:C7;B2:B7;1;1)

Observação: Diferentemente do PROCV, a coluna matriz_procurada fica à direita da coluna return_array, onde o PROCV só consegue pesquisar da esquerda para a direita.

Exemplo 5

Em seguida, usaremos uma função PROCX aninhada para executar uma correspondência vertical e horizontal. Nesse caso, ele primeiro procurará pelo Lucro Bruto na coluna B, depois procurará pelo Qtr1 na linha superior da tabela (intervalo C5:F5) e retornará o valor na interseção dos dois. Isso é semelhante ao uso das funções ÍNDICEe CORRESP em conjunto. Você também pode usar PROCX para substituir a função PROCH.

Imagem da função PROCX usada para retornar dados horizontais de uma tabela aninhando 2 PROCXs. A fórmula é: =PROCX(D2;$B6:$B17;PROCX($C3;$C5:$G5;$C6:$G17))

A fórmula nas células D3:F3 é: =PROCX(D2;$B6:$B17;PROCX($C3;$C5:$G5;$C6:$G17)).

Exemplo 6

Este exemplo usa a função SOMA e duas funções PROCX aninhadas para somar todos os valores entre dois intervalos. Nesse caso, iremos somar os valores para uvas, bananas e incluir pêras, que estão entre os dois.

Usando PROCX com SOMA para totalizar um intervalo de valores que estão entre duas seleções

A fórmula na célula E3 é: =SOMA(PROCX(B3;B6:B10;E6:E10):PROCX(C3;B6:B10;E6:E10))

Como funciona? O PROCX retorna um intervalo; portanto, ao calcular, a fórmula fica da seguinte forma: =SOMA($E$7:$E$9). Confira como ele funciona sozinho, selecionando uma célula com uma fórmula PROCX semelhante a esta, em seguida, vá paraFórmulas > Auditoria de Fórmulas > Avaliar Fórmula e então, pressione o botão Avaliar para acessar o cálculo.

Observação: Graças ao MVP do Microsoft Excel, Bill Jelen, para sugerir este exemplo.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Função CORRESPX

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×