Trabalhar offline com tabelas que estão vinculadas a listas do SharePoint

Você pode usar o Access para trabalhar offline com dados vinculados a listas do SharePoint. Isso pode ser útil, por exemplo, se você precisar ficar longe do escritório ou precisar continuar trabalhando quando um servidor não estiver disponível ou se você tiver perdido conexões com o servidor.

Visão geral

Antes de trabalhar offline com dados de um site do SharePoint, primeiro você deve criar links entre as tabelas do Access e as listas do SharePoint. Em seguida, você pode fazer as listas offline para atualizá-las ou analisá-las usando o Access. Ao reconectar, você pode sincronizar os dados para que o banco de dados e as listas sejam atualizados. Se o banco de dados tiver consultas e relatórios, você poderá usá-los para analisar os dados vinculados.

Se você atualizar quaisquer dados enquanto estiver offline, poderá sincronizar suas alterações quando o Access se conectar ao servidor novamente. Se ocorrerem conflitos de dados — por exemplo, se alguém atualizar um registro no servidor enquanto uma pessoa diferente atualiza o mesmo registro offline — você pode resolver o conflito ao sincronizar.

Você pode vincular tabelas do Access a listas usando vários métodos. Por exemplo, você pode mover seu banco de dados para um site do SharePoint, que também vincula as tabelas no banco de dados às listas no site. Ou você pode exportar dados de uma lista no exibição de folha de dados em um site do SharePoint para uma tabela do Access. Por exemplo, você pode usar um relatório no Access para resumir os dados. Para obter mais informações sobre como vincular aos dados do SharePoint a partir do Access, consulte Import or link to data in a SharePoint list.

Trabalhar offline com listas do SharePoint no Access

A partir do Access 2010, trabalhar offline com listas vinculadas do SharePoint é mais um processo automático mantido pelo Access. Se o Access não puder se conectar ao site do SharePoint onde residem suas listas vinculadas do SharePoint, talvez porque você tenha perdido a conectividade com a Internet, o Access alterna para o modo offline. Na Barra de Status, no lado inferior direito da janela do Access, você verá uma mensagem dizendo que todas as tabelas do SharePoint estão desconectadas. Se você clicar em Arquivo > Informações, você também verá uma mensagem semelhante indicando que você desconectou tabelas. Quando estiver no modo offline, você pode continuar a adicionar, editar e excluir dados em uma cópia local armazenada em cache dos dados da Lista do SharePoint.

O Access continua tentando se reconectar em intervalos regulares com as listas vinculadas no servidor do SharePoint. Depois que o Access restabelecer uma conexão com o site do SharePoint, você verá uma barra de mensagens abaixo da faixa de opções perguntando se deseja sincronizar seus dados offline com o servidor.

Clique em Sincronizar para reconectar ao SharePoint Server.

Clique em Sincronizar e o Access se reconecta às listas vinculadas do SharePoint e tenta mesclar quaisquer alterações de dados.

Resolução de alterações conflitantes de dados

Um conflito ocorre quando dois usuários fazem uma alteração na mesma parte dos dados ou estrutura de uma lista. O usuário que enviar uma alteração primeiro terá êxito ao cometer suas alterações, mas o segundo usuário será notificado de um conflito.

Por exemplo, o usuário A altera a coluna Cidade da terceira linha de Dallas para Seattle e, ao mesmo tempo, você altera a célula de Dallas para Houston. As alterações do usuário A são enviadas primeiro ao servidor, seguidas de suas alterações. O servidor informa sobre um conflito e permite que você resolva o conflito.

Observação: Um conflito ocorrerá mesmo quando os usuários editarem células diferentes na mesma linha.

Você não poderá fazer alterações em um registro que tenha um conflito até resolver o conflito.

Se o Access detectar qualquer conflito de dados ao sincronizar as alterações offline com o servidor do SharePoint, você verá a caixa de diálogo Resolver Conflitos.

Use as opções disponíveis na caixa de diálogo Resolver Conflitos para resolver conflitos de dados.

Siga um destes procedimentos:

  • Para resolver o conflito ou o erro exibido no momento ignorando as alterações feitas no registro, clique em Descartar Minhas Alterações. Suas alterações serão perdidas.

  • Para resolver todos os conflitos e erros pendentes ignorando todas as suas alterações na lista, clique em Descartar Todas as Minhas Alterações.

  • Para resolver o conflito ou o erro exibido no momento, reaplicação de suas alterações, clique em Repetir Minhas Alterações. Em caso de conflito, se você e o outro usuário alterarem a mesma coluna, suas alterações substituirão as alterações do outro usuário. Se você editar colunas diferentes, suas alterações serão mescladas com as alterações do outro usuário.

  • Para resolver todos os conflitos e erros pendentes, aplicando novamente suas alterações, clique em Repetir Todas as Minhas Alterações.

  • Para exibir os detalhes do próximo conflito ou erro, clique em Próximo no canto superior direito da caixa de diálogo.

  • Para exibir os detalhes do conflito ou erro anterior, clique em Anterior no canto superior direito da caixa de diálogo.

  • Para resolver conflitos e erros posteriormente, clique em Fechar na barra de título da caixa de diálogo.

Anotações

  • A grade de detalhes mostra todas as colunas no seu visualização atual. Se as colunas não estão visíveis, use a barra de rolagem horizontal para rolar ou arraste a borda direita da caixa de diálogo para aumentar a largura da grade de detalhes.

    Para ampliar o conteúdo de uma coluna, clique na coluna na grade de detalhes. Suas alterações e as alterações do outro usuário serão exibidas na caixa de diálogo Detalhes do Campo. A caixa de diálogo também é útil para exibir alterações de formatação de texto rich.

  • A grade de detalhes exibe a linha Excluída, em vez de uma linha de dados, se você ou o outro usuário excluir uma linha. Se o outro usuário excluir a linha, a caixa de diálogo não exibirá o nome do usuário ou a data e a hora da exclusão. Além disso, você não poderá repetir suas alterações.

Definir a opção de armazenamento em cache de tabelas do serviço da Web e do SharePoint

A configuração padrão para novos bancos de dados do Access 2010 e versões posteriores é armazenar em cache as tabelas vinculadas a serviços da Web e ao SharePoint. Se você quiser alterar esse comportamento e, em vez disso, usar o comportamento existente no Access 2007, clique em Opções de arquivo > para abrir a caixa de diálogo Opções de Acesso. Clique em Banco de Dados Atual para ver as configurações listadas em Cache web Service e tabelas do SharePoint.

  • Usar o formato de cache compatível com o Microsoft Access 2010 e posterior Selecione essa opção para que o Access armazene em cache uma cópia local dos dados vinculados. Essa configuração pode melhorar o desempenho ao trabalhar com dados vinculados. Carregar e visualizar dados vinculados será mais rápido com o uso dessa opção. Desmarque essa opção se quiser usar o comportamento de armazenamento em cache que existia no Access 2007.

  • Limpar cache ao fechar Selecione essa opção para que o Access limpe todos os dados locais armazenados em cache quando você fechar seu banco de dados.

  • Nunca armazenar em cache Selecione essa opção para que o Access não armazene em cache uma cópia local dos dados enquanto estiver trabalhando com suas fontes de dados vinculadas do SharePoint.

    Observação: As opções Limpar cache ao fechar e Nunca armazenar em cache não estarão disponíveis se você desmarcar a configuração Usar o formato de cache compatível com o Microsoft Access 2010 e versões posteriores.

Posso trabalhar offline manualmente no Access 2010 e superior?

Para ter o controle manual de trabalhar offline com dados vinculados do SharePoint no Access 2010 ou posteriores, você precisará limpar a configuração Usar o formato de cache compatível com o Microsoft Access 2010 e posterior para o banco de dados atual encontrado na caixa de diálogo Opções do Access. Consulte a seção anterior sobre como encontrar e definir essa opção.

Observação: Você pode ser solicitado a fechar e rea abrir seu banco de dados após alterar a configuração.

Depois de limpar a configuração Usar o formato de cache compatível com o Microsoft Access 2010 e posterior, você verá um grupo de comandos listas vinculadas da Web aparecer na guia Dados Externos.

Neste grupo, você verá comandos como Work Offline,Synchronize,Relink Lists e outros. Esses são os mesmos comandos que estavam no Access 2007 no grupo Listas do SharePoint na guia Dados Externos.

Para trabalhar offline com seus dados de lista do SharePoint neste modo, clique em Trabalhar Offline.

Para sincronizar suas listas offline com dados do servidor, clique em Sincronizar.

Para reconectar as tabelas vinculadas depois de trabalhar offline, clique em Trabalhar Online.

Início da página

Usando o Access 2007?

Para executar este procedimento, primeiro você deve vincular suas tabelas do Access às listas do SharePoint.

Observação: Se você tiver um banco de dados que já tenha sido publicado em um site do SharePoint, primeiro salve uma cópia local do banco de dados e, em seguida, mantenha as listas offline.

  1. Abra o banco de dados vinculado às listas do SharePoint.

  2. Na guia Dados Externos, no grupo Listas do SharePoint, clique em Trabalhar Offline.

Observação: Se o botão Trabalhar Offline não estiver disponível, suas tabelas não serão vinculadas às listas do SharePoint ou você já tenha offline os dados da lista.

  1. Abra o banco de dados vinculado às listas do SharePoint.

  2. Na guia Dados Externos, no grupo Listas do SharePoint, clique em Sincronizar.

Se ocorrer um conflito sobre uma alteração que você fez offline e uma alteração que alguém fez no servidor, a caixa de diálogo Resolver Conflitos será exibida.

A caixa de diálogo exibe informações sobre o conflito, como o motivo do erro, e fornece opções para você tentar enviar os dados novamente ou descartar suas alterações. Se houver vários erros, você poderá exibir os detalhes de cada erro clicando nos botões Anterior e Próximo na caixa de diálogo. Alguns erros só podem ser resolvidos descartando suas alterações.

A grade de detalhes na caixa de diálogo Resolver Erros exibe todas as colunas no seu exibição atual. Para a linha afetada, a grade de detalhes mostra a alteração que você fez. Você não pode editar os valores, mas pode clicar em cada coluna para ver mais detalhes.

  • Na caixa de diálogo Resolver Erros, faça um dos seguintes:

    • Se você quiser manter as alterações feitas no servidor para um item selecionado, clique em Descartar Minhas Alterações.

    • Se você quiser tentar enviar suas alterações novamente para um item selecionado, clique em Repetir Minhas Alterações.

      Dependendo da situação, talvez seja necessário aguardar até que o problema seja resolvido. Por exemplo, se você não puder sincronizar suas alterações devido a um problema de conectividade de rede, aguarde até que esteja conectado novamente.

    • Se você quiser manter as alterações feitas no servidor para todos os itens, clique em Descartar Todas as Minhas Alterações.

    • Se você quiser tentar enviar suas alterações novamente para todos os itens, clique em Repetir Todas as Minhas Alterações.

      Dependendo da situação, talvez seja necessário aguardar até que o problema seja resolvido. Por exemplo, se você não puder sincronizar suas alterações devido a um problema de conectividade de rede, aguarde até que esteja conectado novamente.

      Observações: 

      • Se o erro puder ser resolvido apenas descartando suas alterações, os botões para repetir suas alterações podem não estar disponíveis.

      • Você pode fechar a caixa de diálogo sem tomar nenhuma ação, mas não poderá sair ou atualizar a lista ou fazer alterações em uma coluna calculada até resolver o erro.

Depois de reconectar as tabelas vinculadas, todas as alterações feitas aos dados ou objetos serão sincronizadas.

  1. Abra o banco de dados vinculado às listas do SharePoint.

  2. Na guia Dados Externos, no grupo Listas do SharePoint, clique em Trabalhar Online.

    Observação: Se você quiser descartar as alterações feitas offline, clique em Descartar Alterações no grupo Listas do SharePoint.

Início da página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×